New Firmware 7.0.2 For Apple TV 3rd Gen.

Discussion in 'Apple TV and Home Theater' started by Harry Muff, Nov 17, 2014.

  1. Harry Muff macrumors regular

    Joined:
    Oct 8, 2014
    #1
    Apparently, there's an update out today, but my ATV 3 is saying it can't be downloaded at this time.

    Has anyone been successful?


    And will it stop us from being able to add profiles and use Plex?
     
  2. Harry Muff thread starter macrumors regular

    Joined:
    Oct 8, 2014
    #2
    Turns out I forgot to set the DNS back to Manual for the update. Silly me...

    Ok, so I took the plunge and updated.


    It's good news and good news so far.


    Plex Media Server works the same as before and...



    Devices wake up the Apple TV now!


    I was getting sick of having to find the ATV remote to switch it on before streaming to it. Now it starts automatically again. Finally!


    Update at your leisure, peeps.
     
  3. nbuckley macrumors newbie

    Joined:
    Jul 10, 2008
    #3
    7.0.2 AppleTV 3rd Gen and ethernet

    Does anyone know if the 7.0.2 AppleTV 3rd Gen firmware update fixed the problems I read the past firmware was having with ethernet connections?

    Thanks!
     
  4. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
  5. 9512tacoma macrumors member

    Joined:
    Aug 28, 2013
    #5
    My home sharing still does not work with win 7 itunes via Ethernet
     
  6. KiwiAdventure macrumors 6502a

    Joined:
    Dec 7, 2010
    Location:
    New Zealand
    #6
    Todays update has fixed my problem with airplay and peer to peer not working on my new Apple TV. It now works 100% on all my Apple products.:cool:
     
  7. oneMadRssn macrumors 68040

    oneMadRssn

    Joined:
    Sep 8, 2011
    Location:
    Boston, MA
    #7
    Sounds like this is a good update. The only thing holding me back is the laziness of having to log back into ABC, History, and all the other apps that require re-authorization after each restart.
     
  8. sodapop1 Suspended

    sodapop1

    Joined:
    Sep 7, 2014
    #8
    That is ridiculous, some channels have absolutely no regard for user experience.
     
  9. michaelruggeri macrumors newbie

    Joined:
    Feb 24, 2009
    #9
    Air play fixed with new update

    I am happy to say that all the bugs in Air Play have been fixed with the new update on my system.
     
  10. kevo1011 macrumors regular

    Joined:
    Oct 3, 2010
    #10
    Agreed. Mine hasn't worked correctly since my upgrade to win7. I have two atv3's and neither work 100%. I am tired of restarting iTunes & re-enables home sharing. I wish they would fix it.
     
  11. Che Castro macrumors 603

    Joined:
    May 21, 2009
  12. orbital~debris macrumors 6502a

    orbital~debris

    Joined:
    Mar 3, 2004
    Location:
    England, UK, Europe
    #12
    that's fantastic news! Looking forward to installing this and getting stable AirPlay performance.
     
  13. kelub macrumors regular

    Joined:
    Jun 15, 2010
    #13
    That's odd. I've been running a Windows 7 home media server with iTunes for a while now without any significant problems. Wasn't aware there was a known issue between the two.

    I'm also glad to hear the update fixes airplay. It's been flaky for a bit.
     
  14. Crazy Badger macrumors 65816

    Crazy Badger

    Joined:
    Apr 1, 2008
    Location:
    Scotland
    #14
    I'm assuming your using plexconnect in some guise? Did you have to reinstall the certs and/or hijack an app? Which one are you using?

    Sorry for all the questions, but when everything is working I'm reluctant to update although it sounds like a few annoying bugs have been fixed so probably worthwhile if it's not a big job to set back up.
     
  15. cardsdoc macrumors 6502

    Joined:
    Jun 9, 2007
    Location:
    Shaker Hts, OH
    #15
    You do not have to touch the plexconnect install. Just change DNS to auto for update and back to manual afterwards. All works fine for me. Using trailers app. Was using imovie app on 6.x but that no longer works after 7.0 update.
     
  16. Crazy Badger macrumors 65816

    Crazy Badger

    Joined:
    Apr 1, 2008
    Location:
    Scotland
    #16
    Thanks for the quick reply! I'm using openPlex 0.3.5 to manage plexconnect and have hijacked the WSJ app so it even has a Plex icon :D

    Will check the Plex forums to see how other are getting on before talking the plunge as i don't want to update and find Apple have plugged some holes :cool:
     
  17. jmcgeejr macrumors 6502

    jmcgeejr

    Joined:
    Oct 7, 2010
    Location:
    Seattle, WA
    #17
    imovie does work, they fixed that a few weeks after 7 came out. I have been using it for months with no issues.
     
  18. cardsdoc macrumors 6502

    Joined:
    Jun 9, 2007
    Location:
    Shaker Hts, OH
    #18
    Oh nice. Will switch back then. Thanks.
     
  19. DJTaurus macrumors 65816

    DJTaurus

    Joined:
    Jan 31, 2012
    #19
    Home Sharing works for the last 2 days without problems after the latest update.... fingers crossed :cool::apple:
     
  20. Jovian9 macrumors 68000

    Jovian9

    Joined:
    Feb 19, 2003
    Location:
    Planet Zebes
    #20
    Opposite for me. After this update one of my :apple:TV 3's quit with home sharing. I restored it and everything and it just will not connect to my network. The other :apple:TV3 that hasn't updated connects fine. All other devices (iPads, iPhones, etc.) connect just fine.

    If I turn off home sharing on it, restart it, turn it back on, and try to connect it will fail after about 5 minutes. After that it will not even recognize their is a home sharing network in the house, forcing me to turn off and reset again to try and get it to connect. I've restarted home sharing on my iMac, restarted my iMac, etc.


    Of all the updates on all my devices the :apple:TV ones are the ones I worry about most. It seems that every other update causes me home sharing issues on at least one of my :apple:TVs
     
  21. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #21
    I've never had any issues with home sharing with any update. It might be your network/router.
     
  22. Jovian9 macrumors 68000

    Jovian9

    Joined:
    Feb 19, 2003
    Location:
    Planet Zebes
    #22
    I have used nothing but Airport Extremes/Time Capsules for years. My internet is solid at 55 down/12 up. Every device (not just Apple) on my network works fine. The only change was the update this week to one of them.
     
  23. DJTaurus macrumors 65816

    DJTaurus

    Joined:
    Jan 31, 2012
    #23
    1)Try to also reboot your modem/router :)
    2)Also go to Mac->Settings->Privacy and change your Mac's name
    3)Settings->Network->Advanced->Check change names
    4)Settings->Energy Saver->Uncheck Wake for wifi access
    5)Quit itunes and reboot Mac
     
  24. Frankied22 macrumors 68000

    Frankied22

    Joined:
    Nov 24, 2010
    #24
    Did this update fix AirPlay issues? When I had an ATV 3rd gen the AirPlay would never work. It would always cut out and I have an AirPort Extreme with 60mbp internet.
     
  25. mattopotamus macrumors G5

    mattopotamus

    Joined:
    Jun 12, 2012
    #25
    it sound like everyone above your post has mentioned it fixing airplay issues.
     

Share This Page