New MacBook Pro - MagSafe connector Led problem!

Discussion in 'MacBook Pro' started by eStatic, Apr 13, 2008.

  1. eStatic macrumors newbie

    Joined:
    Apr 12, 2008
    #1
    Hi,

    I just bought my first mac ever and I don't understand one thing. The light on the MagSafe connector should be always on? Either amber or green, right? That's what I thoguht but the led on mine turns off after a random time... is this normal? Otherwise the charging works ok...
     
  2. dannyeaston macrumors newbie

    Joined:
    Apr 11, 2008
    Location:
    London
    #2
    A few people have posted about this - but I've not seen an answer.

    You're right though - it should be on all the time. Red when charging, green when charged.
     
  3. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #3
    Is it really red? I always thought it was orange...

    but anyways, go to the applestore or service provider and show it to them. they should replace it.
     
  4. kgeier82 macrumors 65816

    Joined:
    Feb 18, 2008
    #4
    same thing with me. Apple sent me a replacement. I plugged it in, IT POPPED and died.

    im getting a 3rd tomorrow IN STORE.

    the original has been behaving fine all weekend, its a shame i cant keep it now. but APPLE has to have it back.
     
  5. dannyeaston macrumors newbie

    Joined:
    Apr 11, 2008
    Location:
    London
    #5
    I'm colourblind so maybe it is orange.
     
  6. eStatic thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #6
    I really hope the problem is not from the MBP... :(
     
  7. GSMiller macrumors 68000

    GSMiller

    Joined:
    Dec 2, 2006
    Location:
    Kentucky
    #7
    The one on my MacBook does the same thing. I asked my friend if hers done it, but of course she never pays attention. It usually only does it when I'm using the MacBook while it's charging, and when the light is off I don't believe it's charging, so if it does disconnect and reconnect it to the notebook.
     
  8. jdwingnut macrumors regular

    Joined:
    Feb 18, 2008
    Location:
    In the Redwoods, California
    #8
    Your MBP is defective. Ask Apple to replace it.

    Mine did this to me almost immediately out of the box. At first the charge light would come on, then go out within a minute. It would work fine if I unplugged and replugged it 2 or 3 times, but this is not how it's suppose to work. After watching this behavior, I also noticed when it did this, the MBP was not charging. Not good. When I plug the magsafe charger into the laptop, I was expecting it to charge, every time. This was not happening.

    After a couple of calls to Apple, the service rep I've been working with decided it was best to just replace it. This was my 3rd replacement for a variety of reasons. I'm presently on my 4th MBP.

    Not sure what Apple's doing these days to assure quality components, but this seems crazy. I'll be purchasing Applecare for this one, just as I did for my now replaced Powerbook. Money well spent, in my opinion.
     
  9. cwalex18 Guest

    Joined:
    Feb 19, 2008
    Location:
    United States
    #9
    My MBP does the same thing, but not all the time. I notice that my charger light never goes out when it is orange (charging), but it will sometimes go out when it is green (charged) at random times. I have two power adapters, and this happens with both of them. I am using a 15" 2.4 ghz SR MBP by the way. I have never had a problem with my adapter not charging my computer. If your adapter charges your computer fine, I would not worry too much over it.
     
  10. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #10
    I've noticed this happen to mine - no problem or anything affected.

    Just the LED goes out.
     
  11. eStatic thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #11
    I just noticed that the led doesn't completely turn off, it just gets very faint...
     
  12. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #12
    in my case it was not the MBP's problem. Purely the charger. Same thing with a faint green light. However this intermittent charging killed my battery at 68 cycles (34% health). Got both replaced under warranty. After that, no problems.

    Tried with a known working adapter and it was okay. What i believe the cause to be is the twisting of the wire inside the insulation after repeated wrapping around the "ears" of the charger very tightly. Try to leave some slack at the base where the wire comes out. I've seen too many times where people pull it tight right from the start. That is a big no-no. And also, when you unravel it, make sure its not twisted. It puts a lot of strain on the internal wires. On my old charger if i moved the wire around while it was charging the light would turn off.

    oh the other day at work i saw for the first time a burnt magsafe adapter at the magnetic end.
     
  13. bov macrumors 6502

    Joined:
    Aug 21, 2007
    Location:
    San Francisco
    #13
    if my MBP is done charging and the light is green, and i proceed to turn my computer off, the LED always goes off. i dont know if this is normal but it always does this.:confused:

    doesnt seem to have any negative effects so far so i guess its ok
     
  14. bobbleheadbob macrumors 6502a

    bobbleheadbob

    Joined:
    Feb 6, 2007
    Location:
    Massachusetts
    #14
    I've noticed this with my new MBP (17" penryn). It never happened with my previous on (15" from Nov. 2006). I didn't really think anything of it until I read this thread. I'm gonna go plug in and take a closer look at it now. :confused:
     
  15. cwalex18 Guest

    Joined:
    Feb 19, 2008
    Location:
    United States
    #15
    Same with me, but as I said in my previous post, is this really something to lose sleep over? As long as your adapter works and charges your computer, I would not worry about this.
     
  16. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #16
    me too... still charges though
     
  17. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #17
    me too... light goes out sometimes after it's charged unplug and plug in it works. Never had any problems not charging.
     
  18. eStatic thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #18
    Yes, the charging works ok. But there were a few times when I wanted a full charge but I also closed my notebook... and because the light was off I couldn't tell when the notebook was fully charged.
     
  19. eStatic thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #19
    :( I just tried another adapter, which I'm sure it is working and it did the same thing... So the problem might be from the MBP. :(
     
  20. kinglau macrumors newbie

    Joined:
    Apr 14, 2008
    #20
    I am wondering would the LED light intensity on connector represents the % of battery charging? Sometimes I found the green was dimmer with only 5x% remaining battery life. After charging awhile, the LED green light glows brighter. Can any confirm that?
     
  21. beano1947 macrumors newbie

    Joined:
    Apr 15, 2008
    #21
    Magsafe Overload

    I now own 3 MBP's. My latest 17" has an overload problem.
    If the battery is run down and the Magsafe plugged in, the LED goes out and the charger shuts down. All 3 Magsafe's do it when plugged into the 17"MBP The only way to stop it is to turn down the brightness of the screen until the battery is sufficiently charged.
    Looks like the current demand is more than the Magsafe can supply......:mad:
     
  22. mikey.f macrumors regular

    Joined:
    Aug 18, 2006
    Location:
    Slovakia
    #22
    Mine doesn't turn off, and I have kind of an opposite problem. Whenever I plug the adaptor from the electricity, the LED stays on for a few seconds and then dims out. Not that I would be crazy about it, but I thought I would mention it to see if anyone else's doing that, too.
     
  23. jjahshik32 macrumors 603

    Joined:
    Sep 4, 2006
    #23
    I have this problem as well it stays green then it turns off but then if I unplug it and then plug it right back in, the light goes to green once more.. long as it still charges.
     
  24. steve31 macrumors 6502a

    steve31

    Joined:
    Jul 20, 2007
    Location:
    Edmonton Canada
    #24
    I also have the same problem with my MBP 2.5. I have tried 2 different plugs that I have and it does it with both. Most of the time I just unplug it a few times and everything works fine. Glad I have apple care!!;)
     
  25. SolRayz macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #25
    I can confirm that my SR MBP 2.4 does the same but somewhat rarely and randomly. From my recollection it usually dims in the green after having been asleep for sometime...but this does not happen all the time. I unplug the magsafe and then plug it back in and the led returns to normal brightness. Very odd. I haven't really noticed any issues, but surely if this were a problem we would have heard something from Apple by now, no?
     

Share This Page