"New Message Notification" Not Working

Texas_Toast

macrumors 6502a
Original poster
Feb 6, 2016
933
73
Texas
I am no longer getting an icon showing that I have new responses to one of my threads.

That is really a problem.

Yesterday people had responded right away, and the only way I new is I had inadvertantly refreshed my browsers and I saw new posts in my thread, but still no message notification.

Hope this can be fixed!!!
 

Texas_Toast

macrumors 6502a
Original poster
Feb 6, 2016
933
73
Texas
Which icon are you talking about? The top right one?
I haven't been here for a while, so I forget, but I think either the envelope or the bell turned red when you had a reply to one of your threads...

Also, there was a notification when you got PM's - one of those two icons.
 

Texas_Toast

macrumors 6502a
Original poster
Feb 6, 2016
933
73
Texas
I replied earlier that you might have missed. It got merged. Can you check your https://forums.macrumors.com/account/preferences
Okay so MacRumors changed the UI somewhat.

Why were my message/post alerts not working?

And why, ironically, now that I complained about this, are things apaprently now working again?

I got a red bell when you replied above, yet haven't gotten any such notifications in the last few days....
 

JayMysterio

macrumors 6502a
Apr 24, 2010
888
15,399
Rock Ridge, California
Which icon are you talking about? The top right one?
- - Post merged: - -

also make sure you didn't accidentally change anything on your preferences:


Specifically the notification preferences near the bottom
I realize it isn't the same thing, but I've noticed that notifications don't seem to be working when someone responds to you after they've posted a message. Meaning if a person posts a message, then edits that message adding a response to you, it doesn't seem to trigger a notification.

I've come across threads that I hadn't gone back to in awhile only to see responses directed to me. If the response has an edited/merged notification, it didn't show up in the sidebar. It seems to be happening regularly.
 
  • Like
Reactions: Texas_Toast

annk

Administrator
Staff member
Apr 18, 2004
13,733
4,710
Somewhere over the rainbow
I realize it isn't the same thing, but I've noticed that notifications don't seem to be working when someone responds to you after they've posted a message. Meaning if a person posts a message, then edits that message adding a response to you, it doesn't seem to trigger a notification.

I've come across threads that I hadn't gone back to in awhile only to see responses directed to me. If the response has an edited/merged notification, it didn't show up in the sidebar. It seems to be happening regularly.
I'm answering you before I check with anyone, but I believe you're right. I seem to remember that as well. It's been like that since we went to XF, if I remember correctly.

@Weaselboy you've got a great memory about this stuff, are we right?
 
  • Like
Reactions: JayMysterio

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,773
9,403
California
I'm answering you before I check with anyone, but I believe you're right. I seem to remember that as well. It's been like that since we went to XF, if I remember correctly.

@Weaselboy you've got a great memory about this stuff, are we right?
Correct... you only get an alert if there is a new reply. An edit or merge of an existing reply does not generate an alert. It is a shortcoming of the XenForo software.