No "auto unlock with Apple Watch" option

Discussion in 'macOS Sierra (10.12)' started by oftheheavens, Jul 5, 2016.

  1. oftheheavens macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #1
    So I got everything running the latest betas, set up the 2 step verification, but there is no check box option in security and privacy to allow my watch to unlock my late 2013 iMac. I have verified that my watch, phone and iPad are all trusted devices and they show up in my apple account but still, no option to use my watch to unlock my iMac. Any ideas?
     
  2. Alonso Quijano macrumors 6502

    Joined:
    Jul 17, 2013
    #2
    Backup Watch to iCloud, unpair, restore. Then it should appear there :)
     
  3. tywebb13 macrumors 68020

    Joined:
    Apr 21, 2012
    #3
    You shouldn't have two-step verification.

    You need two-factor authentication.

    They are not the same thing.

    auto-unlock.png
     
  4. Lotti macrumors member

    Joined:
    Oct 28, 2006
    #4
    Thanks for those instructions, didn't work however.

    Wierd thing is initially I had the checkbox and tried enabling it a few times. Once I'd migrated to two-factor auth (from two-step) it seemed to disappear and now I can't get it back.

    Hmmm.
     
  5. oftheheavens thread starter macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #5
    Awesome, I had the wrong 2 step (good thing I'm not in Texas!)

    Thanks for your help
    --- Post Merged, Jul 5, 2016 ---
    Well got all this crap set up and the box checked but it still requires my password to wake from sleep. Doesn't even recognize that I have my watch on
    --- Post Merged, Jul 5, 2016 ---
    I got the check box now, but it doesn't unlock using my watch... Still asks for password
     
  6. tywebb13 macrumors 68020

    Joined:
    Apr 21, 2012
    #6
    As well as the instructions I posted earlier, I suggest you also look at this youtube video:

     
  7. oftheheavens thread starter macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #7
    Watched twice. I also just restarted my watch and when it came back up I had lost my watch face. Thinking I may have just needed to restart my watch after upgrading to beta 2. Gonna give it another try now and report back once more before giving up and going to bed.
     
  8. Loismustdie1 macrumors member

    Loismustdie1

    Joined:
    Jun 6, 2015
    #8
    I have an early 2013 MacBook Pro and I don't even see the option. I'm going to be really irritated if they restrict this to the mid 2013 models and forward. There is no reason why this function couldn't have worked on all of the Retina models.
     
  9. oftheheavens thread starter macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #9
    Well put it to sleep and it still came back up with wanting a password. I guess I will chalk it up to beta issues and move on...
    --- Post Merged, Jul 5, 2016 ---
    Make sure you have the correct two step thingy-ma-jig. I used the wrong one at first and after following the instructions above the box showed up. Still doesn't work but at least the box is there.
     
  10. Loismustdie1 macrumors member

    Loismustdie1

    Joined:
    Jun 6, 2015
    #10
    I made sure to have two factor authentication on but no avail. I think I know Apple well enough by now to see the handwriting on the wall *sigh*
     
  11. tywebb13 macrumors 68020

    Joined:
    Apr 21, 2012
    #11
    You mean the two FACTOR thingy-ma-jig, yeah?
     
  12. Binarymix macrumors 6502a

    Joined:
    Nov 1, 2007
    #12
    My Late (and by late I mean December) 2012 iMac doesn't support this feature and there is no technical reason why it can't. It has bluetooth 4.0.

    This is complete BS.
     
  13. iTom17 macrumors 6502a

    iTom17

    Joined:
    Aug 2, 2013
    Location:
    the Netherlands
    #13
    Same thing here.

    Mac keeps asking for password, but it does search to the Watch. Have restarted my iPhone, Mac and Apple Watch a few times already. Very strange, as it should be able to work considering the video from 9to5Mac.
     
  14. oftheheavens thread starter macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #14
    Not only that, but every time I restart my watch trying to get it to work with the computer, my watch face changes lol. Oh well I know we are rollin betas so not upset just frustrated it works with some and not with others.
     
  15. iToph macrumors regular

    Joined:
    Oct 23, 2014
    #15
    A clean install of Sierra fixed it for me. Now it works like a charm :):apple:
     
  16. oftheheavens thread starter macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #16
    Quite a bit of work to do that though right? I skipped the first beta of Sierra and installed only yesterday after b2 was released.
     
  17. bluechair1984 macrumors regular

    Joined:
    Jul 7, 2010
    #17
    Someone said in another thread it worked on their 2012 rMBP. I'm hoping that is true. Otherwise we'll have to wait for a hack.
     
  18. Futhark macrumors 65816

    Futhark

    Joined:
    Jun 12, 2011
    Location:
    Northern Ireland
    #18
    MBP Retina 15" Early 2013 and no option appears for me to unlock with Apple Watch and I have everything setup correctly
     
  19. iTom17, Jul 6, 2016
    Last edited: Jul 6, 2016

    iTom17 macrumors 6502a

    iTom17

    Joined:
    Aug 2, 2013
    Location:
    the Netherlands
    #19
    I've just been at Apple Developer Forums and read that someone got it working after doing a clean install of macOS. Might be the best possible workaround at this point. I'm thinking about doing this, unfortunately it's so much hassle for just one feature...
     
  20. Donga120 macrumors 6502

    Donga120

    Joined:
    Sep 19, 2014
    Location:
    Derby
    #20
    Agreed. Can't be bothered with this.. would be useful for me however.
     
  21. KrisLord macrumors 6502a

    Joined:
    Sep 12, 2008
    Location:
    Northumberland, UK
    #21
    It showed up for me, failed to enable them disappeared :(

    It's now returned and is working. Not exactly sure what changed but I went through the steps provided in the screenshot at the start of the thread (checking iCloud settings on Mac, iPhone and iPhone watch app) all were already correct but the tick box appeared after I went through them all.
     
  22. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #22
    Today may be the only day I'll have plenty of time to do this. I don't see it taking over an hour but just for S&G's I'll time it and post back later.
     
  23. marklemac macrumors regular

    marklemac

    Joined:
    Oct 21, 2003
    Location:
    Southampton, UK.
    #23
    Can't get mine to work either. TFA is turned on on watch, 6s and 2015 MBP Retina.

    All updated. I see the turn on feature in the security pane.

    Nothing happens when I come out of sleep on the MBP.
     
  24. iTom17, Jul 6, 2016
    Last edited: Jul 6, 2016

    iTom17 macrumors 6502a

    iTom17

    Joined:
    Aug 2, 2013
    Location:
    the Netherlands
    #24
    So this is what I'm seeing when trying to enable Auto Unlock, not sure if anyone else had this?? Anyway, I'm not getting any code to see on my watch... But the window does go away after 10 seconds or so.

    Schermafbeelding 2016-07-06 om 15.29.44.png

    Excuse me for the language by the way, it is Dutch. Basically says:

    "Link request from: Apple Watch of Tom

    Enter passcode that is displayed on the external Bluetooth device."

    Again, not receiving any code. Even more strange, earlier today after doing this it didn't do anything. But then, after a minute or two a new window showed up out of nowhere with a code. This is just really weird. Hope that there'll be a quick fix or Apple at least releases a new beta next week or so... xD

    ------

    EDIT: So guys, I finally got it working! Had to sign out of iCloud and then log back in.

    Made a short video:

     
  25. oftheheavens thread starter macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #25
    Glad you got it working and thanks for posting the video for all of us. I have tried logging in and out of iCloud to no prevail. I have all but given up on this working until next beta. Beta 2 on the watch isn't behaving very well anyways.

    EDIT: wow after actually watching the video it works rather fast and makes me really want mine to work... I am flying out for work tomorrow morning though and simply don't have time to try and do a full fresh install of Sierra. Maybe I need to unpaid and repair my watch... /frustrated
     

Share This Page