"No Batteries Available" Mid-2010

Discussion in 'MacBook Pro' started by Toomin, Aug 20, 2011.

  1. Toomin macrumors newbie

    Joined:
    Aug 20, 2011
    #1
    Hi all, I've been having an interesting issue with my 2010 Macbook Pro. A few days ago, I found that the system no longer recognized that the battery existed, and further digging in System Information revealed this:

    Battery Information:

    Charge Information:
    Charge Remaining (mAh): 0
    Fully Charged: No
    Charging: No
    Full Charge Capacity (mAh): 0
    Health Information:
    Cycle Count: 0
    Battery Installed: No
    Amperage (mA): 0
    Voltage (mV): 0

    The system will not boot and will shut down immediately if unplugged. I'm out of warranty, but had the battery replaced today. Still no luck. I have reset the SMC and tried cleaning the contacts to no avail. Further hardware tests say that there is likely nothing wrong with the logic board, and here's the interesting bit. If I unplug the system while it's booting up, the system will boot and run off the battery just fine, though the System Information and menu bar icon still say that there is no battery, and obviously won't show me my current charge. If I put it to sleep while it is running like this, it shuts down and won't turn back until it's plugged in again.

    I think I've exhausted my options, but do any of you guys have any offhand suggestions? Thanks.
     
  2. MarocSpecops macrumors newbie

    MarocSpecops

    Joined:
    Aug 17, 2011
  3. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #3
    Is that info while it's plugged in or running off battery? Also, while you are running off battery and press the battery status button, what do the LEDs show?

    Another question: have you tried a different power adapter? For instance, was there any different behavior at the Apple Store (or where you had the battery replaced)?
     
  4. Toomin, Aug 21, 2011
    Last edited: Aug 21, 2011

    Toomin thread starter macrumors newbie

    Joined:
    Aug 20, 2011
    #4
    That is the info both plugged in and unplugged. The battery status button continues to show no LEDs at all (in both cases), and I have tried multiple power adapters. What's more, even if I trick it into running off the battery (as I mentioned in the OP), once the system has been plugged back in, it will instantly shut off if I remove the power adapter.

    Not exactly making this one easy, huh? I guess my follow-up question would be: is there a hardware trigger that the system uses to determine if a battery is present? If so, how can I find it?
     
  5. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #5
    One question I forgot to ask is what the MagSafe connector LED was showing. Does it go orange or stay green?

    It can stay green even if there's no battery recognized.

    There could be a problem with the internal battery cable. It's a bit strange, though, since the cable would have to be removed and reconnected with the new battery. If it's not the cable/connector at the logic board, it might be the main logic board itself (since you already replaced the battery with a known good one).

    The only "trigger" I know of is resetting the SMC.

    Verify you are resetting the SMC with the following procedure:
    1. If computer is on, turn it off by choosing Shut Down from the Apple () menu.
    2. Connect power adapter to computer and to a working power source.
    3. On built-in keyboard, press (left-side) Shift-Control-Option along with power button just once. Important: Use Shift-Control-Option keys on left side of keyboard.
    Note: When the LED on the MagSafe connector is orange/amber, resetting the SMC will change it to green for a few seconds, indicating that SMC was correctly reset.
    4. Wait 5 seconds and press power button to start computer. Note: If bottom case is removed, you can alternately reset SMC by disconnecting both power adapter and main battery, and holding down power button for 5 seconds.​
     
  6. Toomin thread starter macrumors newbie

    Joined:
    Aug 20, 2011
    #6
    The LED is always green when plugged in, no matter what. As you say, I doubt that it's the cable, since that was replaced with the new battery. As I've mentioned, I have reset the SMC more than once, so I doubt there's anything there either.

    I've already accepted that it is likely the logic board, but it bothers me that the system is clearly still able to draw power from the battery so long as it doesn't know it's doing it. The connections are fine, but the system just doesn't realize it.

    Thanks for everyone's help so far.
     
  7. Oublier macrumors newbie

    Joined:
    Dec 14, 2011
    #7
    Well, this just happened to me on my 2011 MPB i7 13". I use it to primarily do Ruby and RoR development.

    I was in a meeting getting ready to do a presentation. I'm about to plug in the projector cable and BAM, the book shuts off. I was on battery with a slightly less than full charge at the time.

    So I plug in the power adapter and get no light, but it did power up; however the fan on the system was blowing constantly. Also, I got the "no battery available indicator". So I shut down and unplugged, cancelled the meeting and walked over to my desk. At that point, out of curiosity, I powered it back up ,unplugged, and it came on. The fan started running again and I still get the "no battery available" indicator even though I'm obviously running on battery.

    I found this forum post and ran the SMC reset, as mentioned above, and I'm seemingly all good now. I wonder for how long?

    Overall an embarrassing experience. The reason I bought this product was for the stability and quality of the hardware. Now I'm thinking I may have made the wrong choice... We shall see.

    Oublier
     
  8. ryannazaretian macrumors 6502a

    ryannazaretian

    Joined:
    Sep 21, 2008
    Location:
    Mississippi
    #8
    SMC reset should fix the issue obviously...

    Are you pressing Command+Option+Control+Shift, then hitting the power button while holding all 4 buttons?

    To verify that the SMC resets, start your computer. Ensure nothing is running or installing, as this method will do a hard shutdown, meaning that your basically removing the power from the computer. Make sure to back up your computer before this, as you're putting it in an unexpected shutdown situation.

    Try the SMC reset now. The computer should just shut off, and the indicator in the front should turn off. Wait a few seconds, and boot the computer back up.

    Maybe it will work? Hopefully you were just doing the SMC reset wrong? Very weird issue for sure.
     

Share This Page