'No bootable device' - bootcamp windows 7 MBP lion problems

Discussion in 'Windows, Linux & Others on the Mac' started by soldado, Aug 28, 2013.

  1. soldado macrumors newbie

    Joined:
    Aug 28, 2013
    #1
    Hey,

    It seems so many people have had this problem which I am having now, I've tried searching for a solution that works but to no avail. So I'll give as much detail to this problem in the hope that someone knows the answer!

    When running bootcamp assistant in order to install Windows 7 on my MacBook Pro (running Lion), I am able to go through all the steps - create USB installer, download software and partition hard drive. However, when the computer restarts I am faced with the black screen displaying "No bootable device - insert disk and press any key to continue". Nothing seems to work!

    I've tried using a DVD instead of a usb to install Windows, using a burned copy of the ISO disk image (in UDF format) of Windows and I've tried using a sony and a san disk USB. I've tried holding down the option key on start up to see if I can select the disk manually but nothing appears (just my hard drive and the recovery mode).

    Any help would be really appreciated! I'm in need of windows in order to run some programs to carry out data analysis on endangered species for research.
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
  3. soldado thread starter macrumors newbie

    Joined:
    Aug 28, 2013
    #3
    Yes, if I hold down the option (alt) key I can see my hard drive as well as the recovery drive
     
  4. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #4
    If your Mac is recent (2011 or later), you'll need to use the optical drive to install Windows. Try burning the DVD in ISO 9660 format, rather than UDF.
     
  5. soldado thread starter macrumors newbie

    Joined:
    Aug 28, 2013
    #5
    Thank you I'll give it a try and let you know how it goes!
     
  6. soldado thread starter macrumors newbie

    Joined:
    Aug 28, 2013
    #6
    Sir/Mm you are a SAINT!!! That worked and everything has been set up, THANK YOU! I've spent the last 2 days running round in circles getting no where and now it's finally worked, I can't tell you how gratefull I am.

    To anyone else with the same problem TRY THIS!!!
     

Share This Page