MP 1,1-5,1 No display with MSI RX 560 Aero ITX? Help!

dalevis

macrumors newbie
Original poster
Aug 7, 2019
1
0
Upstate NY
Hi all, forgive me if this has been asked before - I was referred to ask you guys for help, and couldn't find anything on this issue with this specific card when I searched. I've been running a cMP 4,1 (flashed to 5,1) with an X5670 CPU, 32GB RAM, and an ASUS GTX 770 GPU on Mojave 10.14.5 with no problems. I also just recently upgraded my display to an LG 27UD58-B 4k monitor.

Just this week, I decided to switch to an RX 560, which to my understanding is a bit of a "downgrade" in terms of raw power. I don't really need the extra overhead of the GTX 770, though, and I could use the internal power ports for things like adding a powered USB-3 card and whatnot, especially since I don't feel like sacrificing a SATA port or doing that one PSU mod (Pixlas or something?). I'm not an experienced power user by any means (Google has been my best friend so far), but it seemed simple enough. Found a reasonably-priced like-new card on eBay, got it today. Installed it, plugged in the DP cable, went to boot up and...

Nothing. Obviously I didn't expect a boot screen, but it never went to the login menu and my monitor stayed on the "no signal" message. I tried rebooting, used HDMI instead of DP, even tried booting into recovery mode, nothing - no display, at all, whatsoever. Reinstalled my GTX 770 and everything worked as normal. Back to the RX 560, no signal again. The fans spin up on the RX 560 as if it's working normally so I know the card isn't just DOA, but I can't figure out what the issue is. I thought this card was compatible based on user testimony online and Apple's own support materials, but maybe I'm wrong? Is it a monitor setting? Something wrong with my MacOS settings? I'd appreciate any advice you guys can give me. Thanks!
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.