Not able to login to icloud account through system preferences -- iCloud

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by RAJESHWAR, Oct 26, 2018.

  1. RAJESHWAR macrumors newbie

    RAJESHWAR

    Joined:
    Oct 26, 2018
    Location:
    INDIA
    #1
    Hi friends,
    I need your support please help me to fix this issue. When I try to login to my iCloud account via , system preferences -> iCloud, it shows an error "** is already signed in to iCloud.
    To use this Apple ID as your primary iCloud account, delete it from Internet Accounts and sign in again."

    I don't know how to fix this issue. There is no issue with iCloud, since its working fine with my iMessage, App Store, iTunes.
     

    Attached Files:

  2. Shadow Jolteon macrumors regular

    Shadow Jolteon

    Joined:
    Feb 1, 2018
    Location:
    United States
    #2
    When you click on the Internet Accounts button shown in your screenshot (or go to System Preferences » Internet Accounts), do you see your iCloud account listed anywhere in the list? If so, select it then click the minus icon at the bottom left. It may take a minute to remove the data for the account from your computer. Once that completes, go back to the iCloud pane and try signing into iCloud there again.
     
  3. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #3
    Often, this can be resolved by opening Terminal and entering the following:
    Code:
    defaults delete MobileMeAccounts
    And then restart the computer.
     
  4. RAJESHWAR thread starter macrumors newbie

    RAJESHWAR

    Joined:
    Oct 26, 2018
    Location:
    INDIA
    #4

    That account is not listed in internet account list :(
    --- Post Merged, Oct 26, 2018 ---
    Thanks dude .. it worked. I wasted almost one day to figure this out. thanks once again
     

Share This Page

3 October 26, 2018