• Did you order new AirTags? We've opened a dedicated AirTags forum.

Enricote

macrumors member
Original poster
Oct 7, 2018
68
39
Madrid, Spain
Hi everyone.
I installed Opencore weeks ago to run Catalina in my cMP 5,1 (4,1). I am very grateful to all the people in that wiki. Opencore is a great advance.

I have read about both Bootcamp adaptations and VirtualBox (Using a Phisical Hard Drive with VirtualBox VM) threads in order to have windows 10 accesible from Opencore BootPitcker. I think both procedures are not easy to do for normal users. I failed in both. The guides are not very well detailed IMO. Opencore wiki has now 87 pages with so many different issues and problems inside many of them mixed.

I honestly think this subject is very important in our days when so many people have unflashed GPUs. I would really appreciate a comprehensive guide to install windows 10 with Opencore and Catalina. I don't know if it is possible. Thanks anyway.
 

h9826790

macrumors P6
Apr 3, 2014
15,196
7,514
Hong Kong
I think you better stick with the existing OpenCore thread.

You can install EFI Windows directly

You can install Windows via VM

You can also convert your existing legacy Windows to EFI mode
 
  • Like
Reactions: zoltm
Comment

startergo

macrumors 68040
Sep 20, 2018
3,440
1,485
I think you better stick with the existing OpenCore thread.

You can install EFI Windows directly

You can install Windows via VM

You can also convert your existing legacy Windows to EFI mode
I am working on another guide:
Modifying genuine Apple Bootcamp partition to boot in UEFI mode. This will cover both Legacy and UEFI with a single partition where legacy Windows would be used to upgrade Windows (or to boot Windows without Opencore) and UEFI will be used to boot same Windows partition under Opencore in UEFI mode (if the user wants to only use Opencore bootloader).
 
Comment

cdf

macrumors 65816
Jul 27, 2012
1,343
1,249
This will cover both Legacy and UEFI with a single partition where legacy Windows would be used to upgrade Windows (or to boot Windows without Opencore) and UEFI will be used to boot same Windows partition under Opencore in UEFI mode (if the user wants to only use Opencore bootloader).

Neat!

Opencore wiki has now 87 pages with so many different issues and problems inside many of them mixed.

The guide (or the wiki) is the first post and is regularly updated. You should stick to that. The rest of the thread is for experimenting and troubleshooting.

I honestly think this subject is very important in our days when so many people have unflashed GPUs. I would really appreciate a comprehensive guide to install windows 10 with Opencore and Catalina. I don't know if it is possible. Thanks anyway.

It is certainly possible. As mentioned in the guide, a how-to for third-party-OS installation is in the works.
 
  • Like
Reactions: Enricote
Comment

Enricote

macrumors member
Original poster
Oct 7, 2018
68
39
Madrid, Spain
Neat!



The guide (or the wiki) is the first post and is regularly updated. You should stick to that. The rest of the thread is for experimenting and troubleshooting.



It is certainly possible. As mentioned in the guide, a how-to for third-party-OS installation is in the works.
The wiki Guide for Opencore is excellent. I could perfectly follow it months ago and the last version is even more clear. I have no complains at all
 
  • Like
Reactions: cdf
Comment

molx

macrumors newbie
Jul 20, 2020
3
1
Bavaria
Hi, my problem fits the thread title.

Background
cMP 5,1 (4,1); Radeon RX 580 8 GB (not flashed)
Catalina 10.15.5 (installed with the help of dosdude1's patcher)
Catalina and Win10 (bootcamp) are both on the same SSD

Problem
After 'installing' OpenCore on my cMP 5,1 – following Activate AMD acceleration – to get a bootpicker and activate HWacc I cannot boot from my windows 10 (bootcamp) partition anymore. Bootpicker for macOS and HWacc in Catalina are working fine but bootpicker is not showing my win 10 partition.

Previous to OpenCore I was able to boot into windows 10 via Startup Disk settings or via BootChamp. Both methods are not working anymore. I still can choose the win 10 start volume in Startup Disk settings but my cMP nevertheless boots into Catalina (same with BootChamp).

Any idea how I can boot into my win 10 partition again?

I tried a view things:
  • NVRAM reset with option+command+p+r
    But that disabled HWacc and the bootpicker. I executed 'Bless OpenCore' again and both are back on. But still no win 10 partition in bootpicker.
  • NVRAM write test
    I was able to write a test variable into NVRAM. The variable still was there after reboot. Deleting it worked, too.
  • I failed using the physical partition in VirtualBox following Boot a Physical Windows 10 Hard Drive using a Mac
    Even when using admin privileges I could not get VB to use the physical partition.

'diskutil list' is giving me:

Bildschirmfoto 2020-07-20 um 13.32.04.png
 
Last edited:
Comment

startergo

macrumors 68040
Sep 20, 2018
3,440
1,485
Hi, my problem fits the thread title.

Background
cMP 5,1 (4,1); Radeon RX 580 8 GB (not flashed)
Catalina 10.15.5 (installed with the help of dosdude1's patcher)
Catalina and Win10 (bootcamp) are both on the same SSD

Problem
After 'installing' OpenCore on my cMP 5,1 – following Activate AMD acceleration – to get a bootpicker and activate HWacc I cannot boot from my windows 10 (bootcamp) partition anymore. Bootpicker for macOS and HWacc in Catalina are working fine but bootpicker is not showing my win 10 partition.

Previous to OpenCore I was able to boot into windows 10 via Startup Disk settings or via BootChamp. Both methods are not working anymore. I still can choose the win 10 start volume in Startup Disk settings but my cMP nevertheless boots into Catalina (same with BootChamp).

Any idea how I can boot into my win 10 partition again?

I tried a view things:
  • NVRAM reset with option+command+p+r
    But that disabled HWacc and the bootpicker. I executed 'Bless OpenCore' again and both is back on. But still no win 10 partition in bootpicker.
  • NVRAM write test
    I was able to write a test variable into NVRAM. The variable still was there after reboot. Deleting it worked, too.
  • I failed using the physical partition in VirtualBox following Boot a Physical Windows 10 Hard Drive using a Mac
    Even when using admin privileges I could not get VB to use the physical partition.

'diskutil list' is giving me:

View attachment 935561
You need to use:
Sudo Hdiutil unmountDisk /dev/diskX
And watch the disk utility as it tends to automount. If it does, repeat the command to unmount disk. Also during reboots the assigned drive number may change so your original Vbox disk may point to different drive.
 
Comment

molx

macrumors newbie
Jul 20, 2020
3
1
Bavaria
You need to use:
Sudo Hdiutil unmountDisk /dev/diskX
And watch the disk utility as it tends to automount. If it does, repeat the command to unmount disk. Also during reboots the assigned drive number may change so your original Vbox disk may point to different drive.

Thank you.
Code:
sudo hdiutil unmount /dev/diskX
did the job.
I now was able to use my win 10 partition in VirtualBox.

Is there no way to boot it natively with OpenCore installed?
 
Comment

startergo

macrumors 68040
Sep 20, 2018
3,440
1,485
Thank you.
Code:
sudo hdiutil unmount /dev/diskX
did the job.
I now was able to use my win 10 partition in VirtualBox.

Is there no way to boot it natively with OpenCore installed?
Yes there is. You need to install rEFInd and chainload from there OC. Whenever you want to use Bootcamp/CSM Windows, boot it straight from rEFInd.
 
Comment

molx

macrumors newbie
Jul 20, 2020
3
1
Bavaria
Yes there is. You need to install rEFInd and chainload from there OC. Whenever you want to use Bootcamp/CSM Windows, boot it straight from rEFInd.

Wow. Took me a while to figure out which files to use and where to put them.
But I got it done.

Thank you for showing me the direction.
 
  • Like
Reactions: startergo
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.