OSX, Kernal Panic, now hangs on restart

Discussion in 'Mac Basics and Help' started by NotATechie, Jun 4, 2007.

  1. NotATechie macrumors newbie

    Joined:
    Jun 4, 2007
    #1
    Help! My iBook has been acting more and more strangely for the past few days -- first it was Safari "unexpectedly quitting," then freezing. Then I got a very scary-looking kernal panic type message, though not in the usual box at the middle of the screen. It was in the upper left, as if I had logged in in single user mode, superimposed on the normal screen. I blithely ignored this and restarted, though I did use "carbon copy clone" to create an complete clone of my entire computer on my external hard drive.

    Today I stupidly (given that the computer has already been acting very oddly) allowed Softwear Update to convince me to download two security updates without noting exactly what they were.

    (Before I go any further -- I believe I'm running 10.3.9, though it may be 10.3.7. This is a 40GB dual usb iBook from 2003, has already had the motherboard replaced once, with third-party RAM.)

    Anyway, I left my computer apparently happily downloading, and came back a while later to find the screen saver image frozen with the dreaded black-square multilingual kernal panic message. I restarted and the hard drive started to spin very very fast, with a shrill whine, and the screen never got past the question-mark file. I restarted again. This time the screen stayed black. Same shreeking whine. I panicked and restarted again. This time it got all the way through the grey apple startup, the general blue-bar startup screen, and hung at the final item in that lineup -- "Login Window starting." And there it's hung ever since.

    I read on one of the archived messages that in a similar situation someone suggested booting in single-user mode and typing "fsck." I did that and it found a place where there was one of something rather than two. It said that it repaired it.

    I tried restarting. Same problem.

    I am at a loss. I don't remember how to boot off a separate computer and run disk utility that way. Past experience suggests to me that this is a hardware issue, but I'm keeping my fingers crossed that it's not.

    Help! I'm not a techie! What do I do?

    While I'm waiting for a response I'm going to take out my third-party RAM and see if that helps, but somehow I don't think that's it.

    Thanks in advance.
     
  2. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #2
    if you still have the origional disks, you could boot up from that, and try to see if there is a problem with the HD, I think that that may be what it is.
     
  3. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #3
    Sadly, I don't have the disks on hand.

    This is why I ask for a reminder if there's some way to boot up from another computer and check that way. Is there? I'm typing this on my second iBook, and I have a firewire cable, so I can easily link the two.
     
  4. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #4
    UPDATE

    I figured out how to boot from my external drive (which has the exact clone of my entire computer from a couple days ago). So #1 was done running off of my exernal drive.

    1. I ran Disk Utility. "Repair Disk" produced the following unusual (in my experience) message:

    > Overlapped extent allocation file (file 3316281d)

    That's the only info it gave, other than the usual list of "checking"s. It ends with "Repairing volume" and then "The volume was repaired successfully."

    I ran "Repair Disk" over and over and it came out exactly the same every time. (This is also exactly the same as what I got when I ran fsck -y in single user mode, that is, after the first time when I got the "There are two of ___. There should be one." message. I don't remember what was in the blank.)

    I also ran Repair Disk Permissions three times. Each time it found a bunch of things to repair.

    (Btw, before all this I zapped the PRAM, which didn't help anything.)

    2. Then, I chose 9.2.2 on my sick iBook as the new startup disk and restarted. It started up FINE. Everything seemed ok.

    3. Then, running off of 9.2.2 on the sick iBook, I chose 10.3.9 as the new startup disk and restarted once again. It still got stuck at "Login Window starting."

    This suggests to me that the problem is in OS X and that it has something to do with the Users end of things. Could I be so fortunate as to have a non-hardware problem on my hands?

    Comments? Advice?
     
  5. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #6
    If your harddisk makes strange noises, it may be on its way out. Backup everything immediately, before you try fixing anything. Trying to fix a broken harddisk (with hardware that isn't working properly anymore) will only cause more problems.

    After that you should try to read up about replacing the harddisk. :(
     
  6. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #7
    This may not be a mechanical problem with the HD. It's more likely to be a logical (e.g., a directory error) issue. Get your hands on a good commercial drive diagnostic utility (TechTool Pro or Disk Warrior). You can run it off the CD or booted on your external drive.
     
  7. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #8
    I hope you're right. Since posting the above I have run TechTools Deluxe (after having gone through all kinds of acrobatics to get a CD into the computer by booting off my external hard drive).

    TechTools crashes with a kernel panic box every time it gets to Step 3 in testing the Volume Structure. So I can't even run the whole thing.

    What might this mean?
     
  8. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #9
    Another update:

    Following the apple website's advice (thanks to the person who sent me there!), I used fsck to remove the offending file that was producing the "Overlapped extent allocation file" message. I ran fsck again and got a message that said "Volume Bitmap needs minor repair." Ran it again and got -- wonder of wonders -- the happy message that "The volume appears to be ok."

    So that's all good, but it seems that the "overlapped extent allocation file" wasn't actually causing the original problem, because when I rebooted the computer hung once again on "Login Window starting."
     
  9. ®îçhå®? macrumors 68000

    ®îçhå®?

    Joined:
    Mar 7, 2006
    #10
    If you backed up a few days ago, why not reinstall the OS??
     
  10. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #11
    Try TechTool again. Are you booting off the internal drive, the CD, or the external?
     
  11. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #12
    In reply to ®îçhå®?, as noted above, I don't have the OS X disks on hand, so I can't just reinstall the operating system. Otherwise I would happily do so.

    IJ Reilly, I just tried TechTool again, booting off the CD. The entire program froze at Task 4 of 7 on "testing Volume Structure," "Step 223,182 of 611,074." Even the mouse has frozen.

    Btw, I can't figure out how to boot off of the external drive at this point because the TechTools CD is in the CD-Rom drive, and the only command I know -- Cmd-Opt-Shift-Del -- seems to boot off the external drive only if there's NOT a CD in there!

    I still can't boot off the internal drive. It continues to hang at "Login Window starting."

    Thanks to all -- keep it coming!
     
  12. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #13
    It just gets worse and worse.

    I restarted, holding down Cmd-Opt-Shift-Del in hopes of booting off my external drive. I got a grey screen with a single thin black line through it and a loudly, quickly whirring internal drive.

    I restarted again, holding down the same keys, got the question mark, then happy mac, then a white screen with the following in the upper left in tiny black type:

    Invalid memory access at %SRR0: 01c0676c %SRR1: 00003030

    Apple Powerbook4,3 4.6.4f1 BootROM Built on 3/5/03 at 10: 06: 09
    Copyright 1994-2003 Apple Computer, Inc
    All Rights Reserved

    Welcome to Open Firmware, the system time and date is: 18:58:13 06/05/2007

    To continue booting, type "mac-boot" and press return.
    To shut down, type "shut-down" and press return.

    ok
    0 > _
     
  13. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #14
    This is sounding like a bad RAM issue to me. You definitely do not want to attempt a reinstall of the OS under these circumstances. Can you remove the third-party RAM?
     
  14. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #15
    I thought the same thing. I just removed the third-party RAM, rebooted, same problem (hung on "Login Window starting").

    Based on advice found in the archives here, I removed the preferences files for com.apple.loginwindow.plist and logwindow.plist from all users and from the overall library. Restarted. Still hung. Booted from my external hard drive which has a complete clone of this computer. Copied over earlier versions (pre-crash, though not pre-weirdness from my computer) of all of those files. Rebooted, this time from internal drive. Still hangs at "login window starting."
     
  15. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #16
    Wait, I thought you said that you could not reboot off the external drive. Since you have, can you run Disk Utility on the internal drive now?
     
  16. Shadow macrumors 68000

    Shadow

    Joined:
    Feb 17, 2006
    Location:
    Keele, United Kingdom
    #17
    Fistly, congratulations! You actually have a PowerBook in disguise! :p

    Secondly, that definatley sounds like a RAM issue, take out the RAM (if you can) and try again or take it to an Apple Store.
     
  17. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #18
    Oops, sorry, forgot to update that part. Yes, I'm able to boot off the external drive again. When I got that "Invalid Memory Access" message, I typed "mac-boot." It spit out the CD and then gave me a prompt which refused to recognize any command whatsoever, not "mac-boot," not "reboot," not "shutdown," nothing. So I had to shutdown using the power key. Thereafter, using cmd-opt-shift-del to boot from the external drive was possible again.

    What I can't figure out now is how to avoid booting in "Safe Boot" mode. For some reason cmd-opt-shift-del will only put me in Safe Boot with the external hard drive.

    Following your instructions, I've just run Disk Utility again. This is perhaps the seventh or eighth time that I've run Disk Utility, and I also ran "dsck -y" perhaps ten times as well over the past 12 hours. Here's the latest result:

    "The volume [name] appears to be OK.

    Repair attempted on 1 volume.
    HFS volume repaired."
     
  18. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #19
    I just ran TechTool off the external hard drive. Midway through step 4 of the "testing Volume Structure" I got another kernel panic message.

    When I restarted, holding down cmd-opt-shift-del to boot form the external drive, I got the "Invalid Memory Acces" message again, just as before (See above), only note that this time the third party RAM isn't in there any more!

    Tried restarting again. Exactly the same thing happened.

    Maybe it's time for a new computer?
     
  19. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #20
    Hmm. Doesn't mean the other RAM module isn't bad, or hasn't worked itself loose. The fact that you get a kernel panic when booted on the external drive certainly suggests hardware and not hard drive issues. Might be worth running the hardware test CD, if you've got it handy.
     
  20. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #21
    I don't have any of the original disks here, sadly. So no hardware test CD.

    The most hideous thing of all has just happened, though: it no longer boots from the internal drive at all, just goes to a grey screen.

    If I try to open in firewire target mode via my other iBook, it shows up for a few minutes and then TURNS ITSELF OFF (!!), even when the power cord is connected (so I know it's not a battery issue).

    When I try to boot from the external hard drive, it intermittently gives me the horrible "Invalid Memory Access" message or boots up ok. Seems to be unpredictable.

    Is it time to bite the bullet and take it to the Mac repair guys? Thank you so much for all your advice.
     
  21. NotATechie thread starter macrumors newbie

    Joined:
    Jun 4, 2007
    #22
    Conclusion to the sad tale

    Thought it might be worth posting the end of this sad story. I got my hands on the hardware test disk. It passed all tests once, but when I re-ran them several times (just in case) it froze each time I tried -- first on Logicboard, then on AirPort, etc... you get the picture. I'm guessing that the Logicboard has gone belly up and that it's time for a new computer. My local MAC repair guys agreed with me, based on the tests I had run and without even taking a look at it themselves.

    Pretty amazing that Apple produced such an inferior product, in terms of hardware: I had the computer four years and the Logicboard had to be replaced twice (not once, as I said below) and now has died for a third time. Not a very good track record. And yet I'm off to buy a new Macbook! Go figure.
     
  22. jng macrumors 65816

    jng

    Joined:
    Apr 6, 2007
    Location:
    Germany
    #23
    Meh, PCs are the same. Basically computers fail. At least Apple replaces them if there really is a logic board flaw as opposed to just breaking down because of age.

    My friend's 4 year old iBook's logic board died last year and Apple replaced it even though it was waay out of warranty. It was in their database of problems to address.
     

Share This Page