OSX Lion bricking itself? Can't Log on.

Discussion in 'Mac OS X Lion (10.7)' started by LachlanH, Oct 5, 2011.

  1. LachlanH macrumors regular

    Oct 5, 2011
    Hey all,

    I've done quite a bit of searching and tried various things but nothing seems to be helping.

    I am trying to fix a Macbook Pro for a staff member here at work. It's a 2010 MBP running Lion.

    Twice now since upgrading to Lion he has experienced this issue.
    You see the login screen and enter your login credentials. If you enter them wrong you get the usual screen shake. If you enter them right, the screen flashes for a second as if it's going to login, then dumps you straight back to the login screen.

    I have tried Safe Boot, same thing.
    I have tried using Cmd+R, going into terminal and resetting his password, same thing.
    I have tried doing the same but for the root account and trying to login as root, again, same thing.

    It goes from working fine one day to totally unusable the next. Last time this occurred I had to restore his machine from a backup. SURELY there is a better fix then that? I would like to know what circumstances cause this issue as well so we can prevent it from occurring again. My 2011 MBP was upgraded to Lion the same day his was and I haven't had a single issue with it.

    Please, if anyone has any suggestions that I haven't already tried, I am all ears.
  2. diastelo macrumors newbie

    Oct 11, 2011
    I have the exact same problem with a Mac Pro. Correct logins look like they're about to work, but the screen goes blank and returns to the login screen just as you've described. Interestingly enough, logging in remotely through SSH does work, so the account plainly works. I suspect some cache or preference files for the graphical log in screen are corrupted.

    I talked to the person using the computer, and he says that he usually "fixes" the problem by rebooting. Apparently he's been having the problem for at least a week now and only decided to come to me for help when rebooting didn't work. Since both his account and the default admin account we created don't work. I'm about to try resetting the password, but I'm afraid it might only be a temporary fix, since the user account plainly still works with SSH!

    If anyone has any pointers or what cache or preference files could be the culprit, let me know. It's such an intermittent problem that debugging it is a huge pain. It reminds me of the problem in Snow Lion I get where the "do things as administrator" prompt no longer accepts the administrator account password. I feel like I had to wipe out most of the admin account's library files before it started working again.
  3. roxxette macrumors 68000


    Aug 9, 2011
    Well i had a little problem playing with bootcamp (not going into details) the thing is when i restart i got regular screen but no login just a " bigfolder icon with a ? sign" , i reboot couple of times same thing ; fix was restart and enter the repair command and then select again the startup disk.

    Try it maybe that helps :)
  4. LachlanH thread starter macrumors regular

    Oct 5, 2011
    Ok Guys this is getting stupid.

    We have now had this problem at work FOUR times.

    2 on a 2010 Macbook Pro
    1 on a brand new 2011 Macbook Air
    and 1 today on a BRAND NEW 2011 MBP

    The 2011 Macbook Pro was bought Wednesday afternoon. It was brought into work yesterday. I updated it right away to 10.7.2 and installed MS Office '11 then updated that.
    That's it.

    The machine restarted fine after the updates and worked. That night, the problem described in my first post occurs.
  5. DefenseEngineer macrumors newbie

    May 27, 2004
    Do the machines with the problem have File Vault running? It bricked my machine, I had to completely restore it from a Time Machine back up and now I can't get file vault to work at all on 10.7.2. Not to mention that the restore from Time Machine has broken my Photoshop license....

    This is a disaster of an upgrade.
  6. diastelo macrumors newbie

    Oct 11, 2011
    I am now extremely reluctant to install Lion on more machines at work just now. I was forced to do a very painful two day fresh reinstall to fix the lock out issue, and I'm beginning to think it's just going to pop right back up again later.

    In case any one is looking for possible points of similarity, File Vault was not turned on. Microsoft Office, VMware Fusion, and Eclipse SDK were pretty much the only software packages installed on the system. Very little else was modified. We had to add a consent banner to the main screen for the legal department, but we did that the usual way, with the appropriate defaults write command, not through a third party program.

    As I mentioned in my last post, if Remote Login/SSH is enabled, I can still log into the system, no problems. It'd almost make more sense if I couldn't log on at all. I did find a couple of other people in other forums with the same problem, except that they encountered it when trying to unlock their screensaver. I don't know if that many users actually log out of their personal machines, so the problem could be really common and yet not affect many people.
  7. LachlanH thread starter macrumors regular

    Oct 5, 2011
    For us as well, I have seen it happen on a machine that was a completely fresh install with just MS office '11 installed as well.

    I have seen it on 10.7.2 as well so it's not been fixed yet.
  8. sucid macrumors newbie


    Dec 21, 2010
    Winona, MN
    I'm having the same problem following an update to 10.7.2 I first noticed something was wrong when I saw that Silverlight was using 103% of my processor according to activity monitor.

    I use VMWare Fusion 4 for school. I have seen that has been a common program on other forums with this problem.

    I'm attempting a Lion reinstall from the recovery partition.

    Resetting my password through Apple didn't help. neither did disk utility which found a bunch of problems.
  9. nate55 macrumors newbie

    Oct 31, 2011
    Same Problem


    I'm having the same exact problem with my brand new 2011 Macbook Pro. Did you get anywhere as to what the problem is and how to fix it?
  10. RatFace macrumors newbie

    Nov 2, 2011
    Having the exact same issues as described. It happened on a 3 days old MacBook Pro I received 3 weeks ago.

    I did all the suggestions as the original poster described with no success. I took it into the Apple Store, they wiped it and reinstalled Lion. The machine worked fine for 1 day and then same thing happened. Took it back in again and they're going to replace the machine.

    They still haven't picked up the machine from me yet and it's almost been 3 weeks. :mad:
  11. Puce macrumors newbie

    Sep 25, 2011
    Even with Lion SERVER !

    Had the same issue with the my lion server !

    Restarted due to a network problem. Boots but I can't login even as root.
    No users can access their accounts. 600GB of data there.

    My backup is a few days old but I don't trust lion anymore...
  12. jasonvp macrumors 6502a


    Jun 29, 2007
    Northern VA
    Apple is aware of this problem as I opened a case with them back when Lion was first released. They've since called me back a few times to glean more info from me. I have no idea if they've been able to fix it, however.

    The basic problem is: the MS Office installer trounces on some of the Lion internal authentication systems. I don't know HOW that happens, but it does. I've reproduced it several times on several different Macs here in the office. Other co-workers have done the same.

    The 'fix' is annoying but harmless: re-install Lion on top of itself without formatting. That way none of your data, applications, etc, are lost.

  13. nomeelnoj macrumors newbie

    Feb 28, 2012

    I have run into this same issue. For us, it seems to only be on computers imaged using Apple's System Image Utility. I imaged a handful with SIU before switching to DeployStudio.

    This has plagued approximately 10% of our employees, and I have now spent long enough going through file by file to find the corruption causing the issue.

    For me, the issue was resolved by deleting one simple file.


    If you do not have an additional user account on the machine that you can log into, boot into single user mode, log in as root, and delete the above file from the affected user account.

    You should then be able to log in successfully.
  14. Hollywood1203 macrumors newbie

    Mar 12, 2012
    Mac OS X lion 10.7.2 MacBook air can't log on

    So I had forgot what my admin password was... I did The whole hold option button while the computer was booting, click on recovery drive, went into the terminal and typed in resetpassword. I reset both my admin, a different log on account I have and the admin root password. Once finished I restarted the computer. Now once it boots up and gets to the log on screen it does nothing but restarts The log on screen itself every like 2 minutes. What do I do??
  15. diastelo macrumors newbie

    Oct 11, 2011
    It happened again, on a Mac Mini. Completely fresh install of 10.7.0. Added the 10.7.3 combo update, got LDAP working, got NFS working, started configuring printers, etc... Well, in the process of trying to set up Kerberos, I managed to knock out ldap, so I decided to reboot. That was a mistake, because I'm getting the same stupid white login screen problem I got all those months before.

    What it is NOT:
    - Office 2011 (I never even got to install it at all)
    - /Users/(username)/Library/Preferences/com.apple.security.plist (It doesn't even exist on my computer)
    - /var/audit/current actually was a symlink. Someone else mentioned that, on their systems, /var/audit/current was not a symlink like it was supposed to be, and deleting it fixed their problem.

    Things I tried:
    - Deleting /Users/admin/Library.
    - Changing password from SSH login.

    I deleted the krb5.keytab file I'd created along with the krb5.conf file I'd added. Now ldap logins work again through SSH, but my ldap users are getting the same white flash at the graphical login screen.

    The only software packages I installed on my system that did not come in the Lion Installer are the following:
    - Libre Office
    - Firefox 11
    - Google Chrome
    - git
  16. cincrin macrumors newbie

    Mar 20, 2012
    I have somehow exactly the same issue as @diastelo: mac mini server, only Libre Office, Qt SDK, Yahoo Messenger, Google Chrome not installed from App Store. Also the same steps: reset password from boot disc utility even for root user. Nothing happens. Quote from @LachlanH: "If you enter them wrong you get the usual screen shake. If you enter them right, the screen flashes for a second as if it's going to login, then dumps you straight back to the login screen." Really nobody has any solution ? :)
  17. nycmacguy, Apr 3, 2012
    Last edited: Apr 3, 2012

    nycmacguy macrumors newbie

    Apr 3, 2012
    Anyone got a fix to this?

    Has anyone got an actual fix to this problem? Please let me know it is happening at my work as well, I can't keep rebuilding these machines.


    Cannot log in as an Local Admins, Root, or Network accounts.
    Changing passwords via restore disk doesn't work.
    Login screen will flash after entering username and password as if it working, then it will just return to the login screen.

    Tried deleting /Users/(username)/Library/Preferences/com.apple.security.plist
    Tried deleting all of /Library/Preferences.
    Deleted the welcome setup.db basically forcing me to create a new local account. I created a new one, could not log in on that one either and it was brand new. This affects something at the system level.


  18. LachlanH thread starter macrumors regular

    Oct 5, 2011
    I can confirm that for my issue at work it was related to our copy of Office '11

    Our install package was originally for 10.6 and using it on Lion seems to brick it.

    The solution as posted by someone above is to reinstall Lion over the existing install. You won't loose any files or programs by doing this, and if you have a Lion install USB it's a fairly quick and painless process.
  19. JimboStormforce macrumors newbie

    Jul 9, 2012
    Resurrecting an old thread - I'm having this issue also, on a Mac Mini Server.

    Screen Sharing and plugging a keyboard and monitor in have the same results - I type a 'good' username and password in, and it goes blank as though it's logging on, then gives me the login screen again. Type a bad username and password in, and I get the usual shake.

    I can't find a way of accessing the users folder on the server (I can only access the network users folder) and SSH is not enabled. So, I can't really do anything - the server is doing everything it should be, but I am unable to make any changes!

    I'm using an iMac running 10.6.8, and additionally can't seem to install a version of Server Admin Tools that will run on this machine.

    Any suggestions/guidance gratefully received.
  20. Tucker5551 macrumors newbie

    Aug 2, 2012
    Hey guys, i have the same problem ive tried everything in here and nothing, i have just wiped my imac with the install dvd and now i cant even get past the registration part now :(
  21. JimboStormforce macrumors newbie

    Jul 9, 2012
    I'm really un keen to attempt a mac reinstall or installing over the top, being a relative newcomer to macs (and not having an install disc handy!) so this is quite frustrating.

    I've tried booting in single user mode, which I can do, and enabling SSH, which didn't seem to work. I don't know what else to try - is it a case of taking it to the Mac Store?
  22. tolsky macrumors newbie

    Jun 19, 2007
    This worked for me!

    IMagine my horror when this happened to me on holiday and the little bit of work I had to do looked set to ruin my day/week. Due to my mac running slow (too many programs open) I held the power button down and shut down in that naughty way, I didn't have time for it to shut everything nicely...
    So when i booted up I got the login screen that wouldn't go away even with the right password. So i found this site on my phone.
    Someone's suggestion of deleting a pref file having booted in as single user gave me the idea of just logging in with the shift key down (mac progs start up without thinking too much when you hold down the shift key) and sure enough it went straight in without issue. So to be clear I didn't boot in as single user, I just held shift down whilst logging in.
    hopefully it will work for some of you too, certainly quicker than some other methods!
  23. JimboStormforce macrumors newbie

    Jul 9, 2012
    Cheers for that tolsky - do you mean hold shift down while logging in, or while starting up?
  24. JimboStormforce macrumors newbie

    Jul 9, 2012
    So I've just tried starting it up in Safe Mode, no joy again.

    What's equally frustrating, is that from the login screen, there is no way of doing a 'clean' shutdown/reboot, so I'm effectively forced to do a dirty shutdown using the power key. Every time I have to do that I cringe a little bit - it's immensely difficult to manage a server that won't let me in!
  25. circuscowboy macrumors newbie

    Aug 23, 2012
    Office 2011

    Office 2011 caused this issue for me.
    I want throw the crappy software that bricked my system at someone personally.
    Who needs viruses when Microsoft distributes them!
    I reinstalled to fix like above.
    Would not boot with root or safemode.
    Royal pain in the arse.

Share This Page