Pages autocorrect options

Discussion in 'Mac Apps and Mac App Store' started by zen, Oct 25, 2007.

  1. zen macrumors 68000

    zen

    Joined:
    Jun 26, 2003
    #1
    I'm 99% ready to ditch MS Office altogether and switch fulltime to iWork, except for one tiny problem.

    I use a lot of en dashes in my writing, and in Word if I do a hyphen between sentences as I type it automatically changes them to en dashs (as it should).

    Pages doesn't do this, and I can't find any option anywhere that will let me set this as an autocorrect preference.

    Any Pages gurus out there got any ideas?
     
  2. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    I haven't used Pages much (yet), but I'm surprised it doesn't have that ability.

    I did find in the Auto-Correction preference where you can enable automatic symbol substitution. The en-dash isn't there, though. As a stop-gap (until someone points out a better way - or the obvious), you could add a substitution rule where a double-dash is converted to en-dash. It seems to work, but it's just as easy to type option-hyphen. Obviously, an autodetect and correction would be better.

    edit: Seems to be font dependent: Helvetica will give you a hyphen, whereas Helvetica CY will auto-correct to an en-dash. So far, the only others I've found are Geneva CY and Charcoal CY.
     
  3. zen thread starter macrumors 68000

    zen

    Joined:
    Jun 26, 2003
    #3
    Ah, so option-hyphen types an en dash? That would do me for the moment.
     
  4. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #4
    edit: yes. opt-hyphen for en dash

    em-dash is option-shift-hyphen, if you use them.

    There's a great widget for symbols called CharacterPal - handy when you can't remember the combo for TM or degree.
     
  5. thekk macrumors newbie

    Joined:
    Oct 28, 2007
    #5
    re:auto correct options in Pages

    Hi, I've just got my dad a mac (Leopard) and convinced him to go with iWorks 08 instead of Office for Mac. He's recently come to me to ask if it has autocorrect. I use a windows but am pretty computer savvy and still can't seem to find where autocorrect might be hiding. By the way you guys were talking there IS in fact something along those lines.


    Help?? How do I do this?

    Thanks

    Kk
     
  6. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #6
    Look in Preferences. Also, a conversion of a regular hyphen to en-dash can easily be added to the auto-correct list.
     
  7. benhollberg macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #7
    This three-year-old thread just helped my out where time was a big factor. I am so glad that I came to MacRumors Forums first and that this was here. Thanks.
     
  8. tinius macrumors newbie

    Joined:
    Aug 17, 2009
    Location:
    Norway
    #8
    How to stop auto capitalization of i

    Is this an option somewhere in Pages to stop autocorrecting "i" to "I"?

    Have searched the prefs but can't find anything about this.
     
  9. walford0205 macrumors newbie

    Joined:
    Nov 19, 2011
    #9
    th to Th.

    G'day,

    When typing for some reason I often leave the 'e' off the word 'the' and pages always autocorrects it with 'Th.'.

    I've added th to be corrected with the in the autocorrect options, but that didn't work.
     

Share This Page