Personal hotspot is badly broken

Discussion in 'iOS 9' started by John Mcgregor, Dec 4, 2015.

  1. John Mcgregor Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
    #1
    So i have a new iPhone 6S Plus and a retina MacBook Pro, but when i try to use personal hotspots on my MacBook it just doesn't show up under wifi menu. I have to retry many times before it shows up.

    Also when it shows up and i can connect it is then impossible to disconnect. It will reconnect again and again and again. The only way i found to disconnect is to flip the switch on the iPhone manually.

    Now i have no idea if its iOS 9, OS X or problem in both. I'm running El Capitan.


    It worked flawlessly on my iPhone 6 with iOS 8 and Yosemite.
     
  2. gordon1234 macrumors 6502a

    Joined:
    Jun 23, 2010
    #2
    I have almost the same setup - iPhone 6s, Retina MacBook Pro (2015), latest software on everything.

    In my case, everything works perfectly - I tether every day, sometimes for hours, and I've never had any problems at all.

    I'd suggest first trying to tether with another device or computer to see if the phone is the problem.
     
  3. jgelin macrumors 6502a

    jgelin

    Joined:
    Jul 30, 2015
    Location:
    St Petersburg, FL
    #3
    I had the disconnect issue the other day at the cafe. I could not untether from my iPhone 6s+ from my MacBook Air. Had to turn off wifi for it to stop reconnecting.
     
  4. John Mcgregor thread starter Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
    #4
    Sadly i gave my iPad Air to charity last week, so i have nothing to test this on.
     
  5. John Mcgregor thread starter Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
  6. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #6
    Do it via bluetooth if you're not trying to share the connection to a third party. I do this on a daily basis and it works great.
     
  7. John Mcgregor thread starter Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
    #7
    Doesn't work at all.
     
  8. John Mcgregor thread starter Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
    #8
    So my OCD took over again and i finally found the issue. As always it's wifi drivers. I found the driver from GM candidate, disabled system integrity protection and replaced the driver. Now i can see my iPhone under wifi almost instantly and it disconnects correctly and also personal hotspots get correctly disbaled on the iPhone as well. **** you, Apple.
     
  9. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #9
    Pretty sure you're making an error. I was curious about this error and was doing some work at my folks home office and I managed to pair / hotspot my phone via bluetooth to their 3 Macs with no issues. I also turned on the wifi hotspot and they all detected it. The phone is a 6S.

    It's extremely unusual that you would need to force a driver change like that. Which version of El Capitan & iOS are you running?
     
  10. John Mcgregor thread starter Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
    #10
    Latest.
     
  11. Stickharuhi macrumors regular

    Joined:
    Mar 12, 2015
    #11
    Yes see my test here http://forums.macrumors.com/threads/iphone-6-and-ipad-air-2-personal-hotspot-miserable.1888510/. I report many bug report to apple bug report site. But no fixed.

    But mostly (to 60%) iOS personal hotspot broken. Android 4-6 hotspot no issue. Or the jailbreak tweaks mywi.

    I am not sure why, the iOS personal hotpot mostly broken. I think the code from the Apple developer very bad. Because I use many android device with other android version (4/5/6). All this android device no issue.
    And the jailbreak tweaks mywi 9.0 (the jailbreak developer has better code and api). This is that issue in iOS, it give parts in iOS the not good. Here is good this iOS part as open Source, then the Community add better code.
     
  12. Stickharuhi macrumors regular

    Joined:
    Mar 12, 2015
    #12
    Not forget: The hotspot (ad-hoc + internet sharing) from OSX is very good.

    Again: Android hotspot,jailbreak tweaks mywi and OSX hotspot no issue. No broken.

    iOS personal hotspot mostly (60%) broken. I test with iOS 7,8,9. Not fixed. Has you test with clean install without backup? Yes!!!
     
  13. John Mcgregor thread starter Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
    #13
    If i setup it manually it works just fine, but i want it to work automatically without me flipping the switch.
     
  14. maxsix Suspended

    maxsix

    Joined:
    Jun 28, 2015
    Location:
    Western Hemisphere
    #14
    I've regularly experienced OS X and iOS wifi/personal hotspot problems. Apple is challenged, when it comes to wireless they're very weak. Sometimes it works other times it doesn't. Never a dull moment. It's a gamble like Las Vegas
     
  15. Stickharuhi macrumors regular

    Joined:
    Mar 12, 2015
    #15
    Yes correct. iOS personal hotspot is as in Las Vegas.

    That issue is iOS use not the code from OSX ad-hoc. Therefore can you on iOS not create hotspot without celluar access. On OSX,Android and jailbreak tweak mywi no issue (to 100%). More as 50 test here.

    My result is iOS personal hotspot to 60% broken.
     
  16. XTheLancerX macrumors 68000

    XTheLancerX

    Joined:
    Aug 20, 2014
    Location:
    NY, USA
    #16
    Also experiencing issues, and I wish that personal hotspot was more feature packed. Like, I would love to be able to see *what* devices are connected not just how many, and also how much data each device that has connected has used. I have only used hotspot between iOS and iOS devices, but I do frequently run into issues where it says the password is incorrect even though it definitely is not, then it connects briefly and disconnects, connects again, disconnects again. All in very rapid succession. Then it just quits and doesn't connect again.

    Sometimes switching between Wi-Fi and bluetooth works but you sometimes have to try each method multiple times before it finally cooperates. Instant Hotspot is also flaky.
     
  17. John Mcgregor thread starter Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
    #17
    For me it works much better in Yosemite.
     
  18. Stickharuhi macrumors regular

    Joined:
    Mar 12, 2015
    #18
    Correct as in my test here. Sometimes is hotspot available or not. Then off,on,off,on not working. Now restart the device. With happiness then it works. Therefore in my test to 60% broken. OSX ad-hoc,Android hotspot,jailbreak tweaks mywi no issue.

    Apple can not fixed, because in this category are the Apple developer very bad. Here is the community very good.
    But Apple lock iOS or not allow jailbreak tweaks e.g mywi.

    Why not allow jailbreak tweaks for normal iOS tasks? Because Apple hate undocumented API. The tweaks mywi is not open source(Apple can not check and add for their iOS system) , but has better code/api as Apple iOS personal hotspot.

    How can fixed this issue?? When Apple not need help from the community.

    Then please add OSX ad-hoc code!! And add then e.g as you say "more options" etc...
     
  19. maxsix Suspended

    maxsix

    Joined:
    Jun 28, 2015
    Location:
    Western Hemisphere
    #19
    It's rather suspicious that Apple cannot or will not fix this issue.

    One minute Apple and is acting superior and charging high prices, the next they can't even get it to work as promised.

    They're the only company that has a large contingent of customers that'll buy anything and make excuses for Apple when it fails to work right.
     
  20. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #20
    Plenty of companies have followings and just regular customers and also have products and services that aren't perfect.
     
  21. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #21
    Yup....I downgraded my rMBP back to Yosemite, and no more problems. I should have read the reports in the OS X El Cap section of MacRumors, before I upgraded, but I just blindly upgraded. I won't make that mistake again...No more .0/day 1 OSX releases for me.
     
  22. AbSoluTc macrumors 68040

    AbSoluTc

    Joined:
    Sep 21, 2008
    #22
    Here it comes.
     
  23. maxsix Suspended

    maxsix

    Joined:
    Jun 28, 2015
    Location:
    Western Hemisphere
    #23
    The last three_major_ revs of OS X have suffered from inconsistent unacceptable personal hotspot performance, in fact Yosemite (clean install was horrible)

    Yet the real underlying true factor is it works for some and not for others. It's this exact characteristic that Apple should have solved long ago. But with compliant tolerant customers, Apple has little reason to fix it.
     
  24. chekz0414 macrumors 6502a

    chekz0414

    Joined:
    Jul 3, 2011
    Location:
    FL
    #24
    I find it odd that you're having this issue, I have a Retina MBP Late 2013, and iPhone 6s Plus and no issues here.
     
  25. John Mcgregor thread starter Suspended

    John Mcgregor

    Joined:
    Aug 21, 2015
    Location:
    Newport
    #25
    Good for you.
     

Share This Page