Photos App keeps crashing after 10 seconds

Discussion in 'macOS High Sierra (10.13)' started by dictoresno, Nov 5, 2017.

  1. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #1
    This never happened until this morning. When I open the photos app and start browsing normally, all of a sudden, it quits and an error report pops up. It won't stay open for more than 10 seconds at a time. Here is a copy of the error report. Anyone else having issues? I deleted a few recent pics, thinking it was an importing issue, but no help. Also rebooted with no change either. Im on the newest beta version, 10.13.2 version 17C60c.

    Process: Photos [817]
    Path: /Applications/Photos.app/Contents/MacOS/Photos
    Identifier: Photos
    Version: 3.0 (3251.12.120)
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: Photos [817]
    User ID: 501

    Date/Time: 2017-11-05 12:49:18.047 -0500
    OS Version: Mac OS X 10.13.2 (17C60c)
    Report Version: 12
    Anonymous UUID: D3869856-6884-875E-26DA-8F58D9C63BF9


    Time Awake Since Boot: 820 seconds

    System Integrity Protection: enabled

    Crashed Thread: 9 Dispatch queue: PAExportCGImageToDataResponse._workQueue

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x000000011a7104ef
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Segmentation fault: 11
    Termination Reason: Namespace SIGNAL, Code 0xb
    Terminating Process: exc handler [0]
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    try this: open the applications folder, and command-option click on the photos icon, let the repair run, see if that helps...
     
  3. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
  4. DKE850 macrumors newbie

    DKE850

    Joined:
    Nov 5, 2017
    #4
    Having exactly the same problem... tried to rebuild and no good. Down graded 10.13.1 and then the Photos app does not recognize the photo folder and would not sync photos with my iPhone. Waiting for a fix...!
     
  5. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
  6. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #6
    I restored my library from a backup and it's crashing again. Is this a corrupted library issue or a macos issue
     
  7. georgeedwardg macrumors newbie

    georgeedwardg

    Joined:
    May 19, 2011
    #7
    Same here. Just started happening today as well.
     
  8. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #8
    Maybe it's an iCloud issue. Mine just started happening yesterday morning.
     
  9. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #9
    Maybe it's an iCloud issue. Mine just started happening yesterday morning.
     
  10. dictoresno, Nov 5, 2017
    Last edited: Nov 5, 2017

    dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #10
    so i just tested a few things out. photo library on the mac hasn't updated since earlier. i just took 4 new pics with the phone, and they never showed up in the photos app after a minute or two like they always do. i went to the iCloud website and sure enough, the photos weren't there either. i guess this means that the phone is failing to upload to iCloud. rebooted the phone, turned off icloud library and back on and still nothing. when i turned it back on, it gave me a low storage warning saying i was trying to upload 24.1 GB of pics to iCloud and didn't have the room (doubling up the photo storage already there). so the phone shows 8021 items but the mac and icloud show 8018. those recent 4 aren't updating. however, imports from the mac to iCloud seem to be. according to their system status page, looks like they were indeed having iCloud issues but it says resolved.
     

    Attached Files:

  11. lindros2 macrumors member

    Joined:
    Mar 21, 2011
    Location:
    Atlanta
  12. georgeedwardg macrumors newbie

    georgeedwardg

    Joined:
    May 19, 2011
    #12
    Did they confirm if this is known issue? Any suggested workaround?
     
  13. jarman92 macrumors regular

    Joined:
    Nov 13, 2014
    #13
    I did exactly the same thing. I don't think the issue is with iCloud, as my photos are still syncing fine between icloud.com and my iPhone. Either way, its incredibly annoying :mad:

    Update: I tried turning off iCloud Photo Library (I know, its a PITA to turn it back on) and Photos still crashed; guess its a local issue with the app.
     
  14. colbill macrumors newbie

    colbill

    Joined:
    Nov 6, 2017
    #14
    Same problem here. Crash each time it is opened (no photos, albums selected). The crash occurs within 10 sec or if I attempt to select any category on the left nav panel. High Sierra 10.13.2 Beta (17C60c). No help as yet from Apple support.
     
  15. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #15
    Mine appears to be back to normal this morning. Doesn’t crash and photos sync normally again. I️ turned off I️cloud photos last night and turned back on. Took all night to update/upload/sync but it appears to be back to normal. Isn’t crashing anymore.
     
  16. georgeedwardg macrumors newbie

    georgeedwardg

    Joined:
    May 19, 2011
    #16
    Still happening here. Followed the same process you outlined. Strange.
     
  17. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
  18. jarman92 macrumors regular

    Joined:
    Nov 13, 2014
    #18
    Anybody updated to the new 10.13.2 beta and can check if the problem is resolved?
     
  19. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #19
    The last thing I️ did before it started working again was turn off iCloud storage (deleted the pics in iCloud). It says you have 30 days to reverse it. Then turned on iCloud Photo Library on my phone again and then turned it back on in iCloud. After it updated, it’s working normal again.
     
  20. lindros2 macrumors member

    Joined:
    Mar 21, 2011
    Location:
    Atlanta
    #20
    They weren't very helpful. I copied this thread URL for them to look at.
    --- Post Merged, Nov 6, 2017 ---
    This isn't practical when you (me) have 33k+ photos in iCloud.
    --- Post Merged, Nov 6, 2017 ---
    I'm starting to think this is an ongoing issue, but has come back in macOS High Sierra 10.13.2 (17C60c).
     
  21. grapunzel macrumors newbie

    Joined:
    Mar 5, 2015
    #21
    Having the same exact issue. I reported to Apple, through the Feedbacks app since I'm in the beta.
    10.13.2 Beta (17C60c)

    Hope it will get fixed, I rely a lot on the Apple Photos app.
     
  22. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #22
    so photos app is crashing again. stayed open all night while it updated/synced/uploaded stuff and was working fine this morning. just checked it again and now its crashing again after about 10 seconds. pictures still sync fine, just crashing again.
     
  23. filipac macrumors newbie

    filipac

    Joined:
    Nov 7, 2017
    #23
    I have the same issue and thought my mac was broken. I am on 10.13.2 Beta (17C60c).
    I get the same error: Crashed Thread: 9 Dispatch queue: PAExportCGImageToDataResponse._workQueue
     
  24. nitschi, Nov 7, 2017
    Last edited: Nov 7, 2017

    nitschi macrumors member

    Joined:
    Jan 17, 2008
    Location:
    Vienna, Austria
    #24
    I have the exact same problem since this morning. MacBook Pro 13" 2017, macOS 10.13.2 Beta (17C60c)

    Already tried to repair the library, didn't get rid of the crash. I literally can't use Photos on my MacBook right now, which kind of sucks. :/

    I just hope that it doesn't f*ck with my iCloud library. On the iPhone everything seems to work and sync fine so far.

    edit
    Interesting!

    • I fired up the macOS Beta-Feedback.app and when finishing my bug report I chose "manually attach iCloud library log report" (or something like that).
    • It directed me to the Apple website where I had to download a "Photos, iCloud Photo Library, and CloudKit Diagnostics Profile".
    • After installing this profile I had to restart Photos.app and select "File -> Gather iCloud Photo Library Diagnostics"
    • I thought: well yeah, good luck, the app will crash before any diagnostic report can be created
    • To my surprise the Photos.app DID NOT crash for around 3 or 4 minutes = the duration of the diagnostics report
    • As soon as the report log file had been created, the Photos.app crashed after another 10 seconds (like the 20 times before)

    Additionally I found these error messages in Console.app (several times; around 30 to 40 error messages in total):

    problem 10:31:50.609109 +0100 com.apple.photos.ImageConversionService IIONumber:174: IIONumber -- 'num' is not a CFNumberRef
    problem 10:31:50.609154 +0100 com.apple.photos.ImageConversionService uint32Num:271: CFNumberGetValue/uint32_t failed
    problem 10:31:52.410773 +0100 com.apple.photos.ImageConversionService IIONumber:174: IIONumber -- 'num' is not a CFNumberRef
    problem 10:31:52.410857 +0100 com.apple.photos.ImageConversionService uint32Num:271: CFNumberGetValue/uint32_t failed
    problem 10:31:57.344616 +0100 com.apple.photos.ImageConversionService IIONumber:174: IIONumber -- 'num' is not a CFNumberRef
    problem 10:31:57.344680 +0100 com.apple.photos.ImageConversionService uint32Num:271: CFNumberGetValue/uint32_t failed
    problem 10:31:58.382284 +0100 com.apple.photos.ImageConversionService IIONumber:174: IIONumber -- 'num' is not a CFNumberRef
    problem 10:31:58.382354 +0100 com.apple.photos.ImageConversionService uint32Num:271: CFNumberGetValue/uint32_t failed
    Additional information: I've been using my iPhone X since Friday and took around 100 photos with it since then. So I don't know if MAYBE it's a problem with (portrait? since I haven't taken any portrait photos before) photos taken with the iPhone X or if it's exclusively a problem with (the) macOS (beta).
     
  25. dictoresno thread starter macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #25
    I wonder if the crash is related to when I import images. Every now and then I'll drag and drop scanned pics into the photos app. The first pic that kept opening prior to the first crash was a scanned import. Also, after "fixing" it yesterday and having it not crash, I imported a pic from my desktop, soon after, it was crashing again. I think it's related. Anyone else with the crash....have you been importing pics?
     

Share This Page