Poor Classic performance on PowerBook G4?

Discussion in 'PowerPC Macs' started by Ann Arcana, May 24, 2019.

  1. Ann Arcana macrumors newbie

    Ann Arcana

    Joined:
    May 18, 2019
    Location:
    Venus
    #1
    I have a PBG4 Aluminum 1.67ghz/1.5GB RAM, running 10.4 Tiger, and 9.2.2 under Classic.

    I've been playing some simple old games on it through Classic and especially with games I get really bad performance, basically the whole program will pause for a second out of every 15-30s, plus I get general slowness and some serious graphics glitches. This even happens in what I would expect to be simple stuff like card games or old 68k games like SimAnt.

    I would chalk this up to just "emulation is slow", except my eMac, with less RAM and only a 1Ghz processor, running the same System Folder (I actually copied that one over to the PB to set up Classic), doesn't have nearly the performance issues. There's a brief little moment of lag now and then but on the whole its much smoother and faster running Classic stuff.

    I tried disabling some unnecessary extensions and stuff, mostly drivers for things I didn't need, and the awful bloated Stuffit extensions, but it had no effect. And OS X stuff, even games, runs fine, so it does seem a Classic issue specifically.

    Any ideas on how to optimize Classic performance?
     
  2. Dronecatcher macrumors 68030

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #2
    It might be the CPU with it's auto frequency scaling? Jumping from one speed to another?
     
  3. AphoticD macrumors 68000

    AphoticD

    Joined:
    Feb 17, 2017
    Location:
    Australia
    #3
    That could be it. To the OP, Go to Energy Saver in System Preferences and set the Performance setting to Fastest/Highest.
     
  4. Ann Arcana thread starter macrumors newbie

    Ann Arcana

    Joined:
    May 18, 2019
    Location:
    Venus
    #4
    It possibly is the CPU frequency. Took it to the office yesterday, and the same card game that was giving me all kinds of lag was able to run just fine at the same time as I was compiling Emacs in the background. It was already set to Highest performance mode when on the adapter, but if it's running faster while the CPU is under load that would point to it being throttled otherwise.

    To make matters more confusing though, after that I took it home and everything's more or less fine now? So ... ‍♀️ It still doesn't feel quite as smooth as I'd hope but not substantially less so than I'd expect from the Classic overhead.

    Computers are weird. Still, any further optimization tips appreciated I guess.
     
  5. Dronecatcher macrumors 68030

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #5
    Sorry, I'd assumed you had the later 1.67 where frequency scaling is automatic and there are no options to set it otherwise.

    I recently had a problem that I'd never had before and on a 1.67 Powerbook, where IPv6 setting was using too much CPU, it's worth considering:

    https://forums.macrumors.com/threads/ipv6-soaking-up-cpu.2171396/
     
  6. Ann Arcana thread starter macrumors newbie

    Ann Arcana

    Joined:
    May 18, 2019
    Location:
    Venus
    #6
    Whooooah. Thanks for this.

    I swear the machine is so much faster now with that off it's hard to believe. Even TenFourFox is kind of snappy, whereas before it was so sluggish I dared not open it more than absolutely necessary.
     

Share This Page

5 May 24, 2019