Possible solution for interface lag and general slowness!

Discussion in 'OS X Yosemite (10.10)' started by baryon, Dec 29, 2014.

  1. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #1
    Ever since upgrading to Yosemite, after a few hours of using my computer, the interface would start to lag more and more, and over the course of a day it would become so slow I'd get really annoyed. After a restart it would be fine again and then it would start lagging eventually. This only affected the animations such as switching Spaces, Mission Control, Scrolling, etc... System performance was unaffected.

    Then I found this article:

    https://david.gyttja.com/2013/01/21/fix-lagging-display-performance-on-retina-macbook-pro/

    Here's what it says:

    • Delete /Library/Preferences/com.apple.windowserver.plist
    • Delete ~/Library/Preferences/ByHost/com.apple.windowserver*.plist
    • Shutdown OSX
    • Startup, immediately press and hold the P and R keys while holding down the option (⌥) and command (⌘) keys before the gray boot screen appears, which resets the PRAM
    • You may have to reset your display preferences (resolution) once you login
    Done!

    So far my computer has been running for a few days without any interface lag. True, I have not used it a lot, and it tends to lag after many hours of using Photoshop, which I haven't done much since then. But even like that, it feels a lot faster than it used to be.

    For those having lag, this is the thing to try!
     
  2. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #3
    Thanks! Maybe the PRAM reset was the key here, though I did try that before with no success. I have not yet reset the SMC but so far it's all good... After 3 months Yosemite finally feels like it isn't a load of ****! I do wish we didn't have to do this in order to get a working system, but at least it works.
     
  3. Populus macrumors 6502

    Populus

    Joined:
    Aug 24, 2012
    Location:
    Valencia, Spain.
    #4
    Thanks for your post, I'll try it because tonight I'm installing Yosemite -from a USB- on my 13" 2010 cMBP. The betas #2 #3 and #4 didn't work as snappy and fluid as Mavericks 10.9.4... And with a LOT of lag.

    I thougt waiting until 10.10.1 was the best idea, and along with this tips, I hope It works flawless.

    Wich mac do you have?

    By the way, sorry for my english. I've been too much time without listening-speaking the language, and now I can hardly speak it with naturality.
     
  4. ncrypt macrumors regular

    Joined:
    May 16, 2012
    Location:
    UK
    #5
    It worked!

    This actually worked so well! Prior to reseting the PRAM mission control and swiping between desktops was a stuttering mess, even with transparency set to reduced, but now I'm getting no lag whatsoever :D:D:D

    You genuinely made my day :D
     
  5. jackdtz macrumors member

    Joined:
    Nov 11, 2014
    #6
    Hi, do you still get no lag whatsoever now? do you restart your mac on daily basis?
     
  6. Eithanius macrumors 65816

    Joined:
    Nov 19, 2005
    #7
    Which Mac are you using btw...?
     
  7. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #8
    Have you switched off the transperancy setting?
     
  8. Tiaraju macrumors newbie

    Joined:
    Oct 23, 2014
    #9
    It's all unnecessary.

    You just need to kill the windowserver process with activity monitor. The system will prompt you to enter the login again.

    I'm doing this occasionally since Yosemite launched.
     
  9. ncrypt macrumors regular

    Joined:
    May 16, 2012
    Location:
    UK
    #10
    So reporting back a few days later, some lag does come back if I have a lot of things open, but generally there is a little less - so no harm done in trying this.

    I restart every 2 or so days to keep things stable ..on Mavericks that wasn't necessary but it definitely helps on Yosemite.
     
  10. jackdtz macrumors member

    Joined:
    Nov 11, 2014
    #11
    okay, restart will improve the overall performance but if i run it a few days without restart it will get laggy. i really expect 10.10.2 will fix this.
     
  11. ncrypt macrumors regular

    Joined:
    May 16, 2012
    Location:
    UK
    #12
    That's what I was hoping, but running 10.10.2 since 21st December and I'm only finding it made a marginal difference :(
     
  12. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #13
    MacBook Pro (Retina, 15-inch, Late 2013)
    2.3 GHz Intel Core i7
    RAM: 16 GB 1600 MHz DDR3
    Graphics: NVIDIA GeForce GT 750M 2048 MB

    I tried that before this solution, and it did not help at all. Now everything works smoothly regardless of whether I disable or enable transparency. It does not seem to make any difference for me.

    You could do that, or you could just reset the PRAM and then you won't have to kill windowserver again. You shouldn't regularly have to kill a low level system process just to fix performance issues.

    So far I have not restarted since, and no lag has come back, but I have not had to use my computer as heavily during this time, so who knows... It's true that Mavericks never had to be restarted for such issues, that's for sure.

    Did you reset the PRAM?
     
  13. jackdtz macrumors member

    Joined:
    Nov 11, 2014
    #14

    I've clear-installed twice and PRAM and SMC reset a few times. I did help at the beginning but i think it is the restart that make my mac smooth. Anyway the lag gets back after a few days without restart. :(
     

Share This Page