Powerbook G4 (5,5) Boot Problems

Discussion in 'PowerPC Macs' started by paredown, Apr 19, 2018.

  1. paredown, Apr 19, 2018
    Last edited: Apr 19, 2018

    paredown macrumors newbie

    Joined:
    Apr 3, 2018
    #1
    Hi,

    I've been working on restoring a couple of late G4 17" Powerbooks (5,5, A1085), and I have one that does not find the drive on a reboot, but finds it OK on a cold boot. (Got these as basket cases so I have no idea about their history).

    If you reboot from the desktop, you see a flicker as the machine finds the drive, then the dreaded flashing folder with a question mark.

    It had a similar problem installing the OS--until I figured out that I had to start it cold with the O/S disk in place. I started with 10.4 for PPC, and then used a retail copy of 10.5 for installs.

    Things I have tried:
    Imaged drive (CC Cloner), fresh build (more than one drive), different memory (long shot).
    Set PB in Target Mode and ran Drive Utility to check. (Another machine seemed to fix itself after this--but it may have been a different problem)
    Had the HD cable off multiple times, examined the cable/mobo connection pretty carefully.

    Things I don't have:
    Original install disks (I have one set for G4 that works with the 1.3ghz, but not the 1.5 or 1.63)
    An extra known good drive cable--what I have at this point is one other that is known bad...

    Things I don't know:
    Was there a firmware upgrade for these machines?
    Does it matter that I am using non-Apple (Hitachi/IBM) drives?

    Any thoughts on what might be the problem?
     
  2. AphoticD macrumors 68000

    AphoticD

    Joined:
    Feb 17, 2017
    Location:
    Australia
    #2
    It sounds like it could be an NVRAM / PMU corruption issue.

    1. Try resetting PRAM first by holding cmd-opt-P-R on startup - repeat 3 times or so to be thorough

    2. Boot with cmd-opt-O-F to enter the Open Firmware prompt and reset NVRAM with `reset-nvram`, then `set-defaults` and `reset-all` to reboot.

    3. Reset the PMU as outlined here: https://support.apple.com/en-au/ht1431

    4. Replace the PRAM battery / module.
     
  3. paredown thread starter macrumors newbie

    Joined:
    Apr 3, 2018
    #3
    Thanks, I'll try these.

    I already did the first as a matter of course--forgot to list it among things tried. I got into the open firmware, and then couldn't remember commands (memory is not what it use to be), so that will be next... PMU link actually seems to list this model.

    I believe that this is one of the models that has a rechargeable PRAM--and I have seen no other evidence of problems, like losing date. I will investigate that suggestion further. If it does, is it something that still needs to be replaced?
     
  4. paredown thread starter macrumors newbie

    Joined:
    Apr 3, 2018
    #4
    Ah, drat--no joy.
    Behaves exactly as before.

    I'm going to check one of these drives with a low-level tool, just to rule out that problem (they came as a batch from the same place, so on the outside chance that there is a problem with the way they were reformatted.)

    The PRAM battery may be at issue though--if I do 'Option'--I don't see the HD as a choice (this is that pretty lame-looking screen from the g4 era--if I have a bootable DvD in place, it seems more likely to show the HD as another choice.)
     
  5. paredown thread starter macrumors newbie

    Joined:
    Apr 3, 2018
    #5
    Not the drive--ordering a new ribbon cable, and fingers crossed.
     
  6. paredown thread starter macrumors newbie

    Joined:
    Apr 3, 2018
    #6
    Score one for the home team --new (used) ribbon cable installed drive to mobo, and all's right with the world.

    (Sometimes it is the physical device...)
     
  7. CooperBox macrumors 6502a

    CooperBox

    Joined:
    Nov 28, 2010
    Location:
    France - between Ricard & Absinthe
    #7
    Glad to hear you've rectified the problem. There could be a lesson here for many.
    I've been fooling around with a troublesome G4 iMac all weekend - tried all sorts to rectify a kernel panic during boot. The HD ribbon cable is one thing I've yet to change.....
     
  8. AphoticD macrumors 68000

    AphoticD

    Joined:
    Feb 17, 2017
    Location:
    Australia
    #8
    I can second this. I have been repairing two PowerBook G4 12"'s. A 1.0Ghz and 1.33Ghz model. A few weeks ago, I jumped onto PowerBook Medic to order some parts which had failed and parts which were missing from the 1.33Ghz machine. The parts arrived today so I set about installing them.

    I stripped both machines down to do the repairs. Both received fresh thermal compound and pads. One unit needed a DC-DC board, hard drive ribbon and sled. The other needed a replacement LCD panel and hard drive.

    I spent hours getting it all done and eventually wrapped it all up. It all looked good to go and both booted fine from Leopard DVDs. But... the 1.33Ghz refused to recognize the replacement hard drive. I pulled it back down again and tried a different hard drive with the same results. I tried a third drive and still the same. I then disassembled the second unit again to test the drive and cable in there and found the issue carried across with the cable. The 1.0Ghz model's known-working drive and cable combo worked in the 1.33Ghz.

    So I have to conclude that the $0.65 used, flex-cable sent out across the great oceans was a dud. I have inspected the cable and can't see any indication of why it's failing. I tried cleaning all of the contacts with IPA and a toothbrush. I even tried oven baking the flex cable (200°C for 6 minutes) to reflow the connector solder joints in case that was the issue, but the result was the same.

    I now need to re-order the same tiny part and pay again for more international shipping... So yes "Sometimes it is the cable" . Even if it makes no sense.
     

Share This Page