General Prevent Calendar events from changing when I travel

Discussion in 'iOS 6' started by ero87, Dec 20, 2012.

  1. ero87, Dec 20, 2012
    Last edited: Dec 20, 2012

    ero87 macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #1
    I've struggled with this for years, so I'm looking for a real answer. I often travel from NY to CA, and when I do so the start times for my iCal events change on my iPhone/iPad. What I want is for Calendar events to remain frozen and never change, regardless of my current time zone. Turning Time Zone Support on/off doesn't help much - if I'm in CA, future events that will take place in NY still display on CA time (even if I change the info of that event). All I want is for Calendar events to be oblivious to time zones, to never change!

    (I briefly found a workaround - turning off Automatic Time Zone detection in date/time settings and manually change the time when I travel - but this disables iMessage for some bizarre reason. Help!)
     
  2. DefBref macrumors 6502

    Joined:
    Feb 26, 2011
    #2
    There's a specific setting for time zone support for calendars. Are you switching that off. It's in settings mail contacts and calendars not the one under general date and time.
     
  3. ero87 thread starter macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #3
    Yeah I've tried that setting, it doesn't help. My problem is this: If I'm in California, and I have a meeting in NY next week at 11am, it'll show as 8am on my calendar. Doesn't matter if I have time zone support on and set the time zones for each event carefully and correctly.
     
  4. kmichalec macrumors 6502a

    Joined:
    Aug 14, 2010
    #4
    I'm not sure I see what the problem is. Your meeting is really at 11am NY time, which is 8am California time. If you were to dial into it from California, you'd be dialing in at 8am. If you're in NY, you'd be attending the meeting at 11am.

    What exactly are you trying to accomplish? Are you just trying to keep the phone from automatically switching time zones, so you can always say the meeting is at 11am, and then you have to know where you will be to know what 11am you are talking about (Cali vs NY)? Not sure why you'd want to do that, but if so, you can try to change one of the following:

    Settings -> General -> Date & Time -> Set Automatically -> Off
    ...or, better yet...
    Settings -> Privacy -> Location Services -> (scroll to bottom) System Services -> Setting Time Zone -> Off

    Maybe one of those two (likely the last one) will do what you need?
     
  5. ero87 thread starter macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
    #5
    I never "dial into" meetings, I always want them to display in local time. It doesn't help me to know the "California time" of an event in New York the following week. Not to mention that this whole time zone mess screws up my flights - I just want the times to never change after I put them in. If I say an event starts at 11am, it should always say that!

    Turning off automatic time zone detection does eliminate the problem, but for some reason it disables iMessage. This is a preferable option to screwing up all my calendars, so it's what I'm using for now, but I was hoping for a more elegant solution. (It seems that on the Mac you can do "Floating" calendar times that are unaffected by time zones, which would be perfect, but it seems you can't do this on iOS devices).
     
  6. johnaubx macrumors newbie

    Joined:
    Jan 23, 2012
    #6
    Yeah, I have the exact same issue with this. And I can't make the calendar be time zone agnostic.
     

Share This Page