Pro won't sleep automatically

Discussion in 'Mac Pro' started by Pagemakers, Apr 2, 2009.

  1. Pagemakers macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #1
    Bought a new Pro and used migration assistant to move stuff from my iMac.

    Now the Pro won't sleep automatically. It sleeps when I tell it to or on Schedule at 0100 but not after x mins of inactivity.

    The iMac it migrated from had no such issues.

    Is there any reset I can do to cure the problem?
     
  2. McShizzel macrumors regular

    Joined:
    Oct 29, 2008
    Location:
    Canada
    #2
    Same problem here, this seems to be an issue affecting iMac and 2009 Mac Minis as well. You can try resetting the SMC http://support.apple.com/kb/HT1806 but this didn't work for me.

    I know that having Firefox open causes the computer to not auto sleep but even with Firefox off mine still can't sleep, my best guess is that there is something up with 10.5.6. It's weird because it was working last week.
     
  3. milk242 macrumors 6502a

    Joined:
    Jun 28, 2007
    #3
    I had the same problem with my 08 mac pro. I just did a clean install and went to install each application i use one at a time and tested the sleep. I noticed after I installed xcode, it would not sleep. I had to reset my pram for it to go back to sleep. It makes no sense to me but those were the results I had.

    You can also try and disable wake for Ethernet administration in the energy saver advanced options menu.
     
  4. omgitscolin macrumors newbie

    Joined:
    Aug 5, 2008
    #4
    Same here. Mine even wakes itself up after a few minutes if I tell it to sleep.
     
  5. si77hay macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Stirling
    #5
    Not a solution, but PleaseSleep may be a potential work-around (worked for me).

    This was discussed recently here
     
  6. Pagemakers thread starter macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #6
    Thanks. That fixed my problem.
     
  7. Pagemakers thread starter macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #7
    Actually it didn't....It's stopped working again :(
     
  8. milk242 macrumors 6502a

    Joined:
    Jun 28, 2007
    #8
    I'm curious, do you have firefox running? (browser window doesn't have to be open)
     
  9. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #9
    I have the same issue as you although with an iMac 24" from last year. I reset the SMC and found out that Internet sharing was on, preventing the sleep. Stopped the Internet sharing and all was good until yesterday when I noticed that my Mac didn't sleep. I only recently installed NetBarrier X5. I'm not sure what the deal is because after an uninstall of NetBarrier the machine still wouldn't sleep automatically.

    I'm the thread starter of the thread that si77hay links to.
     
  10. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #10
    it wont sleep when there is disk activity or a background process is continually cycling to keep the Mac awake. so its probably always a third party applications issue.

    my MacBook Pro didnt used to sleep until i found out the daemon in Fan Control kept it awake.
     
  11. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #11
    richthomas, I don't know where to start. It seems odd this behavior. Because I trust most applications on my Mac I don't know whether it's GlimmerBlocker's daemon or NetBarrier's - Because I did uninstall NetBarrier and that wasn't it. So maybe it's GlimmerBlocker or Antipop(which does send a speak command every 10 or 5(I forget) seconds and is a Launchagent) But I had Antipop installed prior to this and the system slept.
     
  12. Pagemakers thread starter macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #12
    It if set it to sleep after 1 minute it does not, only the screens go off. Setting sleep to 30 mins cures the problem.
     
  13. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #13
    After having uninstalled every LaunchDaemon and tried just about every reset I could find, I narrowed it down to such a simple thing as my ethernet cable. Plugged in; no sleep after 1 minute - unplugged; sleeps after 1 minute.

    I'm going to see if 30 minutes will make a difference. Edit: no, 30 minutes does not help one bit. Thank goodness for Please Sleep.
     
  14. shiny-blanket macrumors member

    Joined:
    Sep 21, 2007
    #14
    I've had the same problem with my 2008 2.8 octo.

    Have you got it hooked to an ACD?
     
  15. Pagemakers thread starter macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #15
    Been out all day, got home to find the screens off and the computer not sleeping.

    I thought these problems only existed in Vista!
     
  16. Pagemakers thread starter macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #16
    Will anybody's Pro auto-sleep after 1 minute?
     
  17. j2048b macrumors 6502a

    Joined:
    Feb 18, 2009
    Location:
    Cali
    #17
    I installed the smcfancontrol and i believe that after this my mac pro 2.8 8 core would not fall asleep any more!

    I did download the please sleep and it seems to work but ...

    if i am running ps3 media server i d not want it to sleep,

    so is there a way to make it so my computer does not go to sleepwhile this app is running?


    Thanks!
     
  18. Pagemakers thread starter macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #18
    Sleep is just hit and miss for me even after an archive install. It sleeps one time and then will not the next.
     
  19. raziel777 macrumors regular

    Joined:
    Apr 3, 2009
    Location:
    League City, Texas
    #19
    I had this issue at first with my 09 2.66 quad core. Did as you, archive and install, and haven't had any problems since.
     
  20. McShizzel macrumors regular

    Joined:
    Oct 29, 2008
    Location:
    Canada
    #20
    Never found out what was causing the problem, I just learned to live with it at least till Snow Leopard comes out (Fresh install).

    And no my computer won't go to sleep if I set it to 1 minute or 15 minutes but I haven't tried 30 min.
     
  21. TheNightPhoenix macrumors 6502

    Joined:
    Dec 16, 2005
    #21
    Interesting, I just tested mine, the screen went to sleep but the machine didn't.
    I did a clean install when I got mine. I don't really care though as I never normally set it to auto sleep.


    Edit:
    Just had a thought, and realised why mine wouldn't sleep!
    I have Transmission running, it has the option to stop sleep if it's actively transferring, perhaps you have this installed?
     
  22. Pagemakers thread starter macrumors 68000

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
  23. milk242 macrumors 6502a

    Joined:
    Jun 28, 2007
    #23
    Have you tried shutting down all your programs fully and setting your sleep to 15 mins and see if that works? Works for me...
     
  24. grue macrumors 65816

    Joined:
    Nov 14, 2003
    Location:
    Somewhere.
    #24
    Did you all do migrations from old machines? It causes a hell of a lot of weird issues
     
  25. Sdancott macrumors regular

    Sdancott

    Joined:
    Mar 9, 2008
    Location:
    Sheffield, UK
    #25
    What's the point in having Migration Assistant then? - Just to cater for those who are moving from machine to machine in the current generation?

    Seems a bit daft...
     

Share This Page