Problem when scanning to PDF with Sierra 10.12.2

Discussion in 'macOS Sierra (10.12)' started by BeeeGeee, Jan 13, 2017.

  1. BeeeGeee macrumors newbie

    Joined:
    Jan 13, 2017
    #1
    It seems impossible to scan any document and getting a PDF doc in a correct weight when using Sierra X10.12.2.

    I use an Epson XP-760 with an iMac 27". Still now, scanning was really simple and efficient, scanning an A4 document at 200 ppp allowed me to get a PDF doc with a reasonable weight, between 180 and 300 ko.

    But that was before the update to Sierra 10.12.2, because now, the same document, scanned at the same resolution generates a 7,9 Mo PDF!!! Impossible to share it by message or mail...

    If you convert to another format, jpeg, you get a correct size, around 250 ko.

    If using the Epson EasyScan software (ugly and absolutely not ergonomic), the PDF is in correct size.

    It seems Apple support does'nt know the problem and suggested this could come from Adobe AcrobatReader etc etc.

    Then I did the same operation (A4, 200ppp, PDF) with the same printer but with a MacBook pro but still with El Capitan 10.11 OS: the PDF was around 280 ko.

    After that, updated the MacBook Pro to Sierra 10.12.2 and you know what? I got a 7,9 Mo PDF !!!

    Let's hope the next update 12.3 will fix the overweight problem of the PDF's!
     
  2. Lunder89 macrumors 6502

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark
    #2
    Interesting, I hadn't noticed that.

    I have tried doing a couple of exports to PDF in order to see if I could find some kind of a word around, but no such luck. Some 3rd party software could properly shrink the files down.

    I assume you are using Apples Image transfer app?

    I have reported the bug to Apple, maybe if enough people should loud enough, they will hear...
     
  3. BeeeGeee thread starter macrumors newbie

    Joined:
    Jan 13, 2017
    #3
    Hello Lunder.
    No I do not use Image Transfer app.
    The printer is added to the dock.
    When I need the scanner I open the printer via the doc and click to the scanner icon.
    The scanner interface is the same than when using Image Transfer.
    I tried also scanning to PDF via image transfer and got the same overweight PDF.
    Yes I reported the bug to Apple.
     
  4. Kornelis, Jan 16, 2017
    Last edited: Jan 16, 2017

    Kornelis macrumors member

    Kornelis

    Joined:
    Dec 4, 2010
    Location:
    Amsterdam, NL
    #4
    Apple changed the code base of the PDF framework in Sierra, from what I understand of it they wanted to bring the old but solid macOS code base in line with iOS. They introduced this in Sierra, this was the reason why there were problems with the ScanSnap software, maybe other scan software is also effected. It looks like 10.12.2 made the problems worst.

    http://www.macrumors.com/2017/01/03/macos-sierra-users-avoid-broken-preview-edit-pdfs/

    It feels like discoveryd all over again. This is the reason why I don't upgrade my main Mac to the newest version of macOS as soon as it comes out. I prefer to wait until two or three updates come out before doing so.
     

Share This Page