Problem with automatic tabs in Sierra

Discussion in 'macOS Sierra (10.12)' started by ccrunner_tj, Sep 23, 2016.

  1. ccrunner_tj macrumors member

    ccrunner_tj

    Joined:
    Nov 20, 2010
    Location:
    West Lafayette, IN
    #1
    I'm having an issue with the tabs feature in Sierra - I use VMware Fusion to run a Windows VM at work, and sometimes I like to use both of my displays for the VM in full screen if I'm hunkering down in the Windows environment. So I turn on the option in VMware to use all displays in full screen, and previously it worked fine. After upgrading to Sierra, the tabs feature makes the new window show as a tab on my primary display in the VMware window as opposed to opening on the second display.

    I've tried right clicking on the new tab to move to a new window, but the whole window moves to the second display, and then a new window is opened that is just black and also on the second display. I got it to work one time using this method, but then when the computer went to sleep and woke back up, I had the same issue. It's inconsistent, and seemingly now I can't get it to work again.

    Is there a way to turn off the auto tab feature in Sierra? I remember reading that developers would not need to adopt the behavior, but it seems for this particular application the results are not the best.
     
  2. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #2
    Yes, you can disable the automatic tab creation when in full screen from System Preferences -> Dock.
     
  3. ccrunner_tj thread starter macrumors member

    ccrunner_tj

    Joined:
    Nov 20, 2010
    Location:
    West Lafayette, IN
    #3
    That fixed it! Thanks so much. I peeked around in System Preferences before making the thread but nothing popped out. Didn't think to check in the Dock section though.
     

Share This Page