Problem with fantastical

chalmers4three

macrumors member
Original poster
Jul 15, 2012
68
2
i love the app but it keeps asking for my ical icloud password. i click for it to remember it in the key chain but it keeps popping up. anybody else having this issue?
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,642
9,261
California
i love the app but it keeps asking for my ical icloud password. i click for it to remember it in the key chain but it keeps popping up. anybody else having this issue?
Working fine for me.

Try this... quit the app then delete Fantastical prefs and cache by running the following two terminal commands.

Then start the app and reenter the iCloud info.


Code:
rm –f ~/Library/Preferences/com.flexibits.fantastical.plist
rm –rf ~/Library/Caches/com.flexibits.fantastical
 

bkuehn

macrumors newbie
Aug 28, 2012
1
0
Having the exact same problem.

Resetting preferences did not do the trick. Running Mountain Lion.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,642
9,261
California
Having the exact same problem.

Resetting preferences did not do the trick. Running Mountain Lion.
I see others in their Twitter feed are having the same problem and they were told to contact support for help.

I am using the Mac App Store version. Maybe you are using their direct DL version (?) and that is the difference. :confused:
 

charlieegan3

macrumors 68020
Feb 16, 2012
2,395
14
U.K
if it this to do with the app store/dl version...

i can report I am using the app store version and it also works.
 

gmar424

macrumors newbie
Nov 17, 2012
1
0
i love the app but it keeps asking for my ical icloud password. i click for it to remember it in the key chain but it keeps popping up. anybody else having this issue?
Not sure if you use your google account with iCal/Fantastical, but I do and I was having the same problem. Got it resolved. I went into Keychain Access and used Keychain First Aid. Verified and Repaired. Not sure if you need to do that. After that, I found and highlighted the www.google.com password. From there, I clicked the info button and the Access Control tab. I allowed all applications access. Not sure if this will work for you, but it's what I did and I no longer have the issue of it asking me to log in every time I quit and restart the program. Good luck.
 

DRGN89

macrumors member
Jan 28, 2011
52
0
I think I found the solution to this problem. If you check your keychains for p11-caldav.icloud.com, double click, click on access control tab, and check on "allow all applications to access this item". I assuming this has to be done because there may be other applications that work with Fantastical to sync dates and reminders within iCal and iCloud. The only way I think you can avoid check off "allow all applications to access this item" is if you can pinpoint any applications that can be affected by it.
 

jonathan999

macrumors newbie
May 12, 2010
13
0
Pirated?

Not sure if you use your google account with iCal/Fantastical, but I do and I was having the same problem. Got it resolved. I went into Keychain Access and used Keychain First Aid. Verified and Repaired. Not sure if you need to do that. After that, I found and highlighted the www.google.com password. From there, I clicked the info button and the Access Control tab. I allowed all applications access. Not sure if this will work for you, but it's what I did and I no longer have the issue of it asking me to log in every time I quit and restart the program. Good luck.
To the few people who have mentioned the keychain fix for this issue.
Are you using a patched copy of the program?
The #1 reason I can think of for OS X to not grant ongoing keychain access to an application is it that application no longer passes whatever check it does to ensure the application has not been modified. It will compare the application with a signature and determine if it is in its original state. If the application does not pass this check, it is likely OS X will not grant the application access to the keychain. Fantastical when then have to prompt you each time it requires the password.
By setting the Key in question to allow all applications to access it, you effectively turn off the application check.
 

allpar

macrumors 6502
May 20, 2002
299
35
At the risk of reopening a dead thread, I just went through the fix: Keychain Access, find the Goo. Calendar password, remove access to Fantastical, restore access. In my case, I am pretty sure the problem was an upgrade breaking the access permissions.
 

spwla

macrumors newbie
Oct 24, 2013
1
0
"Allow All Applications to Access This Item" Keychain Password Prompt SOLVED v1.3.9

I think I found the solution to this problem. If you check your keychains for p11-caldav.icloud.com, double click, click on access control tab, and check on "allow all applications to access this item". I assuming this has to be done because there may be other applications that work with Fantastical to sync dates and reminders within iCal and iCloud. The only way I think you can avoid check off "allow all applications to access this item" is if you can pinpoint any applications that can be affected by it.
To the few people who have mentioned the keychain fix for this issue.
Are you using a patched copy of the program?
The #1 reason I can think of for OS X to not grant ongoing keychain access to an application is it that application no longer passes whatever check it does to ensure the application has not been modified. It will compare the application with a signature and determine if it is in its original state. If the application does not pass this check, it is likely OS X will not grant the application access to the keychain. Fantastical when then have to prompt you each time it requires the password.
By setting the Key in question to allow all applications to access it, you effectively turn off the application check.
Just wanted to confirm that the "Allow All Applications to Access this item" option in Keychain Access for the ...caldav.icloud keychain item DID in fact solve the issue of the persistent password prompt upon fantastical startup. Thank you DRGN89 and jonathan999 :D
 

Jason_G

macrumors member
Feb 24, 2009
61
7
London, UK
Got the same problem, just sent them this:

My Mac just crashed and when I started up again, I launched Fantastical. It prompted me with a message about a database repair and since then I can no longer add my iCloud account back in, despite creating a new app-specific password.

I have tried the steps on your article as per:

Go to the Finder and press command-shift-G
Copy and paste the following into the window that appears: ~/Library/Containers
Move the folder named com.flexibits.fantastical2.mac to the Trash (this is the only folder you have to move)
Restart your Mac
Open Fantastical and set up your accounts again
I am running:

Fantastical 2 for Mac 2.2.5 (386)
OS X El Capitan 10.11.6
iMac (Retina 5K, 27-inch, Late 2014)