Problem with Safari on iPad 2

Discussion in 'iPad' started by jason1790, Mar 27, 2011.

?

Do you have this problem with your iPad 2?

  1. Yes

    54.4%
  2. No

    45.6%
  1. jason1790 macrumors member

    Joined:
    Apr 27, 2010
    Location:
    Iowa City, IA
    #1
    Hey guys. I just want to see if anyone else is having this problem. It does not bother me at all just curious.

    This has happened 2 times since I got my iPad. (Got it at 5pm on launch day). When I am using safari, back out to the home screen, and open safari again it will not show the page I was viewing. I reload the page, the blue bar goes across the URL and fully loads but the screen stays white. You can see when I click the new tab window that the pages load but the white screen is stuck over the web page.

    Is anyone else having this problem?

    Oh.. I also did the Xcode thing from my computer (not the app store) to get the extra gestures. I do not know if this has anything to do with it.
     

    Attached Files:

  2. xraytech macrumors 68020

    Joined:
    Mar 24, 2010
    #2
    I get that every time I tap a YouTube link in Safari. After tapping the YouTube link, the screen switches to the YouTube App to view the video. When I navigate back to Safari I get blank screen like you described. I think it's a bug in iOS 4.3.1
     
  3. xraytech macrumors 68020

    Joined:
    Mar 24, 2010
    #3
    Yeah, I just replicated it.

    At least for me, it happens when I tap a YouTube link that force my iPad to navigate to the YouTube App.

    I do have Gestures, but the issue was present before I enable them.
     
  4. miamialley macrumors 68030

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    Los Angeles, CA
    #4
    I thought this was a known error fixed by the 4.3 update this week. (4.3.1?)
     
  5. xraytech, Mar 27, 2011
    Last edited: Mar 27, 2011

    xraytech macrumors 68020

    Joined:
    Mar 24, 2010
    #5
    Going to try to restore to 4.3 and see if that fixes it.

    Yikes!!! Downloading 4.3 and it's taking a while.

    Back in a few.

    @jason1790 What iOS version are you running?

    Update:

    Stopped downloading 4.3 taking way to long for some reason.
     
  6. jason1790 thread starter macrumors member

    Joined:
    Apr 27, 2010
    Location:
    Iowa City, IA
    #6
    I'm running 4.3.1. It happened when I had 4.3 as well.

    Now that people have mentioned it, it does happen when ever safari sends me to the YouTube app. At least now I know where the problem is coming from.
     
  7. xraytech, Mar 27, 2011
    Last edited: Mar 27, 2011

    xraytech macrumors 68020

    Joined:
    Mar 24, 2010
    #7
    Yeah, it's Safari. The quick fix is to use a 3rd Party browser like Skyfire or Atomic where YouTube videos run in the browser.
     
  8. xraytech macrumors 68020

    Joined:
    Mar 24, 2010
  9. Pballer110 macrumors 6502

    Joined:
    Nov 3, 2010
    #9
    Try Atomic web browser it soo much better than safari
     
  10. steve31 macrumors 6502a

    steve31

    Joined:
    Jul 20, 2007
    Location:
    Edmonton Canada
    #10
    The same here. Happens when YouTube sends you back into browser. Software issue for sure. Apple will fix this issue. Not a big deal.
     
  11. brudog68 macrumors 6502

    Joined:
    Feb 20, 2011
    Location:
    TN USA
    #11
    Ditto
     
  12. elan123 macrumors 6502

    Joined:
    Jan 26, 2011
    #12
    just dont use safari, id say...
     
  13. ShiftyGray macrumors regular

    Joined:
    May 19, 2010
    #13
    Is there another browser that syncs with MobileMe to keep the bookmarks in sync?
     
  14. gatearray macrumors 65816

    Joined:
    Apr 24, 2010
    #14
    When this happens, kill Safari in the task bar before relaunching it and it'll clear the problem, not ideal, but better than a restart and not as painful as migrating your synced bookmarks. :)

    This also happens when clicking a link on some sites that takes you to the App Store app.
     
  15. matapp macrumors newbie

    Joined:
    Mar 28, 2011
    #15
    Safari Problem

    My ipad2 (16gb; wifi, os 4.3.1) bought on Saturday has a similar problem but it appears to be triggered (I think) by use of the twitter app. This causes the safari page to go grey and be not to react to touch, with the exception of the url bar. If I complete a different web address the new web page displays but remains grey and unusable.
    Only way I've found to continue is to reset everything and start again. Use of twitter again causes the problem.
    I am completely new to Apple stuff - does anyone have any ideas as to what I should do. I bought the ipad to use twitter amongst other things!
     
  16. Crosbie macrumors 6502a

    Crosbie

    Joined:
    May 26, 2010
    Location:
    Brighton, UK
    #16
    Don't think it's Twitter since I don't use that app; might be gestures but I seem to remember having this issue before that.

    Certainly had it in 4.3 and 4.3.1, and it persisted between my iPad 1 and 2.
     
  17. Blorzoga macrumors 68030

    Blorzoga

    Joined:
    May 21, 2010
    #17
    So the solution that everyone seems to suggest is to use a different browser? That's ridiculous. This is obviously a problem that should be addressed by Apple. Obviously one could use a different browser but I, for one, like safari and think it should work properly. I'm surprised Apple hasn't fixed this yet.
     
  18. miamialley macrumors 68030

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    Los Angeles, CA
    #18
    What does Safari do that you prefer it over other browsers?
     
  19. Itxdjx macrumors member

    Joined:
    Dec 13, 2010
    Location:
    R.I.
    #19
    Yeah I have the same problem on my iPad 2 on my iPad one I have never had that happened to me! I try to recreate it and only happens on the iPad 2, but I simple ending of the safari app fixes it like stated, I noticed this after the first update that was available to the iPad I noticed it accruing for me.

    I had gone in to get my first iPad replaced thisnlast week at the apple store, and this very problem was happening to me, and I also got into instances when none of the buttons on safari would respond, like refresh, windows tabs, and even bookmarks it would just be frozen! So i asked the genius after he was able to fix my iPad 1 for free! I asked about this problem he told me it wasnt an issue he had herd of. And try a fresh install not from backup! Witch I have not got a chance to do yet.
     
  20. nwcs macrumors 65816

    nwcs

    Joined:
    Sep 21, 2009
    Location:
    Tennessee
    #20
    For me, and others, it's the easy sync of bookmarks. I have Atomic and one annoying thing is keeping my bookmarks in sync with the phone, pad, and computer. So I ended up ditching Atomic. I like it but simple bookmark sync is a valuable feature for me.
     
  21. Blorzoga macrumors 68030

    Blorzoga

    Joined:
    May 21, 2010
    #21
    Honestly, it's not what Safari does, it's the fact that I've tried other browsers and not found them more useful than Safari, so I haven't switched.
     
  22. GP_1 macrumors regular

    Joined:
    Mar 6, 2011
  23. miamialley macrumors 68030

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    Los Angeles, CA
    #23
    That's the only thing I like about Safari.

    You can't tell me you prefer the pages over tabbed browsing!
     
  24. relax42day macrumors newbie

    Joined:
    Sep 1, 2011
    #24
    Problem with Safari on iPad 2

    I have the same problem with the greyed out screen. I've tried deleting history, cookies and Cache. Iava is enabled. Reboot doesn't work either. Screen still shows last webpage, and history of 9 pages intact, but being greyed I can't use it. What else can I try?
     

Share This Page