Problems with ATI Radeon 5770 HD on an early 2008 Mac Pro.

Discussion in 'Mac Pro' started by 8rett, Jan 30, 2011.

  1. 8rett macrumors newbie

    Joined:
    Jan 30, 2011
    #1
    Okay, I have recently upgraded my graphics card to a 5770, I have an early 2008 mac pro, and I have MacOSX 10.5.4 installed.

    I have been playing starcraft 2, and since the upgrade the game throws an error message saying that my card is incompatible with the game.

    I then tried to run Warcraft 3 and get the message that the game is unable to establish open GL and to check that my display drivers are up to date.

    Has anyone else encountered these problems and how do i fix em?
     
  2. mrh63061 macrumors newbie

    mrh63061

    Joined:
    May 30, 2010
    #2
    upgrade to 10.6.4

    You'll need snow leopard 10.6.4 or higher to use that card
     
  3. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #3
    this.
     
  4. goMac macrumors 603

    Joined:
    Apr 15, 2004
  5. gpzjock macrumors 6502a

    Joined:
    May 4, 2009
    #5
    Solution 101

    Buy this: //www.amazon.co.uk/Mac-OS-Snow-Leopard/dp/B001AMHWP8/ref=sr_1_1?ie=UTF8&qid=1296464519&sr=8-1
    Install then hit the Software Update button.
    Job done.
     
  6. 8rett thread starter macrumors newbie

    Joined:
    Jan 30, 2011
  7. AsT1o macrumors newbie

    Joined:
    Feb 17, 2011
    #7
    Hi guys, i have a different problem with, this 5770 on my 2008 Mac Pro...
    when i'm running FrontRow or VLC (in full screen) after a few seconds (with Front Row) and some minute (with VLC) the screen lose brightness.. like as it going to a some kind of sleeping mode... and it turn to normal brightness only if i switch off the full screen mode (VLC) or if i quit FrontRow...
    That's is impossible!! 'cause there isn't a control for this, in the system preferences/energy ecc...
    i've Snow Leopard 10.6.6 currently upgraded...
    I've tried the Pram reset, SMC reset, checked my mac with the Hardware test (nothing wrong), even replace my system HDD with a empty HDD and installed into SnowLeopard and re-upgraded... But nothing has worked!!
    Any ideas??
    i've got a 25" Hannspree monitor DVI-HDMI connector, haven't got any problems before.. (with the 4870 512mb)
     
  8. 8rett thread starter macrumors newbie

    Joined:
    Jan 30, 2011
    #8
    More Problems

    Hey all,

    well got the new OS, installed it, reinstalled starcraft. Still the same messages.
    Please Help!
     
  9. JDrive macrumors member

    Joined:
    Jun 3, 2010
    #9
    Did you update Snow Leopard to at least 10.6.4?
     
  10. ivan275 macrumors newbie

    Joined:
    Mar 11, 2011
    #10
    Problems for me, too!

    I installed the 5770 (kit from Apple) in my Jan 2008 Mac Pro, and now, every so often, the screen turns "fuzzy," like pixels are jumbled. I can reboot and the problem goes away for a little while.

    I have Snow Leopard 10.6.6 installed. Anyone know of any issues like this? Any updates for the 5770 I need?
     
  11. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #11
    I have been running a 5770 in my early macpro for 3 months now with no issues.
     
  12. handheldgames macrumors 6502a

    handheldgames

    Joined:
    Apr 4, 2009
    #12
    How is the noise on the 5770? I'm running a 4870 and would appreciate a little less noise.
     
  13. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #13
    Less heat, lower noise, better cooler. Slower in Dx9. Faster in Dx10.
     

Share This Page