Question using Gmail on iphone...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MrCompletely, Jun 30, 2007.

  1. MrCompletely macrumors newbie

    Joined:
    Jun 30, 2007
    #1
    Everytime i write a message to someone, it shows up in my inbox as a new mail. Is there a way to keep sent mail out of the inbox?
     
  2. TaylorB macrumors regular

    Joined:
    Oct 13, 2006
  3. dagrouch macrumors member

    Joined:
    Jun 4, 2007
    #3
    I'm not quite sure, but I think it has to do with how gmail groups messages into "conversations". I double checked that I wasn't CC'ing or BCC'ing myself, and that the option to do it automatically was off, but it still ended up in my inbox.

    In gmail, if you were to reply to an email, then view the whole conversation thread, the one you just sent is automatically in there, viewable in your inbox. So I think it's a "feature" of gmail that doesn't quite port to a non gmail interface.
     
  4. TaylorB macrumors regular

    Joined:
    Oct 13, 2006
    #4
    that makes sense, it would be nice if it would be in a different box like conversations or something, or atleast an off/on switch or something
     
  5. Furgster macrumors 6502

    Furgster

    Joined:
    Jun 16, 2007
    #5
    ya, my brothers are having problems with this, i hope it gets fixed somehow :eek:
     
  6. Kocab macrumors newbie

    Joined:
    Nov 25, 2006
    #6
    I believe that's the way that Gmail works on with any remote POP client. (You see the same behavior in Mail.app at any rate.)

    The official Google stance is that this is a "feature" and not a bug - and is needed server side to handle the way messages are threaded.

    You can work around this behavior (I've read) by creating a filter in Gmail that takes messages that you write from your return address and archiving them (and skipping the inbox with them.)
     
  7. MrCompletely thread starter macrumors newbie

    Joined:
    Jun 30, 2007
    #7
    will that filtering method mess with the way the convos work when using gmail through a browser?
     
  8. TaylorB macrumors regular

    Joined:
    Oct 13, 2006
    #8
    whenever I reply to something from the mail app I don't receive a new email in my inbox, so I don't understand why this :confused: is doing it.:confused:
     
  9. chriswheat macrumors regular

    Joined:
    Jun 26, 2007
    #9
    It's taken me some time but I've got it figured out:

    By default, GMail on the iPhone is enabled in 'recent mode' where it pulls down your 25 (or 50 or whatever) most recent emails. In this mode it is not actually acting as a true POP3 email client. When the messages download, they are not being cleared out of your inbox.

    That being said, and establishing that it's not operating as the standard mail.app would on a Mac, it operates almost as if you were just using GMail's web interface as far as sending mail is concerned.

    To understand, go to GMails web interface, send a message to someone. Then look at Mail.app on your Mac. The next time it retrieves mail, it will receive the message you sent. This is due to the way that GMail's archive folder is set up. Since messages are essentially in one giant folder, Mail pulls all messages that have not been previously downloaded.

    So when you access it on your iPhone, you are essentially looking at the 25 (or whatever) most recent emails, which includes emails you sent.

    You can disable recent mode on the iPhone by going to the advanced mail settings. This will cause the iPhone to operate more like Mail.app, pulling messages off the server using POP3. Do note however, that if a message is downloaded to your iPhone, it will not be available to be downloaded later to your Mail.app.
     
  10. TaylorB macrumors regular

    Joined:
    Oct 13, 2006
    #10
    But i get my email forwarded automatically to mail.app, so does this mean if i turn that feature off i wont get it forwarded to mail.app?
     
  11. otis123 macrumors 6502a

    Joined:
    May 4, 2006
    #11
    i use gmail and mail.app and this never has happened to me
     
  12. mac000 macrumors 6502a

    Joined:
    Sep 6, 2005
    #12
    its not an issue its just Gmail - i know bc i had a blackberry and i had to change filters .

    i have no idea how to work around the filters for the iphone, if someone gets to the bottom of this please speak up!
     
  13. Furgster macrumors 6502

    Furgster

    Joined:
    Jun 16, 2007
  14. MBHockey macrumors 68040

    MBHockey

    Joined:
    Oct 4, 2003
    Location:
    New York
    #14
    you can, but the down side is that any mail fetched by any other client (marked as read on the server) will not get downloaded to your iPhone.

    Just set up a filter to send messages FROM: yourgmailaddress@gmail.com to get archived (skip in box) and you're all set.
     
  15. TaylorB macrumors regular

    Joined:
    Oct 13, 2006
    #15
    okay, I will have to try this, thanks
     
  16. epochblue macrumors 68000

    epochblue

    Joined:
    Aug 12, 2005
    Location:
    Nashville, TN
    #16
    I tried the trick mentioned above (auto-archive messages from yourself), but that didn't do anything. Still getting mails from myself...

    ...any other ideas?

    And do I understand this correctly? That if I get turn off recent mode, the mails I get on my iPhone won't show up in my Mail.app inbox?
     
  17. MBHockey macrumors 68040

    MBHockey

    Joined:
    Oct 4, 2003
    Location:
    New York
    #17
    With recent mode "on" it downloads the most recent messages regardless if they have been pulled by another client prior to your accessing them. With it off, if it has been pulled by another client, iPhone will not download it (it must me marked as unread on the server).
     
  18. MrCompletely thread starter macrumors newbie

    Joined:
    Jun 30, 2007
    #18
    Will using this method keep those messages out of the 'conversation threads' when accessing gmail through the website inbox? For example, If I respond to my friends email via the website, will my response not show up in the conversation like it usually does and just show his emails to me?


    EDIT: I tried this method and it didn't work. Secondly, I tried the method in turning off recent mode, and it wouldn't retrieve mail altogether! I'm think Gmail might need to make some changes for this to work correctly.
     
  19. sixth macrumors 6502

    Joined:
    Aug 16, 2006
    #19
    I have the same problem, no matter what I do it STILL tries to pull in say 25 messages...its stupid.
     
  20. ZachBrock macrumors newbie

    Joined:
    Jun 29, 2007
    #20
    Don't forget to double check your POP settings in GMail. Usually people set it not do anything to messages when a POP client downloads them.
     
  21. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #21

    I've got my Gmail POP settings to archive mail once downloaded. Even with this setting the iPhone manages to d/l mail I've already retrieved on my computer. It's maddening.

    Anyone know if there is a way to make this stop so it only d/ls NEW mail?
     
  22. buriedpaul macrumors newbie

    Joined:
    Jul 3, 2007
    #22
    I'm having the same problem -- sent emails showing up as new emails in the inbox on my iPhone. Setting up the filter suggested above didn't resolve the problem. Has anyone called Apple about this?
     
  23. joekix macrumors 6502

    joekix

    Joined:
    Feb 2, 2007
    Location:
    earth, long beach CA to be exact
    #23

    worked for me. did you have the filtered mail sent to trash?
     
  24. buriedpaul macrumors newbie

    Joined:
    Jul 3, 2007
    #24
    I just tried setting the filter to "delete" (I didn't see a "send to trash" option); that results in an error every time I send an email from the Gmail web page. So that's not an option. Does anyone have any other ideas?
     
  25. amberashby macrumors 6502

    Joined:
    Nov 6, 2003
    #25
    I just did this and it works.

    Go to gmail settings, filters, in the from box type "your name" and click next step, then click "delete it" then click update filter. Let me know if this helps.
     

Share This Page