Race to dump the 4870 ROM, Who's first?

Discussion in 'Mac Pro' started by MacVidCards, Mar 4, 2009.

  1. philsurmac, Sep 16, 2015
    Last edited: Sep 17, 2015

    philsurmac macrumors newbie

    philsurmac

    Joined:
    Dec 7, 2009
    Location:
    Montpellier, France
    #2751
    A million years later... flashing my Hynix with your rom (and flashed it with at least 37 other roms) and nothing succeeds. The thing is that as soon as I get the boot screen and the card is correctly recognized by OS X, but Yosemite is laggy (like when you use a 7300GT on a Mac Pro 1,1).. and I actually hear the fan always at high (not full) speed.

    I've read maybe 80% of this thread, tried many things, but I can't get Yosemite smooth..

    EDIT : it seems I have an old version of the 4870 and it doesn't have OpenCL or something like that. So Yosemite wouldn't work properly. I need to get rid of it and ONLY buy the same design of heatsink..
     
  2. autoexec1 macrumors newbie

    Joined:
    Oct 2, 2015
    #2752
    Had a Problem with this rom on a Card that looks nearly similar.

    Ive Made a Rom for it! - Ive Tested it on my Mac Pro 1.1 (Flashed to 2.1) - works Perfectly. - For Flashing i Used MSdos and ATIFLASH on a Windows PC

    the Details:
    HD4870 512M GDDR5 PCI-E DUAL DVI-I/TVO
    PN 102-B50701-10-AT
    SKU# 21133-00

    i used another Card with a SKU #11133-00 (The Design of the Card looks the same) - if you Flash my rom or the rom from Moop the card will stop Working. - i try to get the PC rom for it and create another rom for you.
     

    Attached Files:

  3. Macpro 1.1 user macrumors newbie

    Joined:
    Mar 5, 2016
    #2753

    Hello Roger,
    I see lthis is a very old post, but did you manage to flash it correctly, Just bought a macpro 1.1 and bought exactly this card. there are so many rom's and i'm affraid trying something will wreck my card.
    Thanks in advance..
     
  4. kief macrumors newbie

    Joined:
    Mar 14, 2015
    #2754

    geez, I wish I could help you guys, maybe I can in a few weeks. I had an ati 4870, the red one that says ATI radeon, and ATI on the fan... It took me forever to find the correct method... The card was working for me, but I had no boot screen. Then finally, I found a good method, and the right rom, and now it works correctly like a stock apple 4870.

    I'll try to get that hard drive back in my mac pro, where I did all that stuff, and upload the rom and utility which worked, just give me a few...

    here's a link to the picture of my card, let me know if yours is the same, otherwise, it might not be the right rom.
     
  5. Macpro 1.1 user macrumors newbie

    Joined:
    Mar 5, 2016
    #2755
    Thanks for you reply,
    This is my card, it's different, i think it will be hard to find the right rom.
    was searching for day's.
    Best regards Nico
    4870.JPG 4870card.JPG
     
  6. kief macrumors newbie

    Joined:
    Mar 14, 2015
    #2756
    Yes that is a different card then mine, so I bet you need a different rom. Do you think you need a new method of flashing the rom, because I can try to find the exact method I used...
     
  7. AshleyAshes macrumors newbie

    Joined:
    Jul 30, 2016
    #2757
    I'm hoping for some help here. I have a Diamond Radeon HD 4870 1GB version and I'm trying to find a compatible ROM for it. I've found a lot of examples of the 512mb ROM but not of the 1GB ROM. Searching I found people with working cards but no posted ROMs. Could somebody point me in the right direction if possible? Are there ROMs from other 1GB cards that may 'just work' on the Diamond model?
     
  8. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
  9. AshleyAshes macrumors newbie

    Joined:
    Jul 30, 2016
    #2759
    All current versions of Zeus out there seem to be rather broken, missing the 'EFIROM.ROM' file that's necessary, and that's about where I got lost.
     
  10. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #2760
    All you need is in this thread. And it isn't Zeus.
     
  11. AshleyAshes macrumors newbie

    Joined:
    Jul 30, 2016
    #2761
    I don't mean to sound all 'Wah, do it for me' but I've been searching back and forth through this thread with no luck other than guides for Zeus. But it's 111 pages and it's a lot to read through and searching does only work well when you know what the search. The first post hasn't been edited with newer information so I'm just at a loss here. I'm at least going to need more information than 'In this thread'? Though I'm guessing now Zeus has become depreciated?

    This is the stock ROM ripped off the card, I got that far, little help?
     

    Attached Files:

  12. CapnDavey macrumors 6502

    CapnDavey

    Joined:
    Apr 11, 2015
    #2762
    Ashley the ATI 4870 is one of the easiest cards to flash there are so many different cards so you need to dig around and find the right rom for your card. flashing from a DOS prompt works best good luck
     
  13. AshleyAshes macrumors newbie

    Joined:
    Jul 30, 2016
    #2763
    All my reading said I could just modify the ROM with Zeus. But the last build of Zeus is missing the EFIROM.ROM file in it's most recent build that's necessary and older versions I have had no luck finding. I've now been told Zeus isn't the software to use but 666sheep wasn't actually willing to tell me what software to use. I haven't bumped into the answer as I search for keywords though this thread and just reading 111 pages doesn't seem practical.

    To the best of my ability I have been unable to find a prepared from for the 1GB model from Diamond. The 512mb model I found but I'm pretty sure it would be monumentally stupid to flash the 512mb or any other random HD 4870 ROM onto the card.

    Flashing the ROM to the card isn't the challenge. It's the ROM in the first place.
     
  14. Mdaws, Nov 15, 2016
    Last edited: Nov 16, 2016

    Mdaws macrumors newbie

    Joined:
    Nov 15, 2016
    #2764
    Hi guys,

    Firstly, a big thanks to everyone who's contributed here, there is a wealth of info I've lurked over for a long time, and I'm happy to now be a member! I just bought my first Mac Pro about two weeks ago and was very excited! It has been a painful road trying to get it running well but I can see the light at the end of the tunnel while getting stuck on the last step.

    The computer is a Mac Pro 1.1 with 2 2.66 GHz Xeon 2 core processors, SSD, 32GB RAM and stock Nvidia GT7300. I'm running 10.9.5 through Taimo's EFI booter. I'm trying to install a ATI Radeon HD 4870 1GB graphics card to stabilize the graphics (I've got a flickering screen currently).

    I have the extra 2 power cables installed, I am coming out DVI and connecting to my monitors through the VGA port (I've tried DVI-D as well). I have tried to flash the card but I am getting no display out of it. Before I flashed it, I could have both cards installed, connect my monitor to the GT7300 and see it was listed in "about this mac > more info" but you still couldn't use it (black screen). Naively, I did't backup the original BIOS firmware. After flashing the Radeon, my Nvidia GT7300 doesn't work unless the Radeon is removed. So I can't see if the computer is registering the Radeon or not.

    From what I read prior to buying it, it should have worked without the EFI flashed, I would just miss out on the boot screen. So do I have a problem with the card?

    Again, a big thank you and hopefully someone can shed some light!

    Cheers,

    Matt
     
  15. Mdaws macrumors newbie

    Joined:
    Nov 15, 2016
  16. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #2766
    In this thread you should find what 1GB cards work and what don't (not all do). That's the first step. If your is one that works, find an original BIOS for it (techpowerup) and re-flash in a PC or in a Mac using EEPROM pins short trick.
    Test it if it's OK. If you'll recover it you need to make a custom ROM for it. Or throw it to the bin right now and find yourself a good 5770, 5870, 7950 etc :p That's the easy way.
     
  17. Mdaws macrumors newbie

    Joined:
    Nov 15, 2016
    #2767
    Hi 666sheep, thanks for the reply! Is there a complete list of cards that will just drop in? When you say a "good" 5770 etc. are there certain ones that work or don't (such as with the 4870's)? Or do they all work and only mac/flashed pc ones give a boot screen? Do these models all support dual screens and VGA ports or do they also have some of the quirks of the 4870?

    Again, I can't thank you enough! All this forum digging for new-to-me info is leaving me dizzy!

    Matt
     
  18. Fangio, Nov 19, 2016
    Last edited: Nov 19, 2016

    Fangio macrumors 6502

    Joined:
    Jan 25, 2011
    #2768
    Your 7300GT is dying, a common prob and a series error with this one. If you want to rescue it go to a capable AASP that knows how to solder and have him replacing the two condensators in this pic, they are probably bloated already.

    As for the 4870, can only repeat – all one could want to know is in this thread. Quite a desireable card back in the day, lots of reverse engineering was spent on it, unfortunately you'll just have to take your time.

    For a newer AMD card, going with a model as close as possible to the reference design is always highly recommended. For 5770 for example that would mean 2x DVI & 1x DP, 1x HDMI. Regarding a proper EFI there has been quite some progress in the meantime, have a look here.. although this is not a short read either. ;)
     
  19. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #2769
    Nope. There's no other 1x DVI + 2x mDP 5770 than Apple one. Reference design is 2x DVI + DP + HDMI in this case ;)

    Mdaws: there's no list at all. In this thread you'll find post by users who flashed their cards successfully (and unsuccessfully too) and most of them were describing exact models they had.
    No reading – no knowledge.
     
  20. Fangio, Nov 19, 2016
    Last edited: Nov 19, 2016

    Fangio macrumors 6502

    Joined:
    Jan 25, 2011
  21. nickrick macrumors newbie

    nickrick

    Joined:
    Nov 29, 2011
    #2771
    Hi I didn't find so far a ROM for

    XFX Ati Radeon HD 4870 512 MB
    HD-487A-YH HD-487A-YHDC VA.2

    I read that XFX card can't use standard mac 4870.rom and I'm sure that ROM for XFX Ati Radeon HD 4870 1GB won't work on my card.

    Can someone share ROM for my card?

    Thx
     
  22. cornflakes1023 macrumors newbie

    Joined:
    Oct 23, 2016
    #2772
    I have an ASUS EAH4870 Dark Knight 4870 that I am attempting to create a rom for using the pipomolo42 method but I get the "dd: bs must be between 1 and 9223372036854775807" error. I have made sure that the stock rom is named pc4870.rom. Any ideas?

    Alternately, does anyone have a working EFI rom for this card? It has dual DVI and S-video but the S-video port is at the end, not in the middle.

    Stock rom attached. If anyone can help with this, I would greatly appreciate it. Thanks!
     

    Attached Files:

Share This Page