RAID on El Capitan (Lacie little big disc)

Discussion in 'OS X El Capitan (10.11)' started by flimpy, Jan 13, 2016.

  1. flimpy macrumors member

    Joined:
    Dec 21, 2015
    #1
    This is probably no news for anyone at this point.. just wanted to share my frustration and I hope my experience will also be useful for other people who use RAID drives.

    I remembered Apple's screw-up with wi-fi on Yosemite, so I decided to wait for a while before upgrading to El Capitan. About a month ago I thought it's probably safe now and I upgraded to El Capitan.

    All seemed to be fine, until I started to use my Lacie 4TB little big disk. It would randomly disappear from the system and will or will not show up if being re-connected. Later on it just disappeared and did not want to show up at all.

    I googled this issue and found that if you restart El Capitan in safe mode - it will show up and it will stay there (at least for some time) if you will then restart El Capitan again and boot it normally (not in safe mode). It did work for a bit, but was irritating as hell. I decided to rebuild RAID and re-format drive - this is where I discovered that El Capitan does not support RIAD drives. It left me speechless...

    I had to unRAID my drives and now I am using it as two separate drives which delivers half of the RAID speed.

    Nice work, Apple, you keep going downhill, destroying everything I liked in you bit by bit.
    It is hard to understand these morons, that make these kind of decisions in Apple (like giving up RAID support), how in the hell have they got their job and manage to keep it... unbelievable.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    El Capitan certainly does work with RAID. What you may have read is the RAID tools were removed from Disk Utility in El Capitan and you need to use command line tools in Terminal to configure RAID. But the end result is the same.

    If it worked in safe mode and did not work in a regular mode boot, that sounds like you have some sort of driver or utility from Lacie that is causing this issue. A safe mode boot stops all third party utilities like this from launching, and that would explain why it works in safe mode.
     
  3. flimpy thread starter macrumors member

    Joined:
    Dec 21, 2015
    #3
    Thanks, for the suggestion, but I never installed anything from Lacie. The drive just worked out of the box for ~2 years with Yosemite and Maveriks, never caused any trouble. Things changed after I foolishly upgraded to El Capitan.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Maybe something else running that is causing a conflict then? The fact that it works in safe mode is a big clue that some app or utility that is running is causing the conflict.
     
  5. flimpy thread starter macrumors member

    Joined:
    Dec 21, 2015
    #5
    make sense... thought the only software I installed after upgrade was Norton Antivirus and Adobe CC. I do not think any of these apps would have anything to do with RAID.

    I never messed with RAID before - I do not have any extra utilities or drivers that are related to RAID. It just worked before, not the case anymore. I guess Apple should change their slogan from "It just works" to "It just doesn't work" when it comes to their new software.
     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    Norton Antivirus certainly can (and does) have a negative effect on computer performance. Try disabling it and test to see if your problem disappears.
     
  7. cerberusss macrumors 6502a

    cerberusss

    Joined:
    Aug 25, 2013
    Location:
    The Netherlands
    #7
    Perhaps there are drivers running that you forgot about?

    The following terminal command will list all kernel extensions, then filter out the ones by Apple:

    kextstat -l | grep -v com.apple.

    Note that no output means you only the good stuff :)
     
  8. flimpy thread starter macrumors member

    Joined:
    Dec 21, 2015
    #8
    Thanks for the tip with terminal command.

    This what I get when I run this command:

    [​IMG]

    Can Norton Internet Security really cause RAID disk to disappear from OS X?
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    In addition to those kext files, there can be launch items in any of these folders also. ~ is your users folder.

    ~/Library/LaunchAgents
    /Library/LaunchAgents
    /Library/LaunchDaemons
    /Library/StartupItems

    What I would do is run the utility Etrecheck once. That will create an anonymized report showing all third party kexts and apps or launch items running. Then you can use that report as a worksheet to start removing things until you find the culprit.

    If you like, you can post the report here for us to have a look. Here is an example of what the report looks like.
     
  10. cerberusss macrumors 6502a

    cerberusss

    Joined:
    Aug 25, 2013
    Location:
    The Netherlands
    #10
  11. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #11
    It seems unlikely but it's worth testing.
     
  12. flimpy thread starter macrumors member

    Joined:
    Dec 21, 2015
    #12
    I saw this post when I tried to figure out what was going on, but I could not find this RAID manager app on LACIE website, seems like either they have dismissed this software altogether, or it was not meant to be used with Little Big Disk. New (or old) firmware is not available for my drive either. Besides, none of this was needed before.. it just worked...

    Here is the report (it is huge, my apologies for that):

    Problem: No problem - just checking

    Hardware Information:
    iMac (27-inch, Late 2013)
    [Technical Specifications] - [User Guide] - [Warranty & Service]
    iMac - model: iMac14,2
    1 3.2 GHz Intel Core i5 CPU: 4-core
    24 GB RAM Upgradeable - [Instructions]
    BANK 0/DIMM0
    4 GB DDR3 1600 MHz ok
    BANK 1/DIMM0
    4 GB DDR3 1600 MHz ok
    BANK 0/DIMM1
    8 GB DDR3 1600 MHz ok
    BANK 1/DIMM1
    8 GB DDR3 1600 MHz ok
    Bluetooth: Good - Handoff/Airdrop2 supported
    Wireless: en1: 802.11 a/b/g/n/ac

    Video Information:
    NVIDIA GeForce GT 755M - VRAM: 1024 MB

    System Software:
    OS X El Capitan 10.11.2 (15C50) - Time since boot: about 16 hours

    Disk Information:
    APPLE SSD SM0512F disk0 : (500.28 GB) (Solid State - TRIM: Yes)
    EFI (disk0s1) <not mounted> : 210 MB
    Macintosh HD (disk0s2) / : 499.42 GB (37.21 GB free)
    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB

    ST2000LM003 HN-M201RAD disk1 : (2 TB) (Rotational)
    EFI (disk1s1) <not mounted> : 210 MB
    HDD1 (disk1s2) /Volumes/HDD1 : 2.00 TB (1.10 TB free)

    ST2000LM003 HN-M201RAD disk2 : (2 TB) (Rotational)
    EFI (disk2s1) <not mounted> : 210 MB
    HDD2 (disk2s2) /Volumes/HDD2 : 2.00 TB (2.00 TB free)

    ST1000LM024 HN-M101MBB disk5 : (1 TB) (Rotational)
    BackUP2 (disk5s1) /Volumes/BackUP2 : 1.00 TB (479.93 GB free)

    USB Information:
    Seagate Backup+ RD 1 TB
    EFI (disk3s1) <not mounted> : 210 MB
    Boot OS X (disk3s3) <not mounted> : 134 MB
    BackUp1 (disk4) /Volumes/BackUp1 : 999.50 GB (622.39 GB free)
    Encrypted AES-XTS Unlocked
    Core Storage: disk3s2 999.86 GB Online
    Apple Inc. BRCM20702 Hub
    Apple Inc. Bluetooth USB Host Controller
    Apple Inc. FaceTime HD Camera (Built-in)

    Thunderbolt Information:
    Apple Inc. thunderbolt_bus
    Seagate GoFlex Adapter Thunderbolt
    LaCie Little Big Disk

    Gatekeeper:
    Mac App Store and identified developers

    Adware:
    Adware infection possible.[Scan for adware]

    Kernel Extensions:
    /Applications/Parallels Desktop.app
    [not loaded] com.parallels.kext.hypervisor (10.3.0 29227 - SDK 10.7) [Support]
    [not loaded] com.parallels.kext.netbridge (10.3.0 29227 - SDK 10.7) [Support]
    [not loaded] com.parallels.kext.usbconnect (10.3.0 29227 - SDK 10.7) [Support]
    [not loaded] com.parallels.kext.vnic (10.3.0 29227 - SDK 10.7) [Support]

    /Library/Extensions
    [loaded] com.symantec.kext.SymAPComm (12.7.1f4 - SDK 10.8) [Support]
    [not loaded] com.symantec.kext.filesecurity (12.7f4 - SDK 10.8) [Support]
    [loaded] com.symantec.kext.fw (5.3.1f4 - SDK 10.8) [Support]
    [loaded] com.symantec.kext.internetSecurity (5.5f7 - SDK 10.8) [Support]
    [loaded] com.symantec.kext.ips (3.10.3f7 - SDK 10.8) [Support]
    [loaded] com.symantec.kext.pf (5.7.1f4 - SDK 10.8) [Support]

    /System/Library/Extensions
    [not loaded] com.joshuawise.kexts.HoRNDIS (6 - SDK 10.0) [Support]
    [loaded] com.nvidia.CUDA (1.1.0) [Support]

    Launch Agents:
    [loaded] com.adobe.AAM.Updater-1.0.plist [Support]
    [loaded] com.adobe.ARMDCHelper.cc24aef4a1b90ed56a...plist [Support]
    [running] com.adobe.AdobeCreativeCloud.plist [Support]
    [running] com.bjango.istatmenusagent.plist [Support]
    [running] com.bjango.istatmenusnotifications.plist [Support]
    [running] com.bjango.istatmenusstatus.plist [Support]
    [loaded] com.google.keystone.agent.plist [Support]
    [loaded] com.nvidia.CUDASoftwareUpdate.plist [Support]
    [loaded] com.paragon.updater.plist [Support]
    [running] com.rosettastone.rosettastonedaemon.plist [Support]
    [loaded] com.symantec.errorreporter-periodicagent.plist [Support]
    [loaded] com.symantec.nis.application.plist [Support]
    [running] com.symantec.uiagent.application.plist [Support]
    [running] com.teamviewer.teamviewer.plist [Support]
    [running] com.teamviewer.teamviewer_desktop.plist [Support]
    [loaded] org.macosforge.xquartz.startx.plist [Support]

    Launch Daemons:
    [loaded] com.adobe.ARMDC.Communicator.plist [Support]
    [loaded] com.adobe.ARMDC.SMJobBlessHelper.plist [Support]
    [running] com.adobe.adobeupdatedaemon.plist [Support]
    [loaded] com.adobe.agsservice.plist [Support]
    [loaded] com.adobe.fpsaud.plist [Support]
    [running] com.bjango.istatmenusdaemon.plist [Support]
    [loaded] com.google.keystone.daemon.plist [Support]
    [loaded] com.microsoft.office.licensing.helper.plist [Support]
    [loaded] com.microsoft.office.licensingV2.helper.plist [Support]
    [loaded] com.nvidia.cuda.launcher.plist [Support]
    [loaded] com.oracle.java.JavaUpdateHelper.plist [Support]
    [running] com.symantec.deepsight-extractor.plist [Support]
    [loaded] com.symantec.errorreporter-periodic.plist [Support]
    [loaded] com.symantec.liveupdate.daemon.ondemand.plist [Support]
    [loaded] com.symantec.liveupdate.daemon.plist [Support]
    [failed] com.symantec.nav.migrateqtf.plist [Support]
    [running] com.symantec.sharedsettings.plist [Support]
    [running] com.symantec.symdaemon.plist [Support]
    [loaded] com.teamviewer.Helper.plist [Support]
    [running] com.teamviewer.teamviewer_service.plist [Support]
    [loaded] fi.polar.libpolar.plist [Support]
    [running] fi.polar.polard.plist [Support]

    User Launch Agents:
    [loaded] com.adobe.AAM.Updater-1.0.plist [Support]
    [failed] com.adobe.ARM.[...].plist [Support][Details]
    [loaded] com.jdibackup.ZipCloud.autostart.plist [Support]
    [loaded] com.jdibackup.ZipCloud.notify.plist [Support]

    User Login Items:
    iTunesHelper Application (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

    Other Apps:
    [running] com.adobe.acc.AdobeDesktopService.180832.99682460-27F0-413D-92ED-5DC83448D47D
    [running] com.adobe.accmac.180512
    [running] com.apple.xpc.launchd.oneshot.0x10000018.EtreCheck
    [loaded] com.simplexsolutionsinc.vpnguardhelperMac

    Internet Plug-ins:
    Default Browser: Version: 601 - SDK 10.11
    Flip4Mac WMV Plugin: Version: 3.3.1.3 - SDK 10.8 [Support]
    AdobeAAMDetect: Version: 3.0.0.0 - SDK 10.9 [Support]
    FlashPlayer-10.6: Version: 20.0.0.267 - SDK 10.6 [Support]
    AdobePDFViewerNPAPI: Version: 15.010.20056 - SDK 10.8 [Support]
    Silverlight: Version: 5.1.41105.0 - SDK 10.6 [Support]
    QuickTime Plugin: Version: 7.7.
    Flash Player: Version: 20.0.0.267 - SDK 10.6 [Support]
    SharePointBrowserPlugin: Version: 14.5.5 - SDK 10.6 [Support]
    AdobePDFViewer: Version: 15.010.20056 - SDK 10.8 [Support]
    NortonInternetSecurityBF: Version: 1.11.0 - SDK 10.6 [Support]
    MeetingJoinPlugin: Version: Unknown - SDK 10.2 [Support]

    User internet Plug-ins:
    CitrixOnlineWebDeploymentPlugin: Version: 1.0.105 [Support]
    Google Earth Web Plug-in: Version: 7.1 [Support]

    Safari Extensions:
    Adblock Plus
    Open in Internet Explorer
    Norton Internet Security

    3rd Party Preference Panes:
    CUDA Preferences [Support]
    Flash Player [Support]
    Flip4Mac WMV [Support]
    Norton\nQuickMenu [Support]
    Paragon NTFS for Mac ® OS X [Support]
    Perian [Support]

    Time Machine:
    Auto backup: YES
    Volumes being backed up:
    Macintosh HD: Disk size: 499.42 GB Disk used: 462.21 GB
    Destinations:
    Data [Network]
    Total size: 2.00 TB
    Total number of backups: 90
    Oldest backup: 11/27/14, 8:25 AM
    Last backup: 1/13/16, 1:31 PM
    Size of backup disk: Excellent
    Backup size 2.00 TB > (Disk size 499.42 GB X 3)

    Top Processes by CPU:
    46% TeamViewer_Desktop
    18% WindowServer
    16% mdworker(20)
    3% kernel_task
    2% TeamViewer_Service

    Top Processes by Memory:
    4.87 GB com.apple.WebKit.WebContent(28)
    1.47 GB kernel_task
    811 MB Safari(2)
    737 MB com.apple.WebKit.Plugin.64(3)
    516 MB SymDaemon

    Virtual Memory Information:
    7.88 GB Free RAM
    16.00 GB Used RAM (4.84 GB Cached)
    2 MB Swap Used
     
  13. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #13
    You have a LOT running there, so it makes this harder to troubleshoot.

    How about let's try and put the RAID0 disk back together so we can tell if we are fixing anything to begin with. From the list there it looks like disk1 and disk2 are the two 2TB drives that resulted from the RAID split yes? If so, run the command below in Terminal make a new 4TB RAID0 volume called Storage. You can of course change the name Storage to whatever you want. This will wipe the disks of course.

    Code:
    diskutil appleRAID create stripe Storage JHFS+ disk1 disk2
    Then once that is done, see how it works. If it still won't work, try the safe mode boot again and verify it works properly there. If it does, that is conclusive proof it is one of these launch items causing the problem. There is no magic way to figure out which one is the troublemaker. I would start with Symantec, then iStat, then Parallels. I have seen all three cause El Capitan problems. After that, I would do down the list and remove half at a time until you ID to problem app.

    You can see in the Etrecheck report which of the four folders I mentioned contains the launch item. I would just make a folder on the Desktop to drag these off into so you can put them back later. Use the Etrecheck report as your worksheet to keep track.
     
  14. flimpy thread starter macrumors member

    Joined:
    Dec 21, 2015
    #14
    Many thanks to everyone for suggestions.

    I thought a lot about how I should approach this issue and considered re-installing El Capitan and giving it another chance to work with my RAID disk, but at this point I just have no confidence that it will work.

    My RAID disk worked fine for almost two years and only stopped working after upgrading to El Capitan and installing Norton Internet Security. Internet is overloaded with reports that RAID disks either not recognized or not working right with El Capitan and there is nothing that suggests that Norton may cause this issue. I do not see the point in looking into other software (other than Norton), since my RAID worked fine on Yosemite WITH all that software installed.

    Having said that, I doubt that Norton is responsible for issues with my RAID and I think it does not worth an effort trying to see if my RAID disk will work with fresh installation of El Capitan. I will go back to Yosemite (or even Mavericks), with which my RAID disk just worked without any extra effort from my side.

    No more OS X upgrades for me. I have had enough.
     

Share This Page