really bad image retention on 5k imac

Discussion in 'iMac' started by macmee, Mar 12, 2016.

  1. macmee Suspended

    macmee

    Joined:
    Dec 13, 2008
    Location:
    Canada
    #1
    so I've had my 5k iMac for a year and 2 months and I'm noticing really bad image retention issues:

    [​IMG]

    should I be worried about this? Do all iMacs do this?
    --- Post Merged, Mar 12, 2016 ---
    here's another [​IMG]
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    I was the starter of the original thread regarding image retention on my late 2014 5K. I have since taken it in several times for the issue, and three displays plus a logic board later mine still does this, slowly worsening. I'd like to try one more time to get it fixed.

    Depending on the severity of your case (it's hard to tell from the photos) if you're still under warranty you can take it in for a display replacement, but there's no guarantee the issue won't just come back even after then.
     
  3. macmee thread starter Suspended

    macmee

    Joined:
    Dec 13, 2008
    Location:
    Canada
    #3
    I just took mine in and they ran a diagnostic on it to test for image retention and my computer passed... I have no idea how because I definitely get the issue. To be fair I have flux installed (but I had the issue before flux) so they told me to go home and re-install OSX and to come back if it's still an issue. Ah well. I have apple care for a good while longer so I might just leave it for now and deal with it later. I only notice on dark backgrounds for now anyway.
     

Share This Page