Really wierd problem with 2TB Western Digital external drive.

Discussion in 'Mac Accessories' started by MacRobert10, Oct 18, 2013.

  1. MacRobert10 macrumors 6502

    Joined:
    Nov 24, 2012
    #1
    A local company had a number of 2TB USB 2.0 WD external My Book external HDs on sale for $79.95, so I bought one because the price was too temping. I thought I'd repartition the drive so I could haVe a part for Snow Leopard, one for ML, and then a few more for TM backups off my main system. I use SL once in a while for some older PPC graphics apps.

    In any case, after I put both SL and ML onto the thing I decided to boot off of it. I wasn't expecting Ferrari like performance but I wasn't expecting errors, either. What happens seems to be that the drive just plain locks up once in a while. You'll be in the middle of something and it will just freeze.

    I thought the drive was bad so I got out my copy of Scannerz and ran a scan on it. The drive ****looks**** like it's passing with one strange caveat: Randomly, Scannerz picks up a long irregularity, and it's ALWAYS, not sometimes, ALWAYS 30.5 sec +/- 0.15 seconds. I couldn't make sense of the problem. I contacted SCSC (who makes Scannerz) and they had me send them the log file for the test. They said they're going to try and get a unit like mine to replicate the problem, but indicated that it looked to them like the drive was either falling asleep or parking its heads....right in the middle of use.

    Has anyone else ever had this problem? I did a little research and this external unit and it's using a some type of variable spindle speed Western Digital "Green" drive. This is a Western Digital My Book for Mac, USB 2.0 unit 2.0TB Units.

    As-is, the unit is almost useless to me. The sole purpose wasn't to just do back ups, it was also to be used to host a clone of both my SL and ML partitions, and allow me to eventually pull the SL partition off my internal HD all together.

    And low and behold...I bought it 35 days ago so I can't return it.
     
  2. Krazy Bill macrumors 68030

    Krazy Bill

    Joined:
    Dec 21, 2011
    #2
    Did you format the drive before using it? Also, are there any firmware updates that need to be applied (via WD support).
     
  3. MacRobert10 thread starter macrumors 6502

    Joined:
    Nov 24, 2012
    #3
    Basically I've done everything above and beyond what WD requests. I initially just wanted to attach the drive without any add on stuff but when the problems emerged I started going through all of WD's steps to see if using their stuff/tools would fix the problem. Here's everything that I've done (not necessarily in order):
    • Formatted and partitioned using Disk Utility
    • Formattted using WDs utility, eventually followed by partitioning with Disk Utility
    • Upgraded the firmware (it says it doesn't need it)
    • Installed WDs Smartware suite
    • Removed WDs Smartware suite
    • Tried it with all other devices unplugged
    • Tried it with a different device.

    I thought maybe this was an odd characteristic of this type of drive, but based on the lack of response I'm beginning to think I just got a lemon.
     
  4. nyc2pdx macrumors 6502

    Joined:
    Oct 20, 2012
    Location:
    Portland, Oregon
    #4
    I had a firewire 800 2TB WB external HD. I had a VERY similar experience. The HD would just stop responding-in fact, I would hear the fan spin down like the power was lost, but the displayed stayed on. After a while, it would only stay on for 30 seconds at a time before the fan stopped.

    I, too, was outside the return window. I stuck it out for a while, but it became completely unreliable. I finally did a time machine backup of the drive (no easy task since it would only stay working for a few minutes at a time, and then only occasionally), and replaced it with a 4TB thunderbolt Seagate External HD (I had upgraded to a newer mac by that time).

    WD was not helpful with fixing it. I contacted them and they simply told me it was outside the window to return it.

    Last time I will buy a WD HD...sad because I thought it was a good brand.
     
  5. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #5
    You guys might want to take a look at the following link:

    http://www.storagereview.com/how_to...igital_2tb_caviar_green_wd20ears_with_wdidle3

    I'd be willing to bet money that the drive's you have are that type or similar. Apparently in some obscure attempt to save energy, it looks like the drive just parks its heads. Notice the emphasis on 30 seconds.

    And what was that magic number Scannerz was picking up? 30 Seconds?

    Maybe WD thinks parking the heads periodically for 30 seconds is a good idea, but I'd call it a firmware bug!

    For an external drive, you'd have to open the unit up, extract the drive, insert the drive into a DOS based system, and reset the firmware so it doesn't time out, assuming that's your problem. That article is almost 3 years old so that firmware update may not be compatible with your drive, if it's even the drive you have.
     
  6. MacRobert10 thread starter macrumors 6502

    Joined:
    Nov 24, 2012
    #6
    I got the update to Scannerz 1.7 which has the new automatic diagnostics mode. I did a test on that stupid Western Digital drive and, as usual it had it's "I think I'll go to sleep at random for 30 seconds about every 5 minutes" and Scannerz flagged them as excessively long sleep times/timeouts. Caught every one of them.

    This is the last time I buy a drive in good faith. What happened to quality? The next time I buy I drive, the first thing I'm doing is running a test on it. If there's even inkling of a problem, back it goes.

    Does WD even bother testing anything before they release it to the public?
     
  7. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #7
    The problem you're describing is all over the web, with delays ranging from about 8 seconds to 30, maybe even more. It's a firmware error (feature????) in the drive.

    I hate to tell you this, but I suspect that when they discover they made an error like this, as long as the drive itself works properly, some of these guys are just re-packaging bad units as "refurbished" or "discount". After all, all they're doing is claiming it's a storage device, right? Do you see any guarantees about performance anywhere on the box?

    I assume the drive works, and I might be willing to bet money it will last as long as any other drive....it will just be annoying to use.
     
  8. MacRobert10 thread starter macrumors 6502

    Joined:
    Nov 24, 2012
    #8
    Maybe I should list this as a "buyer beware" post because I'll tell you how the thing was sold:

    I was looking for a big drive that I could use for both Time Machine backups and to put some boot partitions on. I was going to use the Phoenix tool that came with Scannerz to also keep an active clone periodically on this drive so that if my main drive failed and I needed to get work done, I could just boot into that instead of having to put in a new drive first, then restore Time Machine. That was theory - Gigantic drive, lots of storage, and external. I wanted FireWire but it's so hard to come by them I decided to settle on USB.

    I looked at the local store's online selection which usually has things they keep in stock at the store too. I figured a Toshiba or Hitachi both looked good, although a bit pricey (not really that expensive...in fact this thread can also be called a "cheapskate beware" thread too, because that's what I was doing - being a cheapskate). I go to the store to see what they've got.

    I hunt down both the Hitachi and Toshiba's I was looking at. Suddenly I notice a pyramid shaped pile of boxes with a "Special" notice on them. It was the WDs I ended up buying. The Hitachi and Toshiba I was looking at, if I remember, had starting (low) prices of about $79.99 and started off at 500GB in size, and then went up from there. This thing had 2TB of storage and was selling for $69.95 Four times the storage and ten dollars cheaper!!

    Wow! What a deal! I bought the thing and brought it home. I set up Time Machine. It seemed to work fine, but I wasn't monitoring it all the time. I took out Phoenix and made the clone of my internal volume on the WD partition I set aside. Once again I didn't monitor it, but it went fine. I booted off the unit once, just to see if it would boot, and it did. All is fine with the world, I thought.

    For kicks I went to the online section of the store I bought this from because they usually have specs on stuff they sell and I thought I'd print them out. This particular drive was nowhere to be found. No online info on this model at all. Similar, newer drives yes, this one no. Oh well, big deal I thought.

    Close to three months later I encountered a problem where I needed to use an old app that's not compatible with anything beyond Snow Leopard. Hey I thought, I've got plenty of room on the WD, so I'll just install Snow Leopard onto that, it's still got plenty of space. I created a volume, put Snow Leopard on it, put on the app, and then reboot, getting ready to use it.

    This is when I noticed the timing problem. Periodically, just using the thing, the system would just lock up for what seemed a minute, then resume working. At first I thought "Well, you've got it on a hub, plug it in directly" so I did. Same problem occurs. It doesn't occur all the time. It seemed to occur between 10 and 30 minutes randomly, it would happen, then it would resume normal use. Then I thought maybe other USB devices were interrupting the USB chains, so I took everything but the basics off. Same problem.

    Finally I started thinking maybe the drive was bad. I set up Scannerz to do a scan on it and thought I'd watch it for a few minutes. During the test the thing is wailing - I'm impressed. The lights on the WD are blinking on and off, Scannerz is spitting out scan updates so fast I'm thinking not only is this drive huge it's pretty fast too. Nothing wrong with this drive, I thought. I even contemplated stopping the test.

    Then it happened. The blinking lights on the WD simply stopped and froze a solid white color. Scannerz froze (that's what it does when it's testing a problem). Crap! I thought. It hit a bad sector, This drive is bad! Suddenly Scannerz comes back to life and the drive lights start blinking...it's as if nothing ever happened. I look at the Scannerz interface. It tells me this wasn't a bad sector, it was an irregularity.

    I literally sit there and watch it test. Next one occurs about 10 minutes later. THe drive just freezes. Scannerz pick up another irregularity. Then another at about another 20 minutes. I'm figuring the media on the drive is defective, but just let the thing test at least a few hundred GB of storage before ending the test.

    Finally I end the test, it went about 300GB into the drive and Scannerz reported about 20 irregularities. I look at the log file for the test, and every single one of them is almost exactly 30.5 seconds, give or take a few tenths of a second. I rescan the regions in cursory mode and the problems are nowhere to be found.

    Finally, I decide to retest the drive with a new cable, thinking maybe the original was bad. Once again, random 30 second timeouts. I even went so far as to test other drives on this and other interface ports just to see if it's the the system or a drive. NOPE!

    I have to wonder how and where the store obtained this "special" group of drives that they sold us as normal at a huge discount. The behavior of the drive explains the discount. If I had never booted off of it and used it as a backup only drive, odds are pretty good I never would have even noticed this problem. It is not marked as refurbished or anything else on it. If I had tested this thing right after buying it, it would have gone back the next day. Instead I didn't realize anything was wrong with it until over 3 months later.

    Also, as an FYI, a newer comparable WD model is also almost $30-40 more than this thing was at that store.

    I'm guessing WD knows about this problem and repackaged the drives as backup drives hoping no one would notice. That's my theory, anyway.
     
  9. Barney63 macrumors 6502a

    Barney63

    Joined:
    Jan 9, 2014
    Location:
    Bolton, UK.
    #9
    What is the model number of the drive?
    I've just got a WD30EURX (3TB) but I don't have Scannerz to test it.

    Barney
     
  10. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #10
    I hate to sound like a cynic, but in todays world of Wall Street billionaire elites basically raping companies to reward themselves with quick bonuses as they tear apart and destroy a company, it's the bottom line and only the bottom line that matters.

    WD had two options: They could put out a recall on the drives in the field and replace them or reprogram the firmware in them and send them back as well as reprogram the firmware in the existing units, OR they could just stick them in a in a little black box and call them backup drives.

    The RIGHT thing to do would be to correct the firmware. The fast money types (DID I GET A BONUS FOR JUST SAVING THE COMPANY MONEY???? WHERE'S MY BONUS??? WHERE'S MY BONUS???? WAAAAAAAAAA? GIMMEE A BONUS!!!) have, however, attempted the "fast money" thing to do by shoving a defective unit out the door disguised as a backup unit. In a sense, it's a good scam as long as the unit is never used as a boot drive. If all you ever used the drive for was Time Machine, would you have ever noticed anything was wrong with it???? Only after you used it as a boot drive and then tested it did you find the problem.

    In an age where HDs are under more scrutiny as SSDs become more prominent, you would think that an HD manufacturer would need to be concerned about their image and quaility...unless of course those running the company just don't care.
     
  11. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #11
    Can't check now but I thought the WD disk utility program has the ability to disable the auto sleep feature.
     
  12. MacRobert10 thread starter macrumors 6502

    Joined:
    Nov 24, 2012
    #12
    @Mike Boreham

    It's not a sleep event, it's apparently a head parking event. In sleep the drive semi-shuts down and stays that will until the system wakes it up. With a head parking event, the disk stops what it's doing, moves it's heads to their rest area, waits 30 seconds, then reactivates. It's really stupid. I tried using WD software to reset it reformat it, etc. etc. and it just keeps doing it.

    @Barney63

    I'll have to check. The drive was also not WD's latest so maybe in yours they got around to fixing it. Mine was a WD 2TB MyBook USB 2.0. The newer models, which cost a fair amount more were using USB 3.0.

    @ TheBSDGuy

    Go ahead and sound like a cynic. Odds are that's exactly how they made this decision.
     
  13. Barney63 macrumors 6502a

    Barney63

    Joined:
    Jan 9, 2014
    Location:
    Bolton, UK.
    #13
    I can confirm that mine is SATA III (6Gb/s).
    http://www.wdc.com/wdproducts/library/SpecSheet/ENG/2879-701250.pdf
    They are touted as DVR drives so are spec'd for continuous running, so maybe they don't spin down.
    They are meant to be pretty silent though so that doesn't worry me. It is just if the TC's power supply is up to it. Then again they are lower power rated.
    The tracking info for my TC says it left the US today so hopefully I will have it and be able to test it out by the middle of next week :)

    Barney
     
  14. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #14
    I would suspect the problem is isolated to either a production lot or production lots (plural). I would hope WD would recognize this as a problem and fix it. I would hope they've done so already. The fact that the OP bought a "new" unit a few months ago that's looking like it's actually a few years old is itself telling about how these guys unload stuff. It's telling, but not impressive.

    As an FYI some of the "low power" Seagate externals have excessive head parking, but instead of it being long in duration like on that WD, they tend to just do it much more frequently. In that case the head parks so often that the drives start clicking and people take them back because they think the drive is having mechanical failure.
     
  15. Barney63 macrumors 6502a

    Barney63

    Joined:
    Jan 9, 2014
    Location:
    Bolton, UK.
    #15
    My WD30EURX has a production date of 20th Nov 2013 so at least I know it is *new*.

    Barney
     
  16. MacRobert10 thread starter macrumors 6502

    Joined:
    Nov 24, 2012
    #16
    I checked mine and it's a WD20EURS. I noticed in the specs that the thing has a huge (64MB) buffer. Is it possible that this thing is designed to make use of the buffer because it's so big?

    The dates on the box say 2010, so it's not exactly new.
     
  17. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #17
    If you're thinking the drive is supposed to fall asleep while the buffer takes over or the drive relies only on the buffer to deal with the logic board while kicking on and off as needed, I'd say the answer is "no." The serial data rate for a transfer between the platter to the controller's buffer is probably 100's of Mbits/second. The buffer could easily be filled in a short time.

    It sounds like you just got stuck with a really early release of that thing.
     
  18. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #18
    Interesting, I wonder if this also explains an issue I've been having with my drive. It's a Western Digital Element, 2 TB and operating through USB 2.0. I got it for cheap as an "open box" item from a retailer. Initial tests didn't reveal any problems. I had wanted to use it as a second Time Machine drive, but it was useless for this purpose. Time Machine backups tended to take a long time with my computer, anywhere from 20 minutes to an hour, but with this drive they all took 3-6 hours. I was missing hourly backups as a result. Speed tests were all comparable to or better than the other drive that I was using, so I couldn't figure it out.

    At this point I've just been using the drive for data storage. It works fine for that purpose. I can watch movies from and download directly to the drive and not have any issues. I'm glad to have a potential explanation for why it wasn't working nicely with Time Machine.
     
  19. ZVH macrumors 6502

    Joined:
    Apr 14, 2012
    #19
    MacRobert:

    If I were you instead of complaining about it to us, who can't do anything, I would contact WD support and send them copies of both the regular log file and the diagnostic files on the drive that you got using Scannerz. WD can't argue with facts.

    The worst that could happen is they could say "That's the way it's supposed to work...sorry" and the best they could say is "We'll give you your money back" or "We'll replace the drive."

    I know a guy that had a drive go bad on him and he contacted WD and they replaced it at no cost with a newer, better, more expensive drive. Although I know many people like to complain about them and their drives they're apparently quite easy to deal with tech support-wise and are more than accommodating when it comes to repairs.
     
  20. MacRobert10 thread starter macrumors 6502

    Joined:
    Nov 24, 2012
    #20
    I seriously doubt they would take it back. Like I said it was beyond the store's return date when I found the problem. I thought it might be something simple like a loose internal cable so I opened it up. I put it back together, too, but I think WD would recognize this as being opened - which it was.

    I may call anyway because I wouldn't have opened it up if it was working properly in the first place.
     
  21. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #21
    Chalk it up to experience. Lesson learned: Test the drive right after you get it and return it immediately if it has problems.

    I've never followed that advice I just gave because I've always assumed the drive would be problem free. With so many of these "low power" units out there that overpark their heads, those days are now over.
     
  22. MacRobert10 thread starter macrumors 6502

    Joined:
    Nov 24, 2012
    #22
    I guess I should just chalk it up to experience and quit worrying about it. It's like a friend of mine said, if I took the family out for dinner followed by a movie, and the dinner sucked and the movie was terrible, it would have cost more than this drive did. At least the drive is usable...just not very good.

    As an FYI, new models of this thing, and I assume it's the same 2TB model are selling for almost $40 more, so yeah, the price was an oddity.
     
  23. Marty62 macrumors 6502

    Joined:
    Mar 11, 2010
    Location:
    Berlin formerly London
    #23
    That's a fair point :)

    I have 4 of these WD Element drives, 2 x 1TB and 2 x 1.5TB from 2011 I think.

    I have backups on two and Data / Movies on the other two.

    Touch wood no problems at all, they were not that cheap, about £80 IIRC
    and only have one small USB2.0 mini connection on them.

    I really only got them for safety and have just kind of replaced them anyway
    for my new CMP system.

    I always figure that after 3 years, it's time for new drives, so I put a Drill
    through them and take 'em down the dump !!
    I can budget £400 every three years for new drives :)
    M.
     
  24. TheBSDGuy macrumors 6502

    Joined:
    Jan 24, 2012
    #24
    No offense, but that isn't a fair point at all. He bought a product in good faith that it would work properly, and when it didn't he ended up using Scannerz on it to find out it wasn't working properly.

    Why should we be putting up with this #$*&!!!! That's kind of like buying a brand new car and then having to take it to a mechanic to make sure it's working properly.

    Whatever happened to quality?
     
  25. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #25

    If this is one of the newer WD's which has the "Intellispin" firmware then that could be your issue...I am currently looking for 4X 2TB's to upgrade my R4 but have been told that these drives are unsuitable for a lot of purposes due to this feature...Basically they have the capability to spin at 7200 but the firmware "decides" what it thinks is best for the situation...you might have a lemon, but you might find that it's the firmware itself...no fix I'm afraid, just return or re-sell.
     

Share This Page