Redsn0w 0.9.10b3

waloshin

macrumors 68040
Original poster
Oct 9, 2008
3,182
68
I have a iPhone 3G running 4.2.1 and was wondering with the new Redsn0w 0.9.10b3 all I have to do is put the phone into DFU mode and then click next and Redsn0w will automatically unlock and jailbreak my phone? I don't have to select a IPSW anymore?
 

Dwalls90

macrumors 601
Feb 5, 2009
4,713
1,082
I have a iPhone 3G running 4.2.1 and was wondering with the new Redsn0w 0.9.10b3 all I have to do is put the phone into DFU mode and then click next and Redsn0w will automatically unlock and jailbreak my phone? I don't have to select a IPSW anymore?
Unlocking is always funky and I don't know about that, but for jail breaking, yes its that easy.
 

waloshin

macrumors 68040
Original poster
Oct 9, 2008
3,182
68
Unlocking is always funky and I don't know about that, but for jail breaking, yes its that easy.
Ok it says it cannot dectect my baseband because I am running an old iPhone. So as my phone is 4.2.1 am I safe to download the

iPhone2,1_4.2.1_8C148a_Restore.ipsw baseband and use that for unlocking my iPhone?
 

noiceT

macrumors 6502a
Jul 7, 2008
526
7
Catalina Wine Mixer
Ok it says it cannot dectect my baseband because I am running an old iPhone. So as my phone is 4.2.1 am I safe to download the

iPhone2,1_4.2.1_8C148a_Restore.ipsw baseband and use that for unlocking my iPhone?
Use iclarified to get the correct instructions. Here is the unlock wizard: http://www.iclarified.com/unlock/

Follow the choices. But be weary and careful with the ipad bb 6.15. If you don't know all the caveats, it can seriously bite you.

Read up on the ipad bb on the dev team website first:

http://blog.iphone-dev.org/post/1718400992/ultra-recycle
 

waloshin

macrumors 68040
Original poster
Oct 9, 2008
3,182
68
Try redsn0w 0.9.6rc19.




Every time I try to do the jailbreak it asks if this is a patched 3GS and even says exploiting your 3GS. Why when the phone is just a 3G? Maybe this has something to do with it.
 

waloshin

macrumors 68040
Original poster
Oct 9, 2008
3,182
68
Are you using windows 7 Computer?
Nope Max osx.

And what is the difference between

iPhone2,1_4.2.1_8C148a_Restore.ipsw 420 MB

iPhone2,1_4.2.1_8C148_Restore.ipsw 320 MB

I know the problem the A is for the 3GS and the one without the A is for the 3G.
 

Crystal-RX

macrumors 68030
Dec 22, 2008
2,691
0
Seattle, WA USA
Nope Max osx.

And what is the difference between

iPhone2,1_4.2.1_8C148a_Restore.ipsw 420 MB

iPhone2,1_4.2.1_8C148_Restore.ipsw 320 MB

I know the problem the A is for the 3GS and the one without the A is for the 3G.
The 3G firmware should say Iphone 1,2 and the 3GS should say Iphone 2,1
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,404
At the iPhone hacks section.
Sounds like either user error or USB issues on that particular computer.
Make sure you have the correct official ipsw for the device you're trying to JB.
Not a 3GS firmware for an iphone 3G etc...
Use another computer to do it and download all new redsnow and ipsw files from the internet.
Make sure you get the correct redsnow version for your device and iOS version.
 

waloshin

macrumors 68040
Original poster
Oct 9, 2008
3,182
68
Sounds like either user error or USB issues on that particular computer.
Make sure you have the correct official ipsw for the device you're trying to JB.
Not a 3GS firmware for an iphone 3G etc...
Use another computer to do it and download all new redsnow and ipsw files from the internet.
Make sure you get the correct redsnow version for your device and iOS version.
Yeah I was trying to install the 3GS ipsw onto my 3G.
 

waloshin

macrumors 68040
Original poster
Oct 9, 2008
3,182
68
So in order to unlock my 3G I will have to install the iPad firmware and lose GPS?
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,404
At the iPhone hacks section.
So in order to unlock my 3G I will have to install the iPad firmware and lose GPS?
Depends on what baseband its on right now.
Also before you do install the ipad baseband run fuzzyband to see if your bootrom is compatible with it to in case you can downgrade it.
If fuzzyband says you cant only option is the ipad bb and all the unwanted side effects that come with it.
 

Crystal-RX

macrumors 68030
Dec 22, 2008
2,691
0
Seattle, WA USA
Depends on what baseband its on right now.
Also before you do install the ipad baseband run fuzzyband to see if your bootrom is compatible with it to in case you can downgrade it.
If fuzzyband says you cant only option is the ipad bb and all the unwanted side effects that come with it.
Like AJ said, if you have 05.08 bootloader, then you can downgrade its baseband. However, it is a little complicated process you need to go through because fuzzyband only support firmware up to 4.1. Yours is 4.2.1, so you can't just run fuzzyband from there.