Reformatting External HDD when Disk Utility does not respond?

Discussion in 'Mac Basics and Help' started by KieranDotW, Jan 10, 2017.

  1. KieranDotW macrumors 6502a

    Joined:
    Apr 12, 2012
    Location:
    Canada
    #1
    Hi,

    I have a 2tb Seagate External HDD divided into two 1tb expansions for backups and external storage, respectively. As of a few days ago I have been able to mount and access the external storage partition; however the backup partition does not mount.

    As a last ditch effort I'm considering reformatting the drive since I managed to retrieve everything I needed from the external storage partition. However, Disk Utility doesn't respond whenever I launch it - I'm met with a blank window which reads "loading disks", which continues for as long as 20 minutes or until I give up and force quit Disk Utility. That being said, I can't use Disk Utility to mount or reformat the partition.

    Is there any other method/utility I can use to mount or reformat the disk/partition? Thanks.

    [​IMG]
     
  2. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #2
    Yes, you can utilize the diskutil command in Terminal. Launch terminal and type "man diskutil" which will give you a complete guide to how to use the tool
     
  3. KieranDotW thread starter macrumors 6502a

    Joined:
    Apr 12, 2012
    Location:
    Canada
    #3
    Not much luck there either
    When I use the mountDisk command, I receive the message "One or more volume(s) failed to mount"
    When I use the repairDisk or verifyDisk command, I receive the message "Unable to repair this whole disk: A GUID Partition Table (GPT) partitioning scheme is required (-69773)"
    When I use the partitionDisk command, I receive the message "Error: -69888: Couldn't unmount disk"
    When I use the eraseDisk command, I receive the message "Error: -69888: Couldn't unmount disk"
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    Try ‘diskutil unmountdisk diskX’ (substitute the X with the disk number). If that does not work, try ‘diskutil unmountdisk force diskX’.

    Then retry the erasedisk command.
     
  5. kschendel macrumors 6502a

    Joined:
    Dec 9, 2014
    #5
    I'd question why you want to do anything with the drive at all. If you reformat it you won't be able to retrieve anything from either partition (I know you said you got what you needed from the ext-storage partition.) Given that it's already caused problems, I sure wouldn't trust it for backups.

    It's possible (although IMHO somewhat unlikely) that you have an enclosure fault. If you have another enclosure that will fit the drive, maybe try in that one to see if it works any better. Otherwise, if it were me I'd just toss it into the trash, or send it back to Seagate and see if they'll replace it for you. (I once managed to get a replacement external drive from WD after one died a few months out of warranty, so one never knows.)
     
  6. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    Some questions:

    In your first post, you said the drive has 2 partitions.

    You said you "managed to retrieve everything I needed from the external storage partition".
    So you could afford to sacrifice that partition if required -- right?

    You said the second partition was a "backup".
    Do all the things that are backed up on that partition "exist" elsewhere?
    In other words -- if you erase the "backup" can you start over, creating a new backup?

    If the answers to all the questions above are "yes", then I suggest you just re-initialize (erase) the drive and start over.

    Have you tried taking the drive to a DIFFERENT COMPUTER and connecting it?
    To see if it would mount there?
    If it does, have you tried re-initializing it there?
     

Share This Page