iPhone Removed spite from iPhone, but left microphone dictation and now iPhone is stuck.

Discussion in 'Jailbreaks and iOS Hacks' started by HappyDude20, Jun 10, 2012.

  1. HappyDude20 macrumors 68030


    Jul 13, 2008
    Los Angeles, Ca
    I remove spite from the iPad but left the microphone dictation hack Now my iPhone is stuck on the setup screen initially at the beginning. any help anyone can provide is highly appreciated.
  2. Traykcool84 macrumors newbie

    Jun 21, 2012
  3. 1Qman macrumors newbie

    Jun 21, 2012
    Yeap same here, had to do a restore to get out of it too! :mad:
    SiriPort worked better anyhow, thats if/when you can get on the server... :rolleyes:
  4. anthmage macrumors newbie

    Aug 27, 2012
    I realize your post is from 2 months ago and you've no doubt resorted to something else by now.. but I ran into the same issue where I was stuck on dictation setup.

    For others who may stumble upon this, I was able to resolve the issue. It seems that when removing Spite (or Spazz if you used that package) fail to remove the dictation feature.

    If you were lucky enough to have afc2 service or openSSH enabled, you should be able to use iphonebrowser or WinSCP to retrieve the /System/Library/CoreServices/Springboard.app/N9XAP.plist file. You will need to edit the correct version of this file depending on your model (you can use plist editor for windows):

    N90ap.plist - iPhone 4 GSM [e.g. ATT]
    N92ap.plist - iPhone 4 CDMA [e.g. Verizon]

    In here look under the capabilities key and ensure that if a key named assistant or dictation exists that it is set to false. I was personally missing the assistant key after uninstalling, but the dictation key was still there followed by the true value. After changing to false, overwriting the file back onto the device and rebooting, problem was solved :)

    Hope this helps
  5. MrMark82 macrumors newbie

    Oct 26, 2012

    Thanks (anthmarge) I used ifunbox (which I love) to navigate to that file..
    Mine was N90ap.plist as I am using a normal UK iphone 4
    I didn't have shsh stuff done etc. etc. so...

    Copied that file to desktop, opened it up with notepad
    Found the dictation entry and changed this to false
    I then copied this back to ifunbox so it over-wrote the old file..

    ((Optional) Just to check entry had changed)
    I then deleted the one off my desktop, and copied the file again from ifunbox to the desktop, opened up with notepad (it had changed and stayed on false)

    I then restarted the iphone, it then went straight to the normal screen

    Any Thanks welcome, I thank me, I thank you haha, my phones back

    Chat soon guys, couldn't have done this without anthmage's comment above though, I'm not as massively technical as some..
  6. Macintsh macrumors newbie

    Dec 21, 2012
    Great help. I was also stuck at the dictation screen when cydia updated some things.

    I use ifunbox and navigated to the N90ap.plist file and copied it to my desktop.

    Opened it using notepad and changed the <dictation> to <false>. Then copied it from my desktop to the springboard folder (same folder where the original file was.

    Restarted my iphone and voila, it started normally.

    Here I was thinking I had to restore my phone and hated the idea since I'm not on iOS6 and don't intend to upgrade anytime soon.

    Thanks again :)
  7. Macintsh macrumors newbie

    Dec 21, 2012
    Also those using iFunbox, here is where you will find the N90 file.

    Raw File system- system- library - core services - springboard - N90AP.plist

    click on the file then at the top click 'copy to pc' . I chose to put it on my desktop.

    Once you have the file on your desktop, open it with notepad. Then do a search for 'dictation'.

    On the right on the dictation you will see <true>, change this to <false>

    Save the file

    On the left navigation pane, click on 'Springboard' again then at the top chose 'Copy from PC'

    browse to where you saved the N90AP.plist that you just modified then double click on it.

    Once done, reboot your iphone, it should now start normally.

Share This Page