Resolution issue with 30" Cinema HD Display

Discussion in 'Mac Accessories' started by ourcore, Sep 29, 2016.

  1. ourcore, Sep 29, 2016
    Last edited: Sep 29, 2016

    ourcore macrumors regular

    ourcore

    Joined:
    Aug 4, 2012
    #1
    Hey, guys,

    I just revived an old 30" Cinema HD Display with a new power adapter. Issue is that when connected via Mini DisplayPort to a rMBP using Apple's MDP to Dual-Link DVI adapter, the display intermittently flickers on and off. I tried the same connection on another rMBP and got no output, which makes me think the adapter is faulty. I also tried resetting the first rMBP's SMC, which improved the flickering, but it still happened, just less frequently.

    Then, back on the first rMBP, I connected the display using a DVI to HDMI adapter, which outputs with no flicker, but at a max of 1280x800 px. Apple says that this happens when the DVI connection is single-link instead of dual, but my adapter looks to be dual-link:
    [​IMG]

    I suspect the adapter isn't powerful enough, so I'm leaning towards buying a new one, but I wanted to check for any feedback and experiences beforehand. It's also a simple adapter with female DVI to male HDMI, so I'm not using a separate cable. Any specific recommendations on Amazon would be awesome. Or could the issue lie somewhere else?

    Thanks in advance!
     
  2. lixuelai macrumors 6502a

    Joined:
    Oct 29, 2008
    #2
    The Apple MDP to DL-DVI adapter is known to have issues. I have one and it is in a drawer somewhere because of flickers. I replaced it with one made by Kanex. Anyway just because an adapter has the pins doesn't mean it is an actual DL adapter, the later one you tried is certainly not DL...you would know if it is simply from the size of it.
     

Share This Page