Retina Macbook sleep issues

Discussion in 'MacBook' started by iosuser, Jan 19, 2016.

  1. iosuser macrumors 6502a

    Joined:
    Mar 12, 2012
    #1
    I just bought the Apple digital AV dongle for my rMB, and just noticed that it is not going to sleep properly. It is connect to my Dell U2415 monitor. Normally when the computer goes to sleep, the monitor immediately puts itself to sleep as well. On the rMB, when I put the OS to sleep, I get the message on the Dell monitor that it's entering sleep. Problem is, a few seconds later the monitor comes back on with a blank screen, and it locks up my monitor (can't access the menu to change input). I know the monitor is on because the power LED is lit solid, instead of slowly flashing.

    I also noticed that when connected to the charger, the wifi remains connected the whole time the OS is sleeping. If sleeping without the charger plugged in, the wifi will eventually disconnected after a few hours, presumably when it goes into a deeper sleep.

    I've owned many other MacBooks and Mac Minis before, none behaved this way. I've set the standbydelay and autopoweroffdelay in pmset to 60 seconds. The OS seems to ignore those settings and never goes into a deep sleep. Is anyone else seeing these issues?
     
  2. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #2
    - Wait a few minutes and the monitor should go to sleep.

    - That's normal. You can disable Power Nap in System Preferences.

    - Deep sleep is hibernation. Do you really want that? If so, set hibernatemode to 1 using pmset.

    What are the "issues", really?
     
  3. iosuser thread starter macrumors 6502a

    Joined:
    Mar 12, 2012
    #3
    It takes several hours before the monitor goes to sleep, presumably when the Macbook goes into deep sleep. The problem is, when the MacBook goes into this "light sleep", it seems the monitor doesn't know how to handle it, and stays on with a blank screen and is locked up and I can't switch input to use my other computers connected to the monitor. To get around it, I'd have to wake up the rMB so that the monitor unlocks, switch input, then put the MacBook back to sleep.

    Power Nap and WOMP are all disabled. Hibernate is on which is the default. I then changed standbydelay and autopoweroffdelay to a much shorter interval, in hope of it going into deep sleep sooner so that it doesn't lockup my monitor. It doesn't, until several hours later, and then my monitor goes to sleep properly.

    All other Macs I've owned in the past did not behave this way. I put the OS to sleep, wifi shuts off and monitor goes to sleep. I just checked my router logs. The MacBook was still "phoning home" an hour after I put it (and myself) to sleep last night. This is the kind of sneaky stuff I would expect from Google, not Apple.

    I love this machine but what is happening is highly irritating. I might end up returning it and go back to my Mac Mini.
     
  4. Queen6, Jan 20, 2016
    Last edited: Jan 20, 2016

    Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #4
    Have you tried removing the adaptor and observing the MackBook on default settings? I rather think this is more to do with the adaptor than the MacBook not that this helps to solve your issue, equally it will help to rule out some basic issues, i.e. software.

    Let`s see what your power stats are, in Terminal copy paste below;

    Code:
    pmset -g
    My instinct is it`s related more to the remote logic of the adapter than the rMB, which during sleep will remain to power the adaptor, resultantly the monitor does not sleep as it senses output from a compliant source.

    My own 1.2 rMB sleeps/hibernates as expected, equally it`s not connected to an external display for lengthy periods of time.

    Q-6
     
  5. SSD-GUY macrumors 6502a

    Joined:
    Sep 20, 2012
    Location:
    London, UK
    #5
    As a quick aside, how much battery are people losing after a night's worth of Sleep? If I close the lid on my MacBook with power nap turned off, I lose around 4/5% over 8 hours. Is this normal?
     
  6. iosuser thread starter macrumors 6502a

    Joined:
    Mar 12, 2012
    #6
    Without the AV adapter and the charger connected, the wifi would disconnect after a few hours, but since there's no power LED, there's no telling if it's really off.

    I was thinking the same, that the AV adapter may be the culprit in locking up my monitor. That AV adapter stays warm the entire time it's connected. Very slightly warm but I can feel it in my hand.

    My pmset stats. I've since returned the autopoweroffdelay to the 14400 seconds default since it ignores whatever number I put in there anyway.

    Active Profiles:

    Battery Power -1

    AC Power -1*

    Currently in use:

    standbydelay 30

    standby 1

    womp 0

    halfdim 1

    hibernatefile /var/vm/sleepimage

    powernap 0

    gpuswitch 2

    networkoversleep 0

    disksleep 10

    sleep 1

    autopoweroffdelay 14400

    hibernatemode 3

    autopoweroff 1

    ttyskeepawake 1

    displaysleep 1

    acwake 0

    lidwake 1



    Yeah seems about the same for me, ~5% overnight. I've owned other Macbook Airs and 13" rMBP before. None had that much drain while on sleep. May have to do with the fact that the wifi remains connected, but it's just a guess.
     
  7. SSD-GUY macrumors 6502a

    Joined:
    Sep 20, 2012
    Location:
    London, UK
    #7
    Yup. My MBA 11 probably loses 1 or 2 percent overnight. The rMB loses more for some reason? Could be an El Capitan thing as I was running Mavericks on my MBA. Hope it gets sorted soon with an update.

    Queen6, are you noticing the same amount of battery decrease overnight?
     
  8. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #8
    All looks normal, sleep problems are often difficult to diagnose. I do think in this case it`s the interaction of the monitor and adaptor that is the culprit. My own 1.2 rMB sleeps/hibernates as expected with little battery loss 2%-3%

    Try running and see what it reveals you may find references to USB devices which loops back to the multiport adaptor
    Code:
    cat /var/log/system.log | grep -i "wake reason"
    Are you able to try the system with a different monitor?

    Q-6
    --- Post Merged, Jan 21, 2016 ---
    2%-3% the rMB definitely closes WiFi on entering sleep/hibernation while on battery.

    Q-6
     
  9. iosuser thread starter macrumors 6502a

    Joined:
    Mar 12, 2012
    #9
    I'll try that command and see what the results are. Will probably try another adapter. I believe Anker has one that is coming out soon. I really like the rMB, so will try to work around this problem. Thanks.
     
  10. SSD-GUY macrumors 6502a

    Joined:
    Sep 20, 2012
    Location:
    London, UK
    #10
    Didn't the 10.10.3 update supposedly fix some sort of issue between Mac's hibernating when connected to a monitor?
     
  11. iosuser thread starter macrumors 6502a

    Joined:
    Mar 12, 2012
    #11
    I didn't see the change log, but no it didn't fix it for me sadly. In fact, I had it on sleep on battery the whole afternoon and the wifi never disconnected. I made it a habit to check to see if it's still connected to the wifi before I turn it on :(
     
  12. Queen6, Jan 21, 2016
    Last edited: Jan 21, 2016

    Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #12
    If the WiFi does not drop when in sleep without the monitor connected it`s likely a separate issue. For this there are endless guides. First I would goto System Preferences - Network delete WI-Fi (- box) Shutdown, boot into Safe Mode (can't hurt and clears out old caches etc.), reboot and reestablish Wi-Fi

    Screen Shot 2016-01-22 at 13.41.24.png
    Also note not all Mac`s play well with all routers, which can be frustrating, as no matter what you do there is no apparent solution. I recently had issue on a business trip with my 13" rMBP connecting to the hotel WiFi, however steadfastly refusing to connect to mail, internet etc. Solution was to use my Huawei MiFi (portable router) as a repeater, result perfect connection. This can only be attributable to hardware incompatibility between the hotel router & the rMBP`s wireless card. On that subject recommend you try a different router before (family, work, public etc.) prior to changing anything in the system.

    Some reading for OS X sleep related issues;

    http://www.macissues.com/2014/04/16/determine-the-reason-why-your-mac-wakes-up/

    Q-6
     
  13. jameronforever macrumors newbie

    Joined:
    Jan 27, 2016
    #13
    My 2015 13" rMBP loses about 1-2% of battery life overnight as well.
     
  14. SteveJUAE macrumors 68000

    SteveJUAE

    Joined:
    Aug 14, 2015
    Location:
    Land of Smiles
    #14
    Ahh at last someone has had same issue as me, this drove me crazy at one hotel as my Android device had no issues
     
  15. iosuser thread starter macrumors 6502a

    Joined:
    Mar 12, 2012
    #15
    Thanks for the suggestion, but I don't think it has to do with my router. I will go and delete my wifi settings and give that a try anyway.

    It seems to me Apple changed the way the OS sleeps with the rMB, kind of like connected standby on some Windows laptops which keeps the wifi active during a certain low power state standby. What is still a mystery to me is why it ignores my pmset setting to go into a deep sleep much sooner than the default 10800 seconds (3hrs). In fact, since updating to El Cap 10.11.3, it's not even going into deep sleep after 3 hours. I have not used my rMB since yesterday morning, disconnected from the charger. I just checked my router logs. It was phoning home to Apple all day yesterday, until almost midnight last night.

    I bought Little Snitch license from the Macheist bundle at least a year ago but never used it. I'm going to finally make use of it on the rMB.
     
  16. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #16
    It`s a Mac thing, luckily for me my MiFi could connect to the hotel network, then I can can connect the Mac to the MiFi.

    Q-6
    --- Post Merged, Jan 27, 2016 ---
    My own rMB is still on 10.10.5 as I am reluctant to move to 10.11 (too many issues 13" rMBP) especially as the system has zero issues, nor will I benefit significantly by the upgrade. I am also aware that 10.11 does phone home far more than 10.10, which tends to add further complication.

    Q-6
     
  17. SSD-GUY macrumors 6502a

    Joined:
    Sep 20, 2012
    Location:
    London, UK
    #17
    I've found a few problems with my rMB in regards to WiFi.

    Firstly, it's suffering from the 'RTC Alarm' wake problem, where it will wake from sleep every hour or 2, due to RTC alarm. My Mackintosh had this same problem, as Apple had started using mDNSresponder, which is some sort of Bonjour service.

    Secondly, I also have the same problems Queen6 and SteveJUAE are having in regards to connecting to certain hotspots. For me, t's connecting to my local library's wifi. It just won't work for some reason.
     
  18. duckson macrumors newbie

    Joined:
    Nov 14, 2015
    Location:
    Preston, UK
    #18
    Does a 13% battery loss over 17.5 hours sound normal for sleep?

    Does these settings look ok or is there anything i can change?
    Battery Power -1*
    AC Power -1
    Currently in use:
    standbydelay 10800
    standby 1
    halfdim 1
    hibernatefile /var/vm/sleepimage
    powernap 0
    gpuswitch 2
    disksleep 0
    sleep 30
    autopoweroffdelay 14400
    hibernatemode 3
    autopoweroff 1
    ttyskeepawake 1
    displaysleep 30
    acwake 0
    lidwake 1
     
  19. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #19
    These are the power settings, you need to see what is preventing your MacBook form sleeping AKA Wakeup`s;
    Code:
    cat /var/log/system.log | grep -i "wake reason"
    Q-6
     
  20. duckson macrumors newbie

    Joined:
    Nov 14, 2015
    Location:
    Preston, UK
    #20
    So you think there is a problem then?

    This is an extract from the above command you posted;

    Jan 28 12:02:13 Stuarts-MacBook kernel[0]: Wake reason: EC.SleepTimer (SleepTimer)

    Jan 28 12:17:15 Stuarts-MacBook kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

    Jan 28 12:25:17 Stuarts-MacBook kernel[0]: Wake reason: ARPT (Network)

    Jan 28 12:25:17 Stuarts-MacBook kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

    Jan 28 12:25:17 Stuarts-MacBook kernel[0]: ARPT: 11271.283979: ARPT: Wake Reason: Wake on Scan offload; Disconnect reason: Class 3 frame received from nonassociated STA

    Jan 28 12:25:18 Stuarts-MacBook kernel[0]: ARPT: 11272.288507: ARPT: Wake Reason: Wake on Scan offload

    Jan 28 12:25:18 Stuarts-MacBook kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

    Jan 28 12:25:56 Stuarts-MacBook kernel[0]: Wake reason: EC.SleepTimer (SleepTimer)

    Jan 28 12:40:58 Stuarts-MacBook kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

    Jan 28 14:41:46 Stuarts-MacBook kernel[0]: Wake reason: RTC (Alarm)

    Jan 28 14:41:46 Stuarts-MacBook kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

    Jan 28 14:41:47 Stuarts-MacBook kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

    Jan 28 15:02:26 Stuarts-MacBook kernel[0]: Wake reason: ARPT (Network)

    Jan 28 15:02:26 Stuarts-MacBook kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

    Jan 28 15:02:26 Stuarts-MacBook kernel[0]: ARPT: 11339.981246: ARPT: Wake Reason: Wake on TCP Timeout

    Jan 28 15:02:27 Stuarts-MacBook kernel[0]: ARPT: 11341.016069: ARPT: Wake Reason: Wake on TCP Timeout

    Jan 28 15:02:27 Stuarts-MacBook kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)

    Jan 28 15:03:05 Stuarts-MacBook kernel[0]: Wake reason: EC.SleepTimer (SleepTimer)
     
  21. duckson macrumors newbie

    Joined:
    Nov 14, 2015
    Location:
    Preston, UK
    #21
    Tested it last night with the wifi off before closing the lid and it was still on 100% 8 hours later.
    So i'm now testing it with utorrent closed but the wifi on prior to closing the lid.

    From reading it seems like it could be an El Cap bug, i might try Sleepwatcher that someone on another forum mentioned and provided scripts for (turns off wifi when going to sleep and turns it back on when woken).
    http://www.bernhard-baehr.de

    All in all I don't put it to sleep and leave it on battery much at all anyway so not really a major problem for me, just be nice to find some sort of solution.
     
  22. duckson macrumors newbie

    Joined:
    Nov 14, 2015
    Location:
    Preston, UK
    #22
    3% loss with utorrent closed but wifi on in 6.5 hours, sounds about normal for the rMB given others results in the thread.
     
  23. iosuser thread starter macrumors 6502a

    Joined:
    Mar 12, 2012
    #23
    Finally took a look at the system log. Yep mine is waking every two hours as well, by RTC. This is the kind of bug I expect in Windows which I've often seen, but it largely hasn't been an issue lately. In fact I just bought an HP Spectre X2 (a Surface Pro clone). There is now an option to specifically to shut off the wifi when it's in sleep, and is working exactly as expected.

    Well at least I've now made use of my purchase of Little Snitch. I know my way to dig deep into the OS on Windows to fiddle, and it now looks like I'd have to do the same in OS X which I never thought I'd have to. Ignorance has been a bliss since I started using OS X. Guess that's over now lol.
     
  24. duckson macrumors newbie

    Joined:
    Nov 14, 2015
    Location:
    Preston, UK
    #24
  25. iosuser, Jan 29, 2016
    Last edited: Jan 29, 2016

    iosuser thread starter macrumors 6502a

    Joined:
    Mar 12, 2012
    #25
    In testing now. I turned off WiFi earlier before I close the lid. I imagine this should work around it, in which case that script will come in very handy. looking at the bright side here, at least I'll get to dig deeper into Mac OS to fiddle lol. Thanks for posting the link.

    Another note. I think the retina MacBook with the Intel Core M is kind of always on, may be a requirement with USB-C charging. Just a guess. When you plug in the charger even with it off, it makes the chime just like when you plug your iPhone to the charger.
     

Share This Page