rMBP: Left USB port won't charge iPad

Discussion in 'MacBook Pro' started by BJB Productions, Jan 1, 2015.

  1. BJB Productions macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #1
    I'm so confused. All the sudden my 2014 rMBP is refusing to properly charge my iPad using my left USB port. When I try to charge it, it disconnects and reconnects the iPad every second. I can charge my iPhone or plug in a USB hard drive and there's no problems. Charging my iPad on the right side works fine.

    Any ideas??
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    try an SMC reset (the SMC controls the USB ports power delivery).
     
  3. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #3
    Thanks for the tip. I tried this but it didn't fix it.
     
  4. Archer1440 macrumors 6502

    Archer1440

    Joined:
    Mar 10, 2012
    Location:
    USA
    #4
    This behavior is consistent with dirty contacts on either the USB connector or on the Lightning connector. Try a different cable first to troubleshoot.
     
  5. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #5
    Tried a different cable, same problem.
     
  6. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #6
    Back up to time machine

    If smc and pram won't fix it, have apple store replace logic board, hopefully it's still under warranty

    If you go to about this Mac, system report, usb do you see 500ma and 1600 ma extra operating current on both ports?

    You need to close and reopen system report when you switch USB ports

    The extra operating current that a Mac offers an iPad is a feature that as far as I know cannot be turned off, therefor you need a new logic board!

    If it's still under warranty and they cover the repair, sign up for AppleCare !
     
  7. iamMacPerson macrumors 68030

    iamMacPerson

    Joined:
    Jun 12, 2011
    Location:
    AZ/10.0.1.1
    #7
    Try rebooting the machine holding down Cmd+D to boot into the on-board diags. See if anything pulls up relating to power or USB. It probably won't find anything just see if by chance it will.

    I'd also try taking it into the Apple Store. Sounds like the logic board has a problem. Does it occur only on battery, only on DC power, or both? When/if you go, take your iPad and Lightning Cable because if you don't, they'll probably try to say it's one of those.
     
  8. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #8
    Now my Thunderbolt port next to the USB port is doing the same thing. I plug in a hard drive and it keeps shutting down and restarting the drive every second. Eek! I thought it was just my USB iPad cable but I guess not?
     
  9. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #10
  10. SkimMilk168 macrumors regular

    Joined:
    Mar 19, 2014
    Location:
    Singapore
    #11
    sounds like that part of the logic board could be having issues. contacts shorting or failing board. get it replaced asap.
     
  11. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #12
    Okay. Now both Thunderbolt ports have started to cut in and out. This is crazy. Heading to the Apple Store ASAP.
     
  12. TimeAgentGamer macrumors member

    Joined:
    Feb 2, 2015
    Location:
    Melbourne, Australia
    #13
    I'm having the same issue, I booked an appointment for later this week. What did Apple say/do?
     
  13. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #14
    See above. They'll most likely send it out to be tested at an Apple repair facility.
     
  14. AzNuS macrumors newbie

    Joined:
    Nov 11, 2015
    #15
    Hi guys. I have same issue with my macbook pro. Did You got that sorted?
     
  15. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #16
    They replaced my logic board. However, I still have the issue from time to time and I have no idea why.
     
  16. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #17
    Alot of macbooks have this issue.
    Google it. A lot of folks having the exact same issue.

    After a restart it usually goes away for a while. That's why I assume it is software related.

    We have a macbook air that does this with older thirty pin connector devices. It also runs certain external drives much slower then others.

    We brought it to apple.
    They said everything is fine.
     
  17. Aneef macrumors regular

    Aneef

    Joined:
    Jun 4, 2015
    Location:
    Lahore, Pakistan
    #18
    I also started having this issue on my 2014 rMBP 15" after having updated to El Capitan. It definitely is a software related issue.
     
  18. Tankmaze, Nov 22, 2015
    Last edited: Nov 23, 2015

    Tankmaze macrumors 68000

    Tankmaze

    Joined:
    Mar 7, 2012
    #19
    I think so too, my left usb cant charge my ipad, but works fine for iphone. this is rmbp amd 2015
    El capitan starting to disappoint more and more....

    Update : If I use a usb hub the one without power adapter it charges my ipad just fine along with 2 external hard drive attached and apple usb keyboard. So this is definitely software issue as the hardware can provide adequate charge.
     
  19. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #20
    Yeah, it's super annoying. The problem came back for me again today and I can't remedy it. Ugh.
     
  20. devtech, Feb 15, 2016
    Last edited: Feb 15, 2016

    devtech macrumors newbie

    Joined:
    Feb 15, 2016
    #21
    Hi Guys,

    I've been searching for info like yours and i've found more posts related to this question: Connect/disconnect rapidly iPhone or iPad with macbook pro retina 15" mid 2015

    In my case when i plug my iPhone on the left side usb port, with iPhone / iPad for example at a minimum % of 30 (more or less) it start switching between the 2 state Connect and disconnect.

    So when it start doing this (also with the charger connected or not, and with the other usb device connected or not) i disconnect the iPhone/ipad and i switch to the right port then i return to the left port and it works fine.

    i only use original cable, one time happened that i was using the original iPhone cord and, i've changed usb cord to charge my iPad from the left port and there wasn't no problem. (Apple told me that iPhone and iPad cables are different !?!?)

    I've called Apple, i've done the diagnostic test and all test that you can make, and all was ok for them, so they were thinking it was a hardware failure but, once i brought the mac to the apple reseller point, they didn't find any issue ... all was perfect... also trying to charge iPad iPhone or other.

    I don't know what the problem is... i only know that i've bought this mac like 2 weeks ago and i've a machine that doesn't work properly (hardware talking).


    I have the same problem with a logitech mouse the M570 (the same that they sell on they web site) if i connect the usb receiver on the left port the range of the receiver decrease and it only works in a range like 20 cm... if connect it on the right port it works like for 6 mt

    I hope they fix this bug and if you have any new just write down :)

    Why for you it is a software problem? In my opinion they will call a campaign for this problem, in future.
     
  21. devtech macrumors newbie

    Joined:
    Feb 15, 2016
    #22
    I can confirm... Just tried now and it works fine... i think it's a 3.0 issue... related to that left hand port... because it's not a problem in the right hand usb port...
     
  22. Glen in Oz macrumors newbie

    Joined:
    Jun 4, 2016
    #23
    My MBPr late 2013 running Yosemite also has a strange behaviour on the LHS USB port.
    I was doing some large (800GB) copies between 2 USB3 external drives. The copy was very slow (5MB/s).
    When I looked in "System Report_USB" the drive connected to the Left USB port showed connection as maximum 480Mbps and power as 150mA - these are USB2 figures. So I tested swapping drives between the left & right ports, swapping cables etc. But no matter which drive or cable, on connection, the drives on both ports show initially as connected to the USB Superspeed bus at 5Gbps & 900mA power (=USB3). But, seemingly randomly sometime during the Copy, the drive on the left port then drops to USB2 connection and speed. Copy software (Disc Utility, Super Duper, Finder) makes no difference.
    If I connect both drives to the RHS port via a hub then both maintain a USB3 connection and speed.
    This is bizarre. I always thought that the fastest transfer should be between 2 ports, not on the same port.

    Any ideas?
     
  23. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #24
    No idea but I wonder if it is a software issue with El Capitan. My 2015 MBP started doing this after the upgrade, with the added benefit of not remounting SD cards in the SD slot after awaking from sleep. Since the SD slot uses a USB controller a software bug might be the cause. Apple ran diagnostics on my machine and nothing came up bad.
     
  24. devtech, Jul 1, 2016
    Last edited: Dec 28, 2016

    devtech macrumors newbie

    Joined:
    Feb 15, 2016
    #25
    Apple Store can do nothing, I've tried to bring the mac to them, but they told me that have replaced a part but it's a lie... Btw I hope apple fix this...
     

Share This Page