Runescape on Mac

Discussion in 'Mac and PC Games' started by MagickJam, Nov 23, 2011.

  1. MagickJam macrumors newbie

    Nov 23, 2011
    Hey guys, this is my first post so if this is in the wrong thread or something, then just let me know (and tell me how to move it) and i shall. But anyways, I decided to go back and play an old childhood game called Runescape the other day, and i found i couldn't run it. Well i assume i can't run it, because when i went to recover my password, the damn java app thing would not load, it is just a white box and the message "Error. Click for details," so i am assuming the game itself will probably yield a similar response but as of yet i cannot log in. This annoys me, not because i cannot play, but because this is a pretty new MacBook (Pro, 13", 8GB ram, ETC) and java refuses to load properly. Is there a fix for this, or what? Any answers would be appreciated.

  2. jav6454 macrumors P6


    Nov 14, 2007
    1 Geostationary Tower Plaza
  3. MagickJam thread starter macrumors newbie

    Nov 23, 2011
    Yeah, I've updated to the latest software update, and tried Firefox, Safari, Chrome, Opera AND Camino, none of which work. Do i need to enable the latest java or something?
  4. antonis macrumors 68020


    Jun 10, 2011
    Open the java preferences utility and change the order of the 64bit - 32bit versions by dragging the second one to the top. Sometimes, old java applications will not work with the 64bit jdk.

    Also make sure in the same utility that "enable applet plug-in and web start applications" option is checked (I don't know if runescape implements web start, but you should enable it anyway and try).

    Finally, on the advanced tab, you could enable console so you can check for more detailed error messages which will help you find what's wrong.
  5. MagickJam thread starter macrumors newbie

    Nov 23, 2011
    Thanks for the reply, I tried doing that but to no avail. I get this output into the console:

    Java Plug-in 1.6.0_29
    Using JRE version 1.6.0_29-b11-402-10M3527 Java HotSpot(TM) Client VM
    User home directory = /Users/Jamesload: class loginapplet.class not found.
    java.lang.ClassNotFoundException: loginapplet.class
    at sun.plugin2.applet.Applet2ClassLoader.findClass(
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(
    at sun.plugin2.applet.Plugin2Manager.createApplet(
    at sun.plugin2.applet.Plugin2Manager$
    Exception: java.lang.ClassNotFoundException: loginapplet.class

    Can anyone make sense of that? Some sort of missing class file by the looks of it, right?
  6. AkuskaUK macrumors 6502


    Mar 18, 2011
    Shanklin, Isle Of Wight
    Hi, to play this you will have to download the runescape client, it is available from their website at:
  7. MagickJam thread starter macrumors newbie

    Nov 23, 2011
    Okay cool thanks, will do, but for since I can't remember my password, I still can't actually log in... and i also can't access the damn password-recovery thingy because it is java based. That really annoys me about Jagex, they have to have everything java based, and so people like me who have problems with it can't access their goddamn accounts... In fact, the password appeal thing was stupid as well! It's beyond me as to why they cannot just send a reset link to an email. Rant over. But yeah thanks for that tip, I didn't know there was a client actually, this will probably solve my playing problem, but a solution to the password recovery still remains to be seen...
  8. MagickJam thread starter macrumors newbie

    Nov 23, 2011
    Right, so i haven't found a solution, but somehow it works on my brothers mac, and his is identical to mine. We bought them at the same time, same shop, etc. The only thing that could make them different is if he installed something and i didn't or vice versa. So i used his computer to recover my password (turns out they've changed that as well now, it is recovered via email thank god), and the downloadable client works a-charm on my own computer. Strange. I'm still looking for a solution to my original problem though, if anyone can find one.

    Magick :)
  9. MagickJam thread starter macrumors newbie

    Nov 23, 2011
    Okay so it's working now. I deleted the 'Java' folder at Macintosh HD/System/Library/Java and then downloaded and installed the latest java build from Apple's website, and it now works. I dunno if this was a wide-spread problem that was fixed, or whether what i did was the solution, but it all works now so yay. Hope anyone else having this problem finds this useful.

    Magick out.

Share This Page