Safari crashing more after 1.1.1

Discussion in 'iPhone' started by macbookProSF, Oct 10, 2007.

  1. macbookProSF macrumors member

    Joined:
    Oct 1, 2007
    #1
    not only do web pages look different but safari crashes all the time, i had issues before but not like this. 8 times in a row in the last hour. Intact I could not sign into this web site in landscape mode over and over I would be kicked back to the home screen. Strange !!!

    Any one else having this happen?

    And yes i have restored twice. All tech support tells me is, we would be happy to replace the phone. I tell them it must be from the update but no one will admit it.
     
  2. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    I haven't noticed any rendering differences on mine. Safari still crashes, but it is less frequent than prior to 1.1.1. If I have any trouble, I clear the cache before reopening.
     
  3. ivi7 macrumors 6502a

    ivi7

    Joined:
    Sep 17, 2007
    #3
    I was under the impression that Safari had started behaving after 1.1.1,
    but I was wrong.

    Recently I have noticed that Safari crashes very often. This really puts me off. I expect updates to imrove things for me not the other way around
     
  4. DotComCTO macrumors 6502

    Joined:
    Aug 17, 2006
    #4
    I'm seeing the same thing. I've been having far more Safari crashes than I did in 1.0.2. In many cases, I'm just scrolling through a page that has been fully rendered already. Next thing I know, the scrolling stops, Safari hangs for a moment and then I'm back at the desktop.

    Now - having said that, this doesn't happen many times for me, but it is noticeably more than in the past. Annoying when it does happen.

    :(

    --DotComCTO
     
  5. haiggy macrumors 65816

    Joined:
    Aug 20, 2003
    Location:
    Ontario, Canada
    #5
    Mine is crashing tons too... I've had it crash like 10 times in half an hour just clicking on MR threads, etc... nothing like loading a page with flash etc
     
  6. MacAficionado macrumors 6502

    Joined:
    Oct 5, 2002
    Location:
    An awesome place
    #6
    My 2 Cents

    I was experiencing some strange behavior after 1.1.1.

    I restored several times only to have the same issue. I realized I was restoring and then restoring my backup Phone from iTunes. When I decided to not restore from my backed up iPhone in iTunes all issues have since disappeared and it has been pretty stable without a single crash yet.

    So if you are restoring and putting your old backed up data and preferences, you might want to start from scratch. I hope this works for you. :cool:
     
  7. taybo20 macrumors regular

    taybo20

    Joined:
    Jul 2, 2007
    Location:
    Tempe
    #7
    The whole restore thing is getting a little old for me. I have restored but it hasn't fixed the problems I was having. They are still present. Its all in the software too. Just bugs...
     
  8. locomien macrumors member

    Joined:
    Aug 29, 2007
    #8
    Under 1.0.2, my safari crashed CONSTANTLY. Ever since 1.1.1, it crashed maybe twice. For me 1.1.1 was a HUGE improvement.
     
  9. gceo macrumors 6502a

    gceo

    Joined:
    Jul 13, 2007
    Location:
    San Diego, CA
    #9
    I find it odd how the experiences differ.

    I find 1.1.1 less stable than 1.0.2.

    others find it more stable.

    weird.
     
  10. Telp macrumors 68040

    Telp

    Joined:
    Feb 6, 2007
    #10
    Do you leave your phone on all the time? Sometimes this happens to me, and what i do is just shut the phone off for several minutes, actually about 3o seconds, turn it back on, and that works for me, everything works better after that.
     

Share This Page