Safari hangs loading webpages

Discussion in 'macOS Sierra (10.12)' started by mildocjr, Aug 22, 2016.

  1. mildocjr macrumors 65816

    #1
    Been having this issue with the beta ever since the first one, not sure if this is a consistent issue for other users or if it's just me.

    Safari Version 10.0 (12602.1.50.0.5) - Beta 7
     
  2. bbeagle macrumors 68040

    bbeagle

    Joined:
    Oct 19, 2010
    Location:
    Buffalo, NY
    #2
    Yep. In the last 2 betas of Sierra, Safari hangs for me as well. It works fine for a while, then occasionally hangs for like 10-20 seconds when I enter a new url. Then it works again after a few minutes.

    Also, typing search words in the url bar is painfully slow or doesn't work at all.

    But it's all random. Works for a while, then fails. But fails pretty often.
     
  3. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #3
    This has been Safari's experience for me since the release of El Capitan. I would admit it's worked a little better. Just slightly.
     
  4. hussainh1 macrumors regular

    Joined:
    Sep 22, 2014
    #4
    Less than desirable experience for me as well, I even completely switched to Chrome for a bit, now I use Chrome sparingly whenever Safari is acting up.
     
  5. mildocjr thread starter macrumors 65816

    #5
    I've sent feedback on this to Apple, perhaps they haven't heard it enough to fix it yet.

    I did not have this issue on El Capitan though, this is a new experience. Resetting Safari (Deleting History + Website data) fixed it for the rest of my session but it was back to it's old tricks later that evening. (~3 hours later)

    I'm feeling forced to used Chrome, which I don't mind, but I like Safari better due to integration. (Gestures and such)
     
  6. mildocjr thread starter macrumors 65816

    #6
    Just an update, Apple sent a feedback request for diagnostics, so it's definitely on their radar. Probably checking other users having the same issues. Hopefully we will see a fix since this has been going on for quite some time from what @benthewraith said.
     
  7. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #7
    Please give an address.
     
  8. mildocjr thread starter macrumors 65816

    #8
    Not sure where I said webpage. You might try using a different browser.
     
  9. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #9
    :) the word 'webpage' is in the title that you gave to this topic, 'Safari hangs loading webpage' … also, sorry if the big bold in my previous post appeared aggressive. I lazily copied the word, with its standard big bold formatting, from the top of this page.

    Can you let us have the address, the URL, of one of the pages with which you have difficulty?
     
  10. mildocjr thread starter macrumors 65816

    #10
    It's completely random, one day it's twitter, one day it's youtube, the next minute it will be times, the next hour will be a macrumors forum post. It's not like it's a specific webpage, it could be any of them. The webpage will start loading about 25% which on mac means it's just trying to get the address, then my network d/u drops to 0.0 kbps and it just sits there waiting for me to refresh.

    It's almost like it makes a function call that should return a value but breaks on an error and doesn't display anything to the screen or refresh the progress bar. Perhaps it's a malformed packet that never gets a response and Safari doesn't have a timeout to catch the error.
     
  11. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #11
    I don't have any OS X handy but there's a way to enable, in Safari, both a Debug menu and a Develop menu (I think that's what they're called). One of the two menus offers some obscure options that you might find useful. Just (common sense) if you do experiment with those, remember to revert to pre-release Sierra norms before continuing to test for Feedback Assistant purposes.
     
  12. mildocjr thread starter macrumors 65816

    #12
    Yeah, I've already checked out my options from the Debug and Develop menus, Feedback has already been sent as well and Apple asked for more info, ran a sys diagnostics for them focusing on Safari and not a peep since.

    I also edited the title to be a bit more descriptive :p
     
  13. heytommy macrumors newbie

    heytommy

    Joined:
    Jan 24, 2017
    #13
    I am having this issue as well.. Did you find a way to fix this?
     

Share This Page