iPad Pro Safari on iPad pro

Discussion in 'iPad' started by jetjaguar, Feb 5, 2016.

  1. jetjaguar macrumors 68030

    jetjaguar

    Joined:
    Apr 6, 2009
    Location:
    somewhere
    #1
    why is it so bad? I would think the problems on lagging on websites and forums wouldn't be present with how powerful the ipp is. I'm always having issues where as I'm scrolling there is lag (also happens in Hulu and Netflix). And a lot of times half the website won't load and I have to close out safari and reopen to make it work again. Just really annoying for a device that is so powerful to have these issues.
     
  2. Beavix macrumors 6502a

    Beavix

    Joined:
    Dec 1, 2010
    Location:
    Romania
    #2
    Me too, I have the same issues with Safari. After a while when I scroll a page it becomes blank for a second and then it loads the content.
     
  3. jetjaguar thread starter macrumors 68030

    jetjaguar

    Joined:
    Apr 6, 2009
    Location:
    somewhere
    #3
    Yep I don't get what the deal is? My air 2 never had this issue.
     
  4. sjleworthy macrumors 65816

    sjleworthy

    Joined:
    Dec 5, 2008
    Location:
    Penarth, Wales, UK
    #4
    It's a known issue throughout users. Theres a few threads on it in here
     
  5. Cnasty macrumors 68020

    Cnasty

    Joined:
    Jul 2, 2008
    #5
    Mine too. I dont want to go Chrome as its a resource hog but getting tired of the black screen at the bottom and slow loading.
     
  6. Dranix macrumors 6502a

    Dranix

    Joined:
    Feb 26, 2011
    Location:
    Gelnhausen, Germany
    #6
    What adblocker are you using? I use Blockr and have no problems in Safari...
     
  7. DavidLynch macrumors 6502a

    Joined:
    Apr 9, 2015
    #7
    I have plenty of issues with Safari on iPad Pro, though they're all present on my iPhone too. I've found myself using Chrome much more than I used to, especially on iPad Pro since it serves up desktop versions of websites much more reliably.
     
  8. jetjaguar thread starter macrumors 68030

    jetjaguar

    Joined:
    Apr 6, 2009
    Location:
    somewhere
    #8
    purify
     
  9. Dranix macrumors 6502a

    Dranix

    Joined:
    Feb 26, 2011
    Location:
    Gelnhausen, Germany
    #9
    What happens when you disable it? Still the same problems? My guess is that some ad blockers are very slow and disturb Safaris normal working.
     
  10. CandyNJ66 macrumors regular

    Joined:
    Feb 11, 2009
    Location:
    USA
    #10
    Seeing none of this on Safari so far on my iPad Pro. Hope I don't either!
     
  11. sjleworthy macrumors 65816

    sjleworthy

    Joined:
    Dec 5, 2008
    Location:
    Penarth, Wales, UK
    #11
  12. CandyNJ66 macrumors regular

    Joined:
    Feb 11, 2009
    Location:
    USA
  13. jetjaguar thread starter macrumors 68030

    jetjaguar

    Joined:
    Apr 6, 2009
    Location:
    somewhere
    #13
    No issues with that site

    Usually happens after browsing for a bit
     
  14. sjleworthy macrumors 65816

    sjleworthy

    Joined:
    Dec 5, 2008
    Location:
    Penarth, Wales, UK
    #14
    I didnt mean it lags full time, it was an example site that can show up the issue.
     
  15. Smeaton1724 macrumors 6502a

    Smeaton1724

    Joined:
    Sep 14, 2011
    Location:
    Leeds, UK
    #15
    Not had any issues on mine and also to add I use Safari and Chrome side by side quite often and do not experience any issues. No ad blockers installed.
     
  16. friedmud macrumors 65816

    Joined:
    Jul 11, 2008
    #16
    No problems here either. Safari is crazy smooth on the iPP. I don't have any ad blockers installed...
     
  17. CandyNJ66 macrumors regular

    Joined:
    Feb 11, 2009
    Location:
    USA
    #17
    Been using Safari like crazy on my iPad Pro and it runs silky smooth. No problems at all
     
  18. jetjaguar thread starter macrumors 68030

    jetjaguar

    Joined:
    Apr 6, 2009
    Location:
    somewhere
    #18
    Weird. It happens every now and then after browsing for awhile and the only way to fix it is to close out safari and reopen.
     
  19. Ghost31 macrumors 68000

    Ghost31

    Joined:
    Jun 9, 2015
    #19
    Silky smooth most of the time on mine. There were a couple times where it became unresponsive and just froze, but hasn't happened since then. It's been great
     
  20. BoiledCabbage macrumors newbie

    Joined:
    Feb 9, 2016
    #20
    This is also present on the iPad Air 2, and i wonder if it occurs on the other 2GB devices (mini 4, 6S/6S+). It's super annoying and almost spoils the device for me because it occurs quite frequently on pages i visit regularly.

    It most certainly is not attributable to ad blockers, because I've switched them off and I have also recreated the issue on mulitiple Air 2/iPad Pros in the the Apple store.

    To recreate the issue:
    Go to this rather simple site: https://www.ozbargain.com.au/

    It should load fine in a new tab; however, if you go to an image heavy page (e.g. http://www.neogaf.com/forum/showthread.php?t=1046854&page=5), load it up, and then next in that same tab go to https://www.ozbargain.com.au/ again, you'll see there is terrible rendering lag when scrolling down the page. If you open a new tab and load ozbargain, it will render fine, but it will continue to render poorly within the original tab.

    You may not think it's a big deal, since you can get around it by simply opening a new tab and closing the problematic one, but I find it takes away a lot of fluidity from the browsing experience.
     
  21. max2 macrumors 68000

    Joined:
    May 31, 2015
    #21
    This is interesting and the first time I heard of this problem.
     
  22. double329, Feb 10, 2016
    Last edited: Feb 10, 2016

    double329 macrumors 6502

    Joined:
    Sep 10, 2008
    #22
    I have not seen such issue with the Safari on my IPP nor Air 2.. Super fast on IPP, web page load is close to instant. As the matter of fact, that is the reason I got ipad.
     
  23. macaximx macrumors 6502

    Joined:
    Apr 5, 2009
    #23
    No problems here either with that site. Using Magic Ad Blocker.
     
  24. ZombiePete macrumors 68020

    ZombiePete

    Joined:
    Aug 6, 2008
    Location:
    San Antonio, TX
    #24
    I've seen this complaint before, but I've never had this issue on any website I browse. However, I'm not a super-heavy user; I generally have at most two or three tabs open and I always close them when I'm done with them. I also use Purify.
     
  25. sjleworthy, Feb 10, 2016
    Last edited: Feb 10, 2016

    sjleworthy macrumors 65816

    sjleworthy

    Joined:
    Dec 5, 2008
    Location:
    Penarth, Wales, UK
    #25
    it usually happens for me on image heavy sites or blogs without safari complete restarts. happens all the time actually.

    regular browsing is fine (like this forums site). but i use image heavey sites. i notice it constantly. have always noticed it on whatever ipad i've used.

    i dont use any ad blocker. perhaps i should try?

    /EDIT

    just installed Purify. perhaps it'll block background scripts or other crap? or any settings/tips that i can use with it?

    i'll report back
     

Share This Page