Safari trackpad scrolling issue

Discussion in 'OS X Yosemite (10.10)' started by jrowlan, Jun 3, 2014.

  1. jrowlan macrumors newbie

    Joined:
    Jun 3, 2014
    Location:
    DC
    #1
    Anyone else having issues with Safari not accepting your two finger scrolling after a little while? It works in Mail and other applications. In Safari when I first open it, it works, but then it will just some working, and the scroll wheel on my external mouse doesn't work either.

    (Back to the good 'ole arrow keys)
     
  2. April Knight Suspended

    Joined:
    Jul 24, 2011
    Location:
    Olympia, WA
    #2
    That, and some gestures, have been a bit iffy for me. Especially if I swipe two fingers to go back a page, it's like Safari gets stuck. I imagine this is just one of the kinks that will be ironed out.
     
  3. jrowlan thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    Location:
    DC
    #3
    For sures. It is a beta right now. I get the hanging issue as well. The weird thing is it's not something easily repeated. Sometimes it does it quickly, sometimes not, and sometimes the gestures start working again.
     
  4. Yakibomb macrumors 6502

    Yakibomb

    Joined:
    May 13, 2014
    Location:
    Cape Town
    #4
    My gestures become more and more buggy the more I use this DP, this will likely be sorted out in the next one though
     
  5. PierreScerri macrumors newbie

    Joined:
    Oct 30, 2012
    #5
    Safari swipe back hangs

    Hi

    I've just come across this issue again.

    Swiping back in Safari locks that window and one has to relaunch Safari to browse to another page.

    I noticed, however that some other gestures (not in Safari) were not working too.

    This points to a trackpad/bluetooth issue (I have a magic trackpad).

    I disconnected and reconnected the trackpad via the bluetooth menu on the desktop. and the problem went away.

    Although this is only a way to get out of the situation, I hope this helps some.
     
  6. SmOgER macrumors 6502a

    Joined:
    Jun 2, 2014
    #6
    You mean like it starts moving the page back and then freezes in the process? Happened to me as well, but only once, and I think I had this issue on one of the Mavericks build as well, but again only once . :D
    After restart it sorted itself out.
     
  7. dmccloud macrumors 6502a

    dmccloud

    Joined:
    Sep 7, 2009
    Location:
    Anchorage, AK
    #7
    I've had issues where Firefox stops recognizing scroll gestures (they work everywhere else), and only a restart of the app will fix it. This happens with either the built-in trackpad or an external mouse, so I think it's a Firefox issue there. I haven't seen the issue occur with Safari or within Yosemite itself.
     
  8. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #8
    happens to me on the trackpad on my Air. Pain, but it's a beta.
     
  9. itchban macrumors newbie

    Joined:
    Aug 4, 2014
    #9
    I'm using the Apple mouse on an iMac 27" (early 2014)...

    my website doesn't seem to want to scroll anymore?

    www.itchban.com

    It seems to scroll fine in Chrome.. and it used to scroll fine pre Yosemite Safari..

    Can anyone confirm that it's also not scrolling in their Yosemite Safari? thanks

    Not sure if its my css or not..
     
  10. Simplicated macrumors 65816

    Simplicated

    Joined:
    Sep 20, 2008
    Location:
    Waterloo, Ontario, Canada
    #10
    The Mavericks swiping bug you're talking about has existed since the DPs of Mavericks. I reported this bug and they closed it as a duplicate. It makes me wonder if Apple actually cares about fixing bugs now if it still exists in Yosemite.
     
  11. dlbmacfan macrumors regular

    Joined:
    Jul 20, 2011
    #11
    The site is scrolling fine for me.
     
  12. itchban macrumors newbie

    Joined:
    Aug 4, 2014
    #12
    Hi all,

    If you've visited my site: www.itchban.com and noticed there's no problem anymore, it's because I've fixed it. It was caused by the css overflow-x property I was using (to get full browser width header).

    I think the new version of Safari doesn't like this property and causes it to play up (at least in regards to my code anyway)..

    The problematic code was solution #1 found at http://css-tricks.com/full-browser-width-bars/

    I'm now using solution #3 and all is good...
     
  13. deviant macrumors 65816

    Joined:
    Oct 27, 2007
    #13
    seems like it waits till the page fully loads to allow you to swipe back one more time. annoying yes, but it will be fixed. i hope.
     
  14. boball macrumors newbie

    Joined:
    Jun 22, 2011
    #14
    Help!

    Help!
    I just upgraded to Yosemite and the two-finger trackpad swiping and scrolling are not working in Safari (Back, Forward, and Scrolling).

    The problem is only in Safari.

    This is ridiculous.

    Is there any fix?
     
  15. boball macrumors newbie

    Joined:
    Jun 22, 2011
  16. Rodster macrumors 68040

    Joined:
    May 15, 2007
    #16
    My trackpad works 100% with all gestures but I also did a clean install.

    edit: I wanted to mention and suggest to try doing a setup of your trackpad. I had an issue where my Apple BT keybd wasn't showing the battery % even though it was working. I did a setup and after that it appeared. Anyone with trackpad issues might want to give that a try.
     
  17. AirThis macrumors 6502a

    Joined:
    Mar 6, 2012
    #17
    Still present in Yosemite. Emptying the cache does not make it disappear for me. Clean install also doesn't help. Only temporary relief is to sleep your rmbp, and then wake it up.
     
  18. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #18
    This has been around in Mavericks and is still not fixed in the final Yosemite release. Reported it as a bug to Apple and they even replied saying that they can't do anything about it unless I tell them how to reproduce it. It's RANDOM Apple, you can't reproduce it deliberately. It just happens. Like most bugs.
     
  19. CrazyAppleGrub, Oct 18, 2014
    Last edited: Oct 18, 2014

    CrazyAppleGrub macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Portland, OR
    #19
    Thanks for that link. This helped fix the problem for me, I will explain what I did from that link that helped me..

    My Background:

    I have been having a similar problem as reported in this thread. I recently updated (an update installation not a clean install) to Yosemite from Maverick yesterday on Oct. 17, 2014. I have a 2013 Macbook Air.

    My Problem:

    When I was in Safari or Firefox, the two finger scroll worked fine initially. However, as soon as I tried to swipe right to go back to the previous page Safari and Firefox would stop responding to the scroll and swipe gestures on the trackpad and I would have to use the arrow keys to go up and down the page. The functionality would only temporarily return after I closed and reopened the programs.

    I didn't take a screen shot before I found a fix to this problem but it looked like, on the left of the Safari browser, I could see a centimeter of another page behind the page I was viewing and this "double screen edge" would not go away even as I navigated to different pages and even though I only had one tab open.

    What Fixed it for Me:

    This is what I did that, so far, has fixed this problem. As I was able to replicate my problem previously and now that I can no longer replicate it, I consider this a "fix" for me. (All of my trackpad functionality has been working for the past couple of hours):

    After I went to the page linked by boball:
    http://forums.macrumors.com/showthread.php?t=1681605

    I looked at the "alternative work-arounds" link that one of the posts referred to, which led me here:
    http://www.bradycline.com/2012/in/stop-safari-reloading-on-back-gesture/

    This page refers to resetting the preference options for "BetterTouchTool, MagicPrefs." I just use the default touch controls built into OS X, but I thought turning off all of the touch preferences and then turning them all back on might do something (plus it seemed like the least invasive method to try first.)

    So I went into the trackpad settings in system preferences and I un-selected all of the options under "Point & Click," "Scroll & Zoom" and "More Gestures." I then closed the window and reopened it and reselected everything under those categories (I prefer to have them all selected for my computer use) and presto it seemed to have fixed the problem.

    Post Script:

    I hope this helps someone, I apologize for the long post but I thought if I was as clear as possible, in regards to what I did, it may be more helpful to everyone. Thanks to everyone who posted, you all helped me a great deal.
     
  20. boball macrumors newbie

    Joined:
    Jun 22, 2011
    #20
    I too had the same a centimeter, of the previous page or so it seems, left behind on the left side of the page, when I did the back swipe, and after that scrolling and other gestures would stop working on that page/tab.

    Funny thing is the problem came back for me a few hours later after the cache emptying seemed to have work. And then I had to keep either emptying cache again and restarting the browser / reloading that unresponsive page again, in order to get the page to scroll normally again (double finger scrolling on the trackpad).

    However, today now everything seems to be fine.... Back swipe... scrolling.. everything is working fine as it should... And I didn't do anything, it's all just working as normal, right now...

    All weird...




    ----------

    Agreed it's all just happening randomly.... And that sucks...
     
  21. CrazyAppleGrub macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Portland, OR
    #21
    Hey boball, I'm glad it seems the functionality has returned for you.

    So far my trackpad hasn't had any issues in either Safari or Firefox after I reset those preferences I outlined above (I know what I did was a bit different than what you did). I used my computer for around 8 hours yesterday after I found the "fix" that worked for me. Now it has been about 24 hours later and my trackpad continues to work even after shutting down and restarting my computer a couple times.

    I'm not sure why what I did seemed to have fixed my trackpad issue, Im not sure what the background activity is that makes unselecting and reselecting those preferences fix my issue. Perhaps unselecting and reselecting those options, as I did, also reset some sort of cache similarly to what you did. But I'm getting out of my knowledge depth with that last sentence, I don't know if that's an accurate explanation of what happened, maybe my actions just scared away the demon that was living in my Macbook Air.
     
  22. DommyB macrumors newbie

    Joined:
    Jul 3, 2013
    #22
    Scroll and swipe gestures not working in Safari

    Hi, gestures in Safari are not working for me either. I have the latest update of Yosemite ( 10.10.1 ) running on a 2012 MacPro Retina laptop. When I open safari, scrolling works, but as soon as I two finger swipe to the left to go back a page, the page starts to slide over to reveal the previous page but gets stuck almost immediately showing a tiny slither of the previous page to the left of the window. It sticks there and then two finger scrolling or any other gestures just stop working. Restart Safari and scrolling works again until you side swipe.

    Ive tried turning gestures on and off and ofcourse a few restarts but no joy.

    Is anyone else experiencing this?

    Thanks!

    Dom
     
  23. CrazyAppleGrub macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Portland, OR
    #23
    Hey Dom, I hope your doing well but I'm sorry to hear you are having the same problem I had a short time ago. I feel that your description very precisely describes the same issue i previously had, although since my previous post it has been fixed for me. What I outlined in my previous post was what worked for me but from what I recall from looking through some other help websites there were a few alternative things other users tried which may have solved this problem in a slightly different way.

    So I will just put down below some of the alternate techniques you can review and consider trying if you haven't done so already. I'm sorry if I don't provide a direct fix for you but as you can tell by my previous posts in this thread I am still a Mac novice in terms of these kinds of topics. But I'm glad you posted on this thread that you were having trouble. Hopefully we can help you out and in turn your post will help other people as well. And perhaps this may get the attention of someone more knowledge who can provide additional guidance if my suggestions don't work.

    http://forums.macrumors.com/showthread.php?t=1681605
    This website outlines a technique I didn't try that might he helpful:
    http://www.bradycline.com/2012/in/stop-safari-reloading-on-back-gesture/
    This is the website I previously looked at that gave me the idea to go into my System Preferences and to Disable all the Trackpad options and then to re-enable them. This worked for me, however, if I understand your post correctly, Dom, you have already tried this and it didn't work. But the post also mentions using a couple different third part software tools to manage the functionality of your Mac trackpad. You may have a preference to want to use the native functionality within your mac as I do but using one of these tools may at least be a temporary fix until the native trackpad functionality is restored. Also another thing I would consider is to download one of these tools and get it working on your Mac. Then uninstall it and go back to using the native trackpad software controls. I know this sounds kinda strange but I am thinking that by doing this your native trackpad functionality might get "fixed." I am again out of my depth in trying to explain why, but my sense is that doing this kind of thing might "reset" your trackpad capability which was the idea behind my "fix" of turning off all the trackpad preference options (within system preferences) and then turning them back on (which worked for me.)

    These are the two third partly trackpad tools you might review:

    http://magicprefs.com
    Magic Prefs trackpad preference manager

    http://blog.boastr.net
    Better Touch Tool trackpad manager

    It is my hope that trying one of these things will help restore your trackpad functionality. I probably don't need to say I am not a Mac expert and that these are just my best guesses of things that might help you. So I would suggest reviewing them and then trying whichever one you think might work best based on your own situation and judgement. If I were you however I would try the first suggest to empty the cache of Safari and if that didn't work then I would try the PRAM "hard" restart before I tried the third party software.

    I would also encourage you to keep checking online for other solutions if none of this stuff works for you. Also you might try contacting Apple support if that is an applicable option for you. Im not sure of all the ways one might contact them for this but as lengthy of a process as it might be, if its an option that is available for you, it may end up being quicker than scouring the internet for a community generated fix that will work for you. I don't have an active Apple support plan so I chose to scour the internet.

    Hang in there, if you try any of these suggestions please let us know what worked or what didn't. Hopefully your input will help add to the body of information on this issue for other users.

    Thanks! :)
     

Share This Page