Safari URL bar Autocomplete NOT working

Discussion in 'OS X El Capitan (10.11)' started by BJMRamage, Jul 19, 2016.

Tags:
  1. BJMRamage macrumors 68020

    BJMRamage

    Joined:
    Oct 2, 2007
    #1
    Hello,

    I seem to find plenty of how to disable this but I want to readable this.

    I want to have the Safari URL bar autocomplete websites from my history. I liked when I could type three letters of a website i go to everyday and have the rest pop up...instead it suggests craigslist.com or all sorts of websites i have not been to.

    I cannot seem to figure out WHEN this stopped or how to ENABLE this feature.


    HELP!!!!
     
  2. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #2
    Have you played with the settings in preferences->search?
     
  3. BJMRamage thread starter macrumors 68020

    BJMRamage

    Joined:
    Oct 2, 2007
    #3
    i have since...to no avail. I don't remember doing so prior. everything is checked on it now.
     
  4. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
  5. BJMRamage thread starter macrumors 68020

    BJMRamage

    Joined:
    Oct 2, 2007
    #5
    nope. i was wondering if I somehow switched but I am not. it almost acts that way though.
     
  6. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #6
    Did you check the setting here --- Safari -> Preferences -> General -> Remove history items : *dropdown menu list*

    Did you look at your History via the Safari menu bar to see if it's being created?
     
  7. BJMRamage thread starter macrumors 68020

    BJMRamage

    Joined:
    Oct 2, 2007
    #7

    ok, so I have the Remove history after One Year checked.
    But, I recently wanted to look t my history and normally, in the past, i could click the History Menu Bar and see a listing of websites. That list isn't there anymore. I was wondering if it was a ElCapitan or safari update thing. I had to select "Show History" Cmd-Y and it brought up a Chrome like display for history but that is blank.
    M

    Maybe i should uncheck History or change that setting, then change it back.

    Thanks for making me look into that area again. strange.
    --- Post Merged, Jul 21, 2016 ---
    ok. I ended up removing the Library > Preferences > com.apple.safari.plist

    quit and restarted and things look fine now. I see a history list.
     
  8. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #8
    Cool. :)Thanks for the update.
     

Share This Page