Samsung ML-1710 Print drivers not working-help!

Discussion in 'Mac OS X Lion (10.7)' started by FNH15, Apr 19, 2011.

  1. FNH15 macrumors regular

    Apr 19, 2011
    Greetings fellow Mac users,
    I have a problem with my Dell 1110 laser printer (AKA Samsung ML-1710). In Snow Leopard, it would print fine, but in Lion, for whatever reason, it displays the message "/usr/libexec/cups/filter/rastertospl failed". I navigated to the file, and it would not run due to it having PowerPC code. Is there any way to recompile that part of the driver in a code suitable for Lion, and if not, is there anyway to find another driver that is compatible with Lion and the ML-1710?



    MacBook May 2008, 3 GB RAM, 250 GB Hard Drive, Mac OS 10.7, iPhone 3G on iOS 3.1.2
  2. Outsider macrumors regular


    Mar 25, 2002
    North Carolina
    The drivers need to be updated to Universal or Intel. It won't work as it stands. Check with the manufacturer to see if they have Intel versions of the drivers that don't rely on Rosetta.

    Also, have you tried setting it up with a Generic driver?
  3. Mal macrumors 603


    Jan 6, 2002
  4. drtekrox macrumors newbie

    Feb 18, 2011
    Download the Linux drivers located On Samsung's Website

    Extract the file, you should have a folder called 'cdroot'
    Navigate to cdroot/Linux/noarch/at_opt/share
    you should see a folder named 'ppd' - Get info and change it's permissions to read/write for yourself and read for everyone else, apply to all enclosed items.

    Remove and start re-adding your printer in System Preferences.
    You will see a list named 'Print Using' - it will likely be set to Auto, choose Other.

    Navigate back to cdroot/Linux/noarch/at_opt/share/ppd
    Choose 'ML-1710spl2.ppd'

    Done :D

    OSX uses CUPS for printing like linux - printing support is provided in cups by a 'PostScript Printer Definition' file; These are interchangeable.
  5. FNH15 thread starter macrumors regular

    Apr 19, 2011
    I used that solution with SPliX, and I actually gained features.
    Thanks guys, I've had this problem since Preview 1, and it for pretty annoying to have to keep booting into SL every time I wanted to print!


  6. linnig macrumors newbie

    Jul 21, 2011
    Alas, does not seem to work with official version of Lion: I get this error message:

    The software for the printer was installed incorrectly. Please reinstall the software from the manufacturer.
  7. FNH15 thread starter macrumors regular

    Apr 19, 2011
    Just use the SPLiX drivers-works with the GM.
  8. NeedMoreVideo macrumors member

    Feb 25, 2011
    I had the same problem yesterday, just get the CUPS drivers for Mac... These are just like the linux drivers above, but they are all nice and packaged up for Mac with an installer...

    Download all 3 things (samsing-gdi, foomatic-rip, and ghostscript). Install all 3 but make sure you install foomatic-rip first. Reboot so that your printer system is restarted then choose the Samsung-1710 foomatic driver and it will work.

    I'm using this on my machine and all is happy.
  9. veedow macrumors newbie


    Dec 19, 2008
    Chicago suburbs
    I used the SPLiX drivers for Lion too. All is good! My Samsung ML-1740 is back up and printing in 10.7!

    Thanks for the tip everyone.
  10. zokinet macrumors newbie

    Aug 8, 2011
    this worked for me, SPliX

  11. cramhurst macrumors newbie

    Aug 9, 2011
    I've tried this out with my ML-1610 and although the printer physically prints the top margin is completely wrong and the print out starts probably 2cm close to the top.

    Any ideas what's causing this and how to fix it?

  12. zub3qin macrumors 65816


    Apr 10, 2007
    Tried this and it worked GREAT!
    Thanks a million!
  13. cramhurst macrumors newbie

    Aug 9, 2011
    I found the answer in another thread. There is something wrong with the latest foomatic rip version. If you find your printer margin is way out install the previous version, I think it was dated 2008, it's below the latest version on the download page. This worked perfectly and now my ML-1610 prints perfectly on Lion! :)
  14. Tamburinmannen, Aug 31, 2011
    Last edited: Aug 31, 2011

    Tamburinmannen macrumors newbie

    Aug 31, 2011
    Problem with Samsung ML 1710 in Lion

    I got the same message. Does anyone have a solution? I use the printer via my Asus WL-500 router.

  15. dcnblues macrumors member

    Oct 23, 2007
    I've tried every tip here, installed both Splix and the other drivers, and can't get the printer pref install to see anything when I try to add printers. Totally blank screen options.

    Any info on where these items get installed, and where Lion looks for them would be most welcome.
  16. Yorb macrumors newbie


    Nov 13, 2009
    Raleigh, NC
    omg thank you. saved me with some last minute concert tickets that MY FRIEND forgot to print.

    splix-2.0.0 ftw! make sure you click the splix link in that post btw, because if you just google you end up on the *nix splix and that doesnt work in OS X. :]
  17. R Boffy macrumors newbie

    Jan 13, 2012

    I used the Linux 2008 "package" on my MacOS 10.7 and it worked, but only after I had shut down and rebooted. This might be an obvious move to some - but not to me!
  18. hashman27 macrumors newbie

    Jan 22, 2012
    Sorry what did you try?

    Theres a couple of different suggestions here, and I was just confused as to which one you did. I have the samsung ml-1610 as well and I am so annoyed that it isn't working!

    I guess this post will make sense to me once I understand the first post!
  19. jlrathke macrumors member


    Apr 10, 2011

    The SPliX worked beautifully on my new Mac Mini. Now, if someone can help me with my HP CP1215 Color Laser.....


  20. strabo macrumors newbie

    Oct 15, 2011
    Samsung ML-1710 Printer Driver for Lion

    This is the solution - thank you very much!

  21. omerce macrumors newbie

    Nov 27, 2012
  22. Bernard-C macrumors newbie

    Dec 28, 2012
    Solution for Samsung ML-1710 Print drivers

    I do that yesterday with OS X 10.8.2 and my printer work well now.
  23. barbara.cuba macrumors newbie

    Jan 2, 2013
    Ml 1710

    I' ve done the same. Thank you!! The printer prints like a new one!
  24. mgabe macrumors newbie

    Jun 7, 2010
    I, too, am having no luck using my Samsung ML1710 with Mountain Lion. Tried to download samsing-gdi, foomatic-rip, and ghostscript and install as advised above and got this message:

    "Your security preferences allow installation of only apps from the Mac App Store and identified developers."

    Suggestions, anyone?

  25. mgabe macrumors newbie

    Jun 7, 2010
    FIXED!!! I am now once again enjoying my Samsung ML 1710! Thanks much for the super guidance/help!!!

Share This Page