Saving a G5 Powermac

Discussion in 'PowerPC Macs' started by Viserion, Aug 17, 2016.

  1. Viserion macrumors newbie

    Joined:
    Mar 25, 2015
    #1
    A while ago I got a Powermac G5 as a replacment for the previous G5 that would not turn on, not even so much as a light or fan spinning except for the very rare occation it would boot fine.

    Back to the current G5, I think it is also broken, and I'm the one who did so by mistake.

    I'm not very experienced with Macs, and these two are the only ones I have ever owned.

    It started with me wanting OSX, MorphOS and PPC version of Ubuntu on it, and I managed to set it up correct somehow.

    I was not happy with Gnome, as I also run Opensuse with KDE on an Intel machine, so I tried updating to KDE trough apt-get, but that didn't work as I got numerous errors and instabillity.

    I then found an old OCZ Vertex 2 SSD and decided to do a compplete reinstall.

    OSX and MorphOS worked well, but Opensuse PPC/Kubuntu didn't.

    On Kubuntu the installer would always crash when finishing the last settings window no matter if I hit next at once, or waited for it to install completely.

    On Opensuse I only got to Grub, and only later learned you had to find the core and load it.

    So I made an memory stick and tried via Openfirmware.

    Big mistake.

    I entered something like "boot ????\boot\ppc64le\grub2-ieee1275\core.elf"(I don't remember what ???? was) with the result that nothing happed, and after nearly an hour I turned it off.

    So when I try to start it now it chimes, but no picture on the screen at all, and fans will be very loud after a while.

    So tried reseting it by pushing the button on the motherboard. Made no difference , and the CMD - OPT-P-R command numerous times.
    After a while I noticed that the light under the mouse isn't on, so it may be that keyboard/mouse isn't working.

    Tried all the USB port. Same thing.
    I tried several different ram, and also swapping the grapichcard from old G5 to the new one, but with out any effect.

    So is there a way of saving this by reflashing Openfirmware, desolder it and replace it, or something else.

    It was such a good machine, so it would be a pity if it ended up as unusable because of this.
     
  2. ITguy2016 Suspended

    Joined:
    May 25, 2016
    #2
    I'm no Openfirmware expert but I cannot see how that command would render your Mac permanently un-bootable let alone damage it. It merely tells the firmware what file to load from that command. To my knowledge it doesn't change anything in the configuration. Unless the source file you booted made changes then I would think it was a coincidence and not something you did. Others with more Openfirmware experience might say differently.

    With that said have you tried to reset the PMU:

    http://www.macusersguide.com/photo-gallery/powermac-g5-dual-2ghz/
     
  3. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
    #3
    What model PMG5 is this? There could be a few possibilities, and knowing the model number would help
     
  4. lcdswat macrumors newbie

    lcdswat

    Joined:
    Jul 11, 2016
    Location:
    Ufa, Russia
    #4
    You have to do PMU reset, i'm sure it will be helpfull.
     
  5. Viserion thread starter macrumors newbie

    Joined:
    Mar 25, 2015
    #5
    Tried the PMU more than once, and no difference. Also tried disconecting everything, and removing battery.
    No change.

    As I wrote I'm a long shot from being an expert, but when shutting it down it caused this problem so I assumed .

    It's a dual cpu 2GHz, with 8 ram sockets(had 6GB installed when this happened) .

    It says 2GHz/DP/512MB 400/160GB/8xSD/FX5200/56K . I think the FX5200 is a Nvidia card, but a ATI 9600 is installed, and was when I bought it.

    I tried again, just to be safe, but no change.
     
  6. ITguy2016 Suspended

    Joined:
    May 25, 2016
    #6
    Typically these kinds of commands do not permanently damage a system. I'm thinking the issue is something unrelated to your actions.

    Case in point. I recently purchased a dual 2.0GHz PowerMac G5. Brought it home and it worked fine. When I came back to it the next day the system would not boot. The power light flashed indicating a problem with memory. After researching I discovered it had fell victim to the well known motherboard failure. One day it worked without issue, the next no go.
     
  7. Viserion thread starter macrumors newbie

    Joined:
    Mar 25, 2015
    #7
    But would it chime if that was the case.

    I shut it off, waited a bit, and turned it on again. It went from working find, to nothing showing on the monitor, and probably keyboard/mice not working in a few minutes time.
     
  8. ITguy2016 Suspended

    Joined:
    May 25, 2016
    #8
    It does not chime. The flashing power light is misleading as it indicates there's a problem with the memory when in fact it's a failed motherboard. The memory is fine (tested in another G5 and that G5's memory was installed in the problematic system). I'm 99.9% certain the motherboard has failed (I was able to verify by pressing down on the part of the motherboard known to experience the issue and it began to boot until I released the pressure).

    I suspect your system has failed for reasons unrelated to what you were doing. In fact perhaps the problem you were trying to solve was caused by a pending failure of the system.
     
  9. Viserion thread starter macrumors newbie

    Joined:
    Mar 25, 2015
    #9
    Not entierly sure I follow you. Are you talking about your failed G5 or mine.

    Mine does chime, same sound now as when it was working.
     
  10. ITguy2016 Suspended

    Joined:
    May 25, 2016
    #10
    I was referring to mine as I thought that's what you were referring to. Now that we've clarified that I'm not saying your system has experienced the same problem as mine. I'm merely saying the problem seems unlikely to be the result of what you were doing at the time.

    The Openfirmware command you type merely tells Openfirmware to load a different image from some location. That shouldn't lead to a system failure. However since I'm not an Openfirmware expert I cannot be certain. It sounds like whatever issue you're having is unrelated to the Openfirmware commands. I'm thinking something in the system has failed and that is causing your issues.

    Did you do the obligatory pull all but the necessary parts (expansion cards, memory, hard disks) and disconnect all the external peripherals (if any)?
     
  11. Viserion thread starter macrumors newbie

    Joined:
    Mar 25, 2015
    #11
    Ah, ok.
    I understand that it only load an image from, in this case, an USB image, It's just that the timing was as it was.
    I thought maybe it could corrupt it in some way. Apparently I was wrong.

    I have taken out everything with the exeption of the harddrives. Don't think that will matter, but will try it withourt them just in case.

    It's really looking bleak for this machine.
     
  12. ITguy2016 Suspended

    Joined:
    May 25, 2016
    #12
    I doubt the command you executed would have corrupted anything. There's the possibility the file you executed may have done so. However it seems unlikely. As I am not an Openfirmware guru I cannot say if the "NVRAM" contents could become corrupted to the point the system refuses to operate.

    With all that said I think it was bad timing or the system was marginal (thus leading to the problem you described that led to your executing the OBP command in the first place). Sadly these PowerMac G5's seem to have a fairly high failure rate and I suspect it only gets worse as time marches forward. I'm bummed my dual 2.0GHz system gave up the ghost the next day (but it was only $10) and the dual 2.7GHz system I bought last Friday has a leaking (or had leaked) liquid cooling system (long handle torx drives just arrived today so something to do this weekend). I wouldn't be surprised to learn yours has failed too.
     
  13. Viserion thread starter macrumors newbie

    Joined:
    Mar 25, 2015
    #13
    Well, thanks for the help.
    I give up on this thing, as this is the second PPC, and third motherboard to fail on me so the enjoyment to money/time spent on it is just to low.
     
  14. ITguy2016 Suspended

    Joined:
    May 25, 2016
    #14
    I know the feeling! I have three PowerMac G5's...a 1.8GHz single (working fine), a dual 2.0GHz which failed the day after I got it (though I did only pay $10 for it so I was on notice something was wrong with it), and my newly acquired 2.7GHz (which is currently working but has obvious signs of LCS failure).

    I'm going to try reviving the 2.0GHz this weekend by heating the motherboard with a heat gun to see if that will reflow the solder joints. Since it's not operational I figure why not? The 2.7GHz is another issue. Trying to figure if I should leave it alone since it's working. But doing so could lead to its ultimate demise.

    Question to the group...if the heat gun doesn't work to revive it what should I do with it? Hate to send it to the recycler so maybe give it to someone who could use it for parts?
     
  15. Viserion thread starter macrumors newbie

    Joined:
    Mar 25, 2015
    #15
    Good luck with the revival.

    I took an olde pci usb card I had, and installed it, to try a last ditch attempt but no luck.

    Try to see if someone is interested it as parts, if not the thing might as well be recycled.
     

Share This Page