SBSettings causing GPS to fail to lock (3.1.2)

Discussion in 'Jailbreaks and iOS Hacks' started by fjk, Nov 17, 2009.

  1. fjk macrumors regular

    Jun 9, 2008
    I've been trying to figure out what's been causing my GPS to fail to lock. I restored and it worked fine, but it began to fail again sometime after jailbreaking. In Maps, the GPS is able to triangulate me (large blue circle) to my approximate location, but never progresses to the blinking/pulsing blue dot that indicates GPS is fixed/locked on my specific location.

    I've found a few other reports from this and other forums that some users had the same problem, as a result of SBSettings.

    I tried this (sitting outside, open sky), and immediately after uninstalling SBSettings (and re-springing), my GPS worked again (blinking/pulsing blue dot). After re-installing and re-springing, my GPS again failed to lock on.

    This is all after a practically new restore, blackra1n (same problem with pwnage tool, i tried last night), sbsettings.

    Can anyone confirm or explain? Possible solutions?
  2. fjk thread starter macrumors regular

    Jun 9, 2008

    I was able to solve my problem by deleting the toggle for location services.

    Found in:


    Re-springing after deleting the folder for location services solved my GPS issues.

    EDIT: It only seems to work immediately after re-springing. After a while it fails to work, then re-springing works again. This behavior didnt happen prior to deleting the location services toggle though. So i'm still not completely sure where to isolate the problem.
  3. OhioLefty macrumors regular

    Aug 7, 2009
    I had EXACTLY the same problem. I emailed the dev (BigBoss) of SBSettings and they said it works for them. Mine doesn't. They said it might be some other app or plugin causing my problem. :confused:

    My wife can be right beside me (identical 3GS, v3.0, not JailBroken) and her GPS apps work perfectly. Mine will also work perfectly (3GS, v3.1.2, JailBroken) if I uninstall SBSettings.

    Please let me know if you really find the problem or a fix. The only other thing I have using MobileSubstrate other than SBSettings is LockInfo.

  4. scirica macrumors 68020


    May 13, 2008
    Dallas, TX
    That seems like a very strange conflict, but it sounds like in your case it's true!
  5. CBR900RR macrumors 6502a

    Oct 11, 2008
    Middle of Pacific
    Same problem here, 3G on 3.1.2 with pwnage tool, but I did not remove SBsetting to narrow down the problem.
  6. ckong macrumors regular

    Nov 12, 2009
    My GPS works. I must not have the combo of apps that's causing this.

    I do have SBSettings installed. Locate toggle is installed but I have it off in the toggle-menu.

    I have a 3Gs 3.1.2 JB w/ blackra1n.
  7. fjk thread starter macrumors regular

    Jun 9, 2008

    Just to be clear, my GPS works in that it triangulates my approximate position. It doesn't however, lock onto my exact position and "follow" me. Are you able to get it to follow you? Thats also indicated by the pulsing/blinking blue circle that emanates from the center of the blue dot.

    In my case, it gets to this "approximate" point, and then stops, without attempting to improve to the GPS locked status.

    See the first image with the blue "shading" indicating that its an approximated triangulated position based on cell towers.

    The second image shows the clear blue pulsing circle radiating from the blue dot, as opposed to being a fixed, shaded circle.

    Attached Files:

  8. fjk thread starter macrumors regular

    Jun 9, 2008

    I deleted all toggles, then removed and reinstalled SBSettings. By doing this, the toggles settings remains empty (SBSettings toggles is usually installed alongside SBSettings, so by reinstalling SBSettings you ONLY get SBSettings and no toggles).

    The GPS works and tracks immediately. I loaded SBSettings and returned to maps, re-tracked and GPS locked on again (pulsing blue circle). Waited a few minutes and tried again, and worked again.

    I'll try re-installing the toggles a few at a time and see if any of them affect the behavior.
  9. fjk thread starter macrumors regular

    Jun 9, 2008

    Added, one by one, checking in-between each addition if Maps GPD still locked (via SSH and CyberDuck), Processes, Phone, Wifi, and Bluetooth. So far, everything still works. I am not going to test Edge, Fast notes, Location, or Brightness.

    My recommendation would be:

    Toggles folder: var/mobile/Library/SBSettings/Toggles

    1) Copy the Toggles folder to your desktop (i.e. via SSH)
    2) Delete the Toggles folder in your iPhone
    3) Uninstall SBSettings
    4) Reinstall SBSettings
    5) Test Maps + GPS lock
    6) Add ONE toggle to the Toggles folder (i.e., copy back the Phone folder)
    7) Re-spring
    8) Test again
    9) Add NEXT toggle to the Toggles folder (i.e., copy back Processes)
    9) Re-spring
    10) Test again

    ...) When finished, reboot the device and make sure Maps and GPS lock is still working.

    Alternatively: Just add back the toggles I tested and re-spring and check if it still works. Then add one bye one any additional toggles you desire.

    I'll check if this behavior/solution is maintained long-term and report back.

    Also, you can tell the behavior is immediately different because even if it doesnt obtain GPS lock right away, the approximated light-blue circle immediately becomes a smaller, more accurate circle, whereas when the behavior was "broken" it would stay a large shaded circle. That smaller, more accurate circle will lead to GPS lock (just give it a minute).

    *I also disabled auto-lock, to give it a chance to get GPS lock (was working within 1 minute or often 10 seconds usually after the "fix)

    *I have my date/time set to obtain Automatically, as some users on the apple forums reported that there are some time zone issues that cause GPS failure.
  10. OhioLefty macrumors regular

    Aug 7, 2009
    I sent another email to the dev (BigBoss) directing him to this forum. Maybe he will stop by with some suggestions or a possible fix.

    I hope we can find the problem and get it fixed, I really like SBSettings and don't want to dump it but I want the full functionality of my iPhone.
  11. ckong macrumors regular

    Nov 12, 2009
    fjk: I got the "thrumming" circle around the blue dot (2nd image). My iPhone does get the larger "cell-tower-resolved" circle (first image), but it resolves itself to the smaller one shortly thereafter.

    I tried this after work while walking to my car (three blocks away; so I was outside not inside a building or my car). The blue dot followed (slightly difficult to see it move at all since I was walking). I also tried Navigon and seems to work too.

    I gotta say, this thread got me thinking a little. I'm wondering when/if my GPS might quit. I'm fairly careful what I load on my phone but sometimes something really cool comes out and...gotta have it right?

    I'll try my GPS again today while driving and will report if it doesn't work.
  12. fjk thread starter macrumors regular

    Jun 9, 2008

    Thanks for contributing your input. It frustrates me that this problem seems to only affect some users.

    Tonight, my GPS worked sporadically. Of course, it didnt work when i needed it.

    Seems like my "solution" hasn't really completely solved anything. Im going to try to remove SBSettings altogether and see if the fix is permanent, or only temporary/sporadic.
  13. mdwsta4 macrumors 65816

    Jul 23, 2007
    i had this problem as well. didn't realize there was a fix, i just dealt with it. i ended up resetting my entire phone and for now GPS/location services work. it's only been a day so we'll see how long that lasts.
  14. fjk thread starter macrumors regular

    Jun 9, 2008
    So after a lot more frustration, i decided to get my 3GS replaced with a new one.

    Lo-and-behold, the new one, so far, works fine with SBSettings. The GPS is able to acquire and lock.

    I still maintain that my previous iphone had aberrant behavior with SBSettings installed and was partially resolved by removing it. However, it may have fallen into the iPhone category that's been reported on the forums to have sporadic GPS problems. It seems like a large number of them had this problem.
  15. Point2G macrumors newbie

    Nov 10, 2009
    Excellent tread! Thank you for sharing this info! I know location settings will drain battery so I usually only enable when needed.. On my (still) stock 3Gs i was getting battery drain on 3.1.2 in standby until i disabled location setting..
  16. chrisesposito macrumors member

    Mar 23, 2008
    unfortunately for me, the problem interaction on my 3GS is between MobileSubstrate (required for Categories) and GPS. If MobileSubstrate is installed, GPS fails to lock, but as soon as I uninstall it, GPS works again.

    Are there apps that provide Categories-like capabilities, but don't require MobileSubstrate?

  17. iPhone-power macrumors 6502a

    Nov 12, 2009
    Why don't you fire off an email to Saurik and give him all the details you can (phone model, firmware, baseband, MS version, etc)

    He is in Germany right now, but he is very responsive to issues and will fix it if it is indeed a MS problem.
  18. chrisesposito macrumors member

    Mar 23, 2008
    A good idea. Glad to here he is responsive to these things. I'll send a message off with all the details.
  19. doboy macrumors 68020

    Jul 6, 2007
    Not a permenant fix

    For anyone having GPS locking issues, try to reset the Maps app by holding down the power button (on top) while using Maps until "slide to power off" shows then hold down the home button only until it exits out of the app. Re-launch and it should be better, at least this worked for me. :rolleyes:
  20. fjk thread starter macrumors regular

    Jun 9, 2008
    As a reminder/summary:

    On my previous phone (3GS, 3.1.2):

    GPS just wouldn't work period. It triangulated but never locked. Deleting SBSettings improved the situation. But even when newly restored it was sporadically unreliable.

    On my new phone (also 3GS, 3.1.2, nothing changed except its a replacement:

    GPS works stock, works jailbroken, works with SBSettings, just plain works.
  21. leons macrumors 6502

    Apr 22, 2009
    you just got a new replacement, but got one with the old firmware (allows untethered jailbreak)?

  22. fjk thread starter macrumors regular

    Jun 9, 2008
    Correct. Being that mine is a replacement, and over 30 days, i didn't get a "new box" replacement but got a white box replacement. These have "new" externals but a "mixture" of old and new internals (read: semi-refurbished, or just plain refurbished). I guess I got lucky so that I don't have to deal with the tethered jailbreak.
  23. OhioLefty macrumors regular

    Aug 7, 2009
    Son of a .....! This worked! :eek: I've been scratching my head raw over this! It fixed the same problem with Google Earth too.

    Thank you doboy. :D :apple:
  24. doboy macrumors 68020

    Jul 6, 2007
    Glad it worked for you :D It's a bit of pain in the butt. I think there is some conflict when you install some unknown jailbreak app. It seems the Maps app just gets stuck.
  25. eaglesteve macrumors 6502

    Aug 10, 2009
    I have been battling this problem for some time too. I have a 3G and 3GS, both jailbroken and both has sbsettings installed. During one of the trips, the 3G has good GPS signal thoughout and the 3GS kept alternating between colored and grey map.

    I then did a full restore on the 3GS, and everything works perfectly once again.

    After a few days, it became cranky once again, and as you know it is a big exercise to do a full restore, I chose to just reset the location warning data using the setting application, followed by a reboot.

    This works for a while although not perfectly.

    Lately, doing the above would not zero effect on my ability to improve the signal. I just can't get a lock at all, and when I did, it was extremely unstable, and my position was all over the place with both TomTom and Sygic.

    I then did a full restore, which solves everything once again (this is full restore, jb, and sbsettings reinstalled).

    Except it lasted only two trips, and it started becoming cranky again.

    I'm about to pull out my hair over this.

    Next I'm going to uninstall SBsettings and see what happens.

    Update: removal of sbsetting does not improve the bad signal. Next, I'm going to un-jailbroken it and see whar happens.

    Performance without jailbreak
    Update: Two days now. 5 trial runs and it's perfect. Very fast position locking never experienced before. Once once did the position jumped to another street, which is accuracy never seen before. Will continue to test and report the result.
    Day 5, still running perfectly. There were brief moments of cursor being in the wrong street but very quickly it came back.

    GPS performancw when Jailbreak again
    Today (day1), I decide to rejailbreak and observe the performance under this situation. I got problem immediately with the reception but the problem is not serious yet. My cursor position went to the wrong street, my cursor seems to be lagging far behind my actual locations, and I had grey and white map again. Also, in inside my house, I get only 2 bars shown on Sygic instead of 3 when I removed the jailbreak.
    Day 2: Seems to be working perfectly today.
    Day 3: Had a couple of instance where the signal was lost but was mostly very good
    Day 4: Morning run was good. Home trip was a complete disaster. Kept getting poor GPS signal message, grey map, and location was jumping all over the place again. Did a location warning reset and reboot. Helped to get the signal, but few seconds later it was grey map and jumping cursor problem for the rest of the trip. Absolutely unuseable.
    Day 15: By today, the GPS signal has become COMPLETELY useless. Zero signal no matter how long I stay under the open sky. Not even getting weak signals. Repeat location resets followed by reboots ( and doing it 5 to 6 times in a row) does not cure the problem. Not a single GPS software (Map, TomTom, Sygic, iGO, Copilot, Ndrive, Navigon, Motion X) are getting any signal. I mean NO signal. Not even weak signal.
    Day 16 : Do a full restore, then jailbreak immediately. Observation: No longer was able to get signal from my usual position inside the house, but no problem once I go under open sky. So, it is NOT as good as if I stay away from jailbreak.

    Jailbreak DOES affect the signal.

Share This Page