Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
I've had a Schlage Sense lock for several years. Its only radio is Bluetooth (BLE), so initially, without a hub, I could only operate while my iPhone was within Bluetooth range. There is always a long delay to operate on arrival, as it takes time for the lock to re-connect via Bluetooth.

About a year or so ago, I purchased an Apple TV 4K 2nd Gen (model A2169) and set it up as my only HomeKit Home hub. It worked great. I could monitor and control the Schlage from anywhere. This meant that my phone no longer needed to be within Bluetooth range, and I no longer needed to wait for my phone to reconnect to the lock when arriving. The lock was always available and responsive to HomeKit no matter where I was located.

I setup scenes and automations that worked flawlessly thanks to the Apple TV 4K hub.

... Until I recently updated to tvOS 16.3.1 and 16.3.2

(I also previously took the optional HomeKit architecture update in 16.2 before it was pulled)

The reliability gained by installing an Apple TV 4K as a Home hub is completely gone. It's behaving just like before the Apple TV was a hub, even though it's still shown as a hub in Home.

I can turn off the Bluetooth/Wifi on my phone to simulate "not being here", or when I am not really here, the Schlage constantly reports "unreachable" through the Schlage app and "No Response" through Home app. The lock only connects via Bluetooth to my phone. When I arrive home, the lock is unresponsive until it eventually connects, same as before I had a Home hub. I have rebooted the Schlage lock by pulling out the batteries and it made no difference. I restarted the Apple TV and it worked great again, but only for a short time. Restarting the Apple TV only fixes the issue for 15 minutes or so.

EDIT: I pulled the batteries from the lock again to force a restart. Curiously, it worked great, but for only about 5 to 10 minutes and then back to "No Response" and "Unreachable".

EDIT 2: I restarted the Apple TV and it worked for about 15 minutes before back to "No Response" and "Unreachable". Putting the Apple TV closer to the door resulted in the same.

EDIT 3: It was discovered that rebooting both the router and the Apple TV restored full functionality for the remainder of the day, but never overnight. Many weeks of daily router and ATV rebooting was the routine.

EDIT 4 (final): Issue seems to be fully resolved with the tvOS 16.4 update. For the first time in 7 weeks, the remote HomeKit functionality is working again. TLDR; https://forums.macrumors.com/thread...sense-with-apple-tv-hub.2381073/post-32061624
 
Last edited:

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
Today, I logged the Apple TV out of iCloud. Then when I attempted to log back in, I was forced to add it back into HomeKit, assign a room, etc. Like my other attempts, it worked for several minutes and then the accessory went back to "No Response" and "Unreachable".
 

chabig

macrumors G4
Sep 6, 2002
11,254
8,950
It seems like the lock prefers Bluetooth with your iPhone. Perhaps if you set it up in HomeKit and then Forget the lock from your iPhone Bluetooth settings, it will stay connected to the hub.
 

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
It seems like the lock prefers Bluetooth with your iPhone. Perhaps if you set it up in HomeKit and then Forget the lock from your iPhone Bluetooth settings, it will stay connected to the hub.

Bluetooth is only the communication method between the lock and the hub, or between the lock and the phone. It never shows up under Bluetooth devices since the accessory can only be added via HomeKit or the Schlage app.
 

chabig

macrumors G4
Sep 6, 2002
11,254
8,950
I tried to look at the instructions for that lock and it wasn't very clear. I believe the lock must be connected via Bluetooth for the Schlage app to work. To my knowledge, apps can't connect to devices without those devices showing up in Settings. Maybe I'm wrong.

I also wasn't aware that a Home hub can control Bluetooth devices.
 

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
I tried to look at the instructions for that lock and it wasn't very clear. I believe the lock must be connected via Bluetooth for the Schlage app to work. To my knowledge, apps can't connect to devices without those devices showing up in Settings. Maybe I'm wrong.

This is not something you can access or will be able to see via Bluetooth settings. Everything is handled transparently via the Schlage app and/or HomeKit, AFAIK. I believe it's leveraging BLE.

I also wasn't aware that a Home hub can control Bluetooth devices.

See: https://www.schlage.com/en/home/smart-locks/schlage-sense-works-with.html

Screen Shot 2023-02-19 at 5.23.25 PM.png
Screen Shot 2023-02-19 at 5.24.08 PM.png


As far as the current problem, it's like the Home Hub is no longer able to maintain its connection to the lock beyond the first 15 minutes. Before the tvOS and iOS updates last week, I've had zero issues monitoring and using this lock remotely.
 
Last edited:

chabig

macrumors G4
Sep 6, 2002
11,254
8,950
I’m sorry you’re having problems. They could very well be caused by the update. We are in a transition period as HomeKit merges with Matter. There are architectural changes taking place in both hubs and devices that will hopefully work themselves out over time.
 

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
Today out of total frustration, I deleted the lock from HomeKit in order to start over fresh. I am thinking maybe I am the only person using a Schlage Sense with an Apple TV (16.3.2) as a Home hub who is having this problem. I approached it today as if I am starting with a new Schlage Sense.
  • I deleted the lock from HomeKit
  • Rebooted iPhone and AppleTV
  • Cannot add to HomeKit without resetting lock to factory defaults
  • Reset lock to factory defaults
  • Rebooted iPhone and AppleTV
  • Followed Schlage procedure for adding new lock to HomeKit
  • Verified Schlage firmware up to date - v4.31, no change.
  • Verified Schlage battery - 100%
  • Rebooted iPhone and AppleTV
  • Followed Schlage procedure for rebooting lock when it's "unavailable"
  • Rebooted iPhone and AppleTV
It worked as expected for about 5 minutes. Then it failed again. No remote access via HomeKit... which means there is no Home hub functionality with this device.

Surely I cannot be the only person using a Schlage Sense with an Apple TV (16.3.2) as a Home hub?!
 

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
For more than a year, my Apple TV 4K, mounted to the wall behind my TV, has been a very reliable Home hub for this Schlage Sense lock, which is only one room away.

As an experiment, I removed the Apple TV from the wall where it was previously working fine as a Home hub, and plugged it in on my kitchen countertop, just a few feet away from the Schlage lock. Well, what do ya know... it's still not working, but instead of failing after only 5 or 10 minutes, it seemed to stay connected for almost an hour.

I think something with BLE (Bluetooth Low Energy) has been hosed up by tvOS 16.3.1 or 16.3.2.
 

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
My router reboots automatically every week, and I've rebooted the Apple TV many times since this problem started.

However, I took the advice of somebody in another thread to reboot the router while the Apple TV is unplugged from power.
  • Unplugged Apple TV from power
  • Unplugged router - plugged in router
  • Waited for router to restart
  • Plugged in Apple TV power
I am presently testing it by my iPhone with BT and Wifi disabled all day. So far, issue was finally resolved!

But just wow... I hope future updates to HomeKit are more robust than this.
 
Last edited:

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
Not resolved. Solution only lasted less than a day... problem has returned.

EDIT: The above procedure needs to be repeated almost daily in order to have any remote access.
 
Last edited:

gdrisc

macrumors newbie
Mar 5, 2023
1
1
Just wanted to let you know you aren’t alone. Exactly the same setup as you. I’ve had my appletv farther than 40ft for a couple years and never had any issues. With the latest update I cannot get the lock to work when away from home. I also think it must have something to do with BLE. When my dog sitter comes over during the day to walk my dog, it seems like the device “wakes up” and sends me a notification that my lock was unlocked and relocked. But I have no control of the lock and it shows as unresponsive in the app. I have followed almost the exact same steps as you, and have regained connectivity for about a day and then lose it again. Hoping for an update to fix this sooner than later.
 
  • Love
Reactions: sparky672

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
Just wanted to let you know you aren’t alone. Exactly the same setup as you. I’ve had my appletv farther than 40ft for a couple years and never had any issues. With the latest update I cannot get the lock to work when away from home. I also think it must have something to do with BLE. When my dog sitter comes over during the day to walk my dog, it seems like the device “wakes up” and sends me a notification that my lock was unlocked and relocked. But I have no control of the lock and it shows as unresponsive in the app. I have followed almost the exact same steps as you, and have regained connectivity for about a day and then lose it again. Hoping for an update to fix this sooner than later.
Thank you for taking the time! I was wondering if I was the only one. It's also very interesting that you're getting remote status notifications and yet have no ability to control it remotely. It's like it goes to sleep, but then since it's asleep it's invisible to HomeKit so there's no way to wake it up remotely.

If different than mine, what procedure are you following to regain control?

In the last 6 days, I got it work by doing the following, but it only lasts for a day or so.
  • Force quit HomeKit and Schlage app from my iPhone. Not sure if this step matters.
  • Unplug Apple TV from power
  • Unplug router from power and wait 30 seconds or so
  • Plug in router and wait for internet connection to come back
  • Plug in Apple TV
So far this is the only thing that works. This procedure also completely failed to work for me one day and I don't know why. And today was not a good test because my router did an auto-reboot overnight, so I had to go through this procedure again this morning.

It's working right now, but only after even more fiddling around.

By "fiddling around", I mean:
  • Turn OFF iPhone Wifi and BT and open Home and Schlage apps
  • Check status, if working, STOP
  • If unresponsive, then turn ON iPhone Wifi and BT
  • Check status, should be working since BLE takes over
  • Turn OFF iPhone Wifi and BT and open Home and Schlage apps
  • If unresponsive, then turn ON iPhone Wifi and BT
  • Check status, should be working since BLE takes over
  • Turn OFF iPhone Wifi and BT and open Home and Schlage apps
  • Check again... after toggling Wifi and BT and force-quitting Home and Schlage a couple times, if it's not "unresponsive", then it's working.
 
Last edited:

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
When my dog sitter comes over during the day to walk my dog, it seems like the device “wakes up” and sends me a notification that my lock was unlocked and relocked.

I am seeing the same. When it's unresponsive, manually locking/unlocking seems to "wake it up" and it suddenly becomes responsive again in HomeKit.

So now I am rebooting Apple TV once per day. And when that fails to work, I am manually locking/unlocking to kick it back into HomeKit.

Utterly ridiculous and my most critical HomeKit device is rendered completely unreliable.
 

perezr10

macrumors 68000
Jan 12, 2014
1,990
1,457
Monroe, Louisiana
I think Schlage dropped the Sense from their HomeKit supported list. I bought a new house and Schlage no longer recognizes my Sense as a HomeKit compatible device. it says I need the Schlage Encode, the latest model.

It’s like Apple dropping the iPhone 7 when iOS 16 was released. The Sense is kind of old now. I bought my first one in 2016.

I was thinking of upgrading to the Encode any way. The instant NFC responsiveness when walking up to the door and unlocking with my Apple Watch looks awesome.
 
Last edited:

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
I think Schlage dropped the Sense from their HomeKit supported list.

I don't think so. It's still the third product on their smart-locks page:

https://www.schlage.com/en/home/products/products-smart-locks.html

And the Schlage website is still showing the Sense as HomeKit compatible:

https://www.schlage.com/en/home/smart-locks/schlage-sense-works-with.html

Screen Shot 2023-03-08 at 11.32.46 AM.png


I bought a new house and Schlage no longer recognizes my Sense as a HomeKit compatible device.

Super odd because I deleted and re-added my lock and did not get any messages like that. FWIW, the Sense needs to be added to HomeKit directly; and only then after that will it show up in the Schlage app. You cannot directly add it to the Schlage app if you want to use HomeKit. Once added to HomeKit, it shows up in the Schlage app where you can set the codes, etc.

To start over is tricky... not only do you need to delete the accessory from HomeKit, you also need to follow Schlage's procedure for resetting the lock to factory settings. While pressing & holding the "Schlage" key on the OUTSIDE keypad, remove and reconnect the battery pack. This puts it into discoverable mode for adding the lock back to HomeKit. You will also need the 8-digit HomeKit code.

Even after being deleted and re-added, it's still a HomeKit device same as it always was, except for the remote HomeKit functionality becoming unreliable since tvOS 16.3.2.


it says I need the Schlage Encode, the latest model.

What exactly is "it"? What says you need the Encode?


I was thinking of upgrading to the Encode any way.

Normally deadbolts last more than 2 or 3 years, especially ones that cost $250 - and since the Sense is still for sale, I doubt they would obsolete it for somebody buying one today. While the Encode Plus would be more reliable as it has a direct Wifi connection eliminating the need for a Home hub, the Encode Plus is in the $350+ range.

EDIT: FWIW, you would need the Encode Plus, not Encode, for HomeKit compatibility.
 
Last edited:

perezr10

macrumors 68000
Jan 12, 2014
1,990
1,457
Monroe, Louisiana
Yeah, I did the complicated start over procedure to “reset” my Sense locks. And it was when I tried to add them directly to HomeKit where I got the message from the Schlage App that the Sense was not HomeKit compatible. The website is out of date and they haven’t updated it now that HomeKit is dropped.

I was kind of wondering if this could be true until I saw your thread here. Now it confirms it for me.

Good luck, I hope I’m wrong. But I doubt you’ll ever get the Sense back on HomeKit if Schlage dropped HomeKit compatibility. But it’s not obsoleted. It still works just fine. You just can’t use HomeKit automations or when you’re away from the house.
 
Last edited:

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
And it was when I tried to add them directly to HomeKit where I got the message from the Schlage App that the Sense was not HomeKit compatible.

And yet I completely deleted mine and successfully re-added it to HomeKit just a couple days ago...

IMG_3594.PNG
IMG_3595.PNG


And here it is in the Schlage app...

IMG_3593.PNG
IMG_3592.PNG


The website is out of date and they haven’t updated it now that HomeKit is dropped.

I just called Schlage and they confirmed that Sense fully supports HomeKit and that their website is up to date. I encourage you to do the same before making bizarre claims.

Good luck, I hope I’m wrong. But I doubt you’ll ever get the Sense back on HomeKit if Schlage dropped HomeKit compatibility. But it’s not obsoleted. It still works just fine. You just can’t use HomeKit automations or when you’re away from the house.

Schlage cannot "obsolete" a lock or "drop" HomeKit without touching the lock's firmware. The Sense has been on the same firmware (v4.31) since at least 2018.

As others and myself have experienced, rebooting the Apple Home hub restores full HomeKit remote functionality. The same remote functionality that was working reliably well just until tvOS 16.3.x was released.
 
Last edited:

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
So are your locks fully functional in HomeKit again?

Yes. 100% fully functional, however, not reliable since the recent tvOS updates.

• 100% fully functional - I have full HomeKit local functionality, and full remote functionality after rebooting Apple TV and router. Every feature works as it should. Also, absolutely no issues deleting and re-adding the lock back into HomeKit.

• Not reliable - frequent Home hub rebooting is required since tvOS 16.3.x was released. Once rebooted, everything is fully functional for a while.

This thread is about how Apple's last software update broke something in the Home hub that causes the hub to periodically lose its connection to the lock.
 
Last edited:

perezr10

macrumors 68000
Jan 12, 2014
1,990
1,457
Monroe, Louisiana
Yes. 100% fully functional, however, not reliable since the recent tvOS updates.

• 100% fully functional - I have full HomeKit local functionality, and full remote functionality after rebooting Apple TV and router. Every feature works as it should. Also, absolutely no issues deleting and re-adding the lock back into HomeKit.

• Not reliable - frequent Home hub rebooting is required since tvOS 16.3.x was released. Once rebooted, everything is fully functional for a while.

This thread is about how Apple's last software update broke something in the Home hub that causes the hub to periodically lose it's connection to the lock.
That’s good to hear. I stand corrected and was hoping you’d be right. I’ll have to give my Smart Sense another try before I just buy the Encode.
 

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
That’s good to hear. I stand corrected and was hoping you’d be right. I’ll have to give my Smart Sense another try before I just buy the Encode.

As it stands, the unreliability introduced by the last tvOS updates is super inconvenient. The lock worked great today but I had to do the full reboot before I left the house.

If the next couple of Apple updates do not resolve this issue, I may have to explore more drastic options... either by switching to the Schlage Encode Plus or trying a couple Home Pods as additional hubs. From what I was reading, many people are having various HomeKit issues since 16.x came out, including the "unresponsive" accessories. If that's the case, then Schlage is not the only accessory being affected and more Apple hubs might only multiply the issue.

Another possible solution that would be cheaper than buying an Encode Plus or Home Pods, is another Apple TV 4K. That can be downgraded to the last working tvOS, maybe 16.3, with auto-updates disabled, and it can just be a temporary hub dedicated to the Schlage.

For now, I'll just wait and see if 16.4 brings any relief.
 
Last edited:

clintber

macrumors newbie
Mar 17, 2023
3
2
Same problem here! I just searched today for the umpteenth time to see if ANYONE else has had this problem as I have struggle with it for many months since I decided to install Apple's new, now aborted, Homekit architechture on my Apple TV. I had hoped that the latest updated was to clean everything up but it didn't. Now all I can hope for it that TVoS 16.4 restores the original Bluetooth function that was working flawlessly before. Schlage support is disgracefull. TOTAL SILENCE. I'm done with a company that treats it's customers that way.
 
  • Like
Reactions: sparky672

sparky672

macrumors 6502a
Original poster
Dec 17, 2004
533
251
Same problem here! I just searched today for the umpteenth time to see if ANYONE else has had this problem as I have struggle with it for many months since I decided to install Apple's new, now aborted, Homekit architechture on my Apple TV. I had hoped that the latest updated was to clean everything up but it didn't. Now all I can hope for it that TVoS 16.4 restores the original Bluetooth function that was working flawlessly before. Schlage support is disgracefull. TOTAL SILENCE. I'm done with a company that treats it's customers that way.

See if my latest reboot procedure helps you. It's not a permanent fix, and it's super inconvenient, but I'd be curious if you get the same results.

• Force quit Schlage and Home apps from your mobile devices (probably does not matter)
• Unplug Apple TV (or all Home hubs if you have more than one)
• Reboot your router by unplugging it for 15-30 seconds
• After your internet and wifi are restored, plug in Apple TV (and your other Home hubs)

Test Schlage remote functionality by first disabling wifi and bluetooth on your phone. This seems to hold for 12-24 hours.

Also to note, like the other poster, even when I have no remote access, manually operating the lock seems to wake it up and restore some remote functions, like Home notifications.

Totally convinced that the last HomeKit update screwed up how this lock works with BLE. It goes to sleep and then cannot be woken remotely, effectively killing remote access until the next reboot.
 

clintber

macrumors newbie
Mar 17, 2023
3
2
Before I buy any more smart anything I'll wait for them to have Matter or Thread at least. Thanks, sparky, I will.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.