Screensaver behavior in High Sierra

Discussion in 'macOS High Sierra (10.13)' started by Joobs333, Oct 6, 2017.

Tags:
  1. Joobs333 macrumors newbie

    Joobs333

    Joined:
    May 7, 2016
    #1
    My macbook air no longer wakes (while the screensaver is on) from a keystroke or mouse/trackpad movement, only a mouse or trackpad CLICK. Is this normal behavior for High Sierra?
     
  2. Don MC macrumors member

    Don MC

    Joined:
    Nov 25, 2010
    Location:
    Finland
    #2
    I have the same. And if it goes to sleep after a set period on screensaver, then it'll wake up from a keystroke again. So I guess it's a bug.
     
  3. Joobs333 thread starter macrumors newbie

    Joobs333

    Joined:
    May 7, 2016
    #3
    I've also noticed that the screensaver wake behavior is inconsistent; sometimes it takes two trackpad clicks or taps instead of one to wake. So yes, seems like a bug. I also use a secondary monitor.
     
  4. mikeboss macrumors 65816

    mikeboss

    Joined:
    Aug 13, 2009
    Location:
    switzerland
    #4
    same here on an iMac Late 2015, not waking from a single keystroke anymore. running High Sierra 17A405.
     
  5. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #5
    I think it's normal. I have this since Sierra.
     
  6. Joobs333 thread starter macrumors newbie

    Joobs333

    Joined:
    May 7, 2016
    #6
    I would think its normal if the behavior is consistent. However it is not, sometimes it will wake in one click, other times two. If it not a bug, its a function that runs poorly.
     
  7. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #7
    If you are using Magic Mouse (or may be even other wireless mouse), I suspect sometimes require 1st click to wake up the mouse. I won't be too surprise if there is a logic inside Magic mouse (or even on the Mac side) to save power.
     
  8. Joobs333, Oct 6, 2017
    Last edited: Oct 6, 2017

    Joobs333 thread starter macrumors newbie

    Joobs333

    Joined:
    May 7, 2016
    #8

    No, it does this with the trackpad only as well, and this behavior did not happen with earlier operating systems and my same setup.

    Update: I did some further testing with the screensaver, without the secondary display connected to my macbook air. The behavior appears to be two trackpad clicks or taps, or two primary mouse button clicks to turn off the screen saver. Moving the mouse or pressing the keypad buttons doesn't do anything. Can someone confirm if this is normal behavior for high sierra and if there is a way to modify it? thanks.
     
  9. Don MC, Oct 6, 2017
    Last edited: Oct 6, 2017

    Don MC macrumors member

    Don MC

    Joined:
    Nov 25, 2010
    Location:
    Finland
    #9
    Sierra was completely normal for me. The problem started with High Sierra. This is NOT normal.

    I too have an external display, but I have yet to try this with the external display disconnected. For me, it takes a click and a drag on the mouse for the screensaver to go away. Haven’t tried two clicks. Nothing else but my mouse will wake the computer.
    It’s a Logitech M705, if that matters.
     
  10. ZipZap macrumors 603

    Joined:
    Dec 14, 2007
  11. mikeboss macrumors 65816

    mikeboss

    Joined:
    Aug 13, 2009
    Location:
    switzerland
    #11
    strange: on my Mac Pro (Late 2013) the screen saver stops with a single keystroke or when moving the mouse. on the iMac I have to click and move the mouse.
     
  12. stomms, Nov 2, 2017
    Last edited: Nov 2, 2017

    stomms macrumors newbie

    stomms

    Joined:
    Nov 2, 2017
    Location:
    Tallinn
    #12
    Same problem On my Mac Mini 2010 with High Sierra, screensaver doesn't go off with a mouse movement, only with a click... :( And it is not fixed on 10.13.1 :(
    No such a problem on all previous verisons of MacOS (incl. Sierra) was present...
     
  13. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #13
    I got this bug back into Sierra, Mac Pro 5,1 with Magic Mouse. I though Apple changed the logic, but now seems just a bug.
     
  14. stomms macrumors newbie

    stomms

    Joined:
    Nov 2, 2017
    Location:
    Tallinn
  15. rswc90 macrumors newbie

    Joined:
    Mar 8, 2008
    Location:
    US
    #15
    My desktop has lost its ability to wake from photo screensaver with "esc" key, mouse movement or the above-mentions attempts. Also, I am now NOT able to scroll through my photos with screensaver on using the forward and backward arrow. Are there any tweaks that will take me back to Sierra behavior?
     
  16. schinji macrumors newbie

    Joined:
    May 10, 2012
    #16
    Yep, same problem here too. MacBook Pro (Retina, 13-inch, Late 2012). The trackpad will wake it, but the keyboard just makes it error beep.
     
  17. willardmccarty, Dec 30, 2017
    Last edited: Dec 30, 2017

    willardmccarty macrumors newbie

    Joined:
    Dec 30, 2017
    Location:
    London, England
    #17
    A slightly different problem. The Energy Saver on my MacBook Pro (mid 2017) running 10.13 turns both the main screen and the attached LG 5K monitor's off after a minute or so of no activity whatever the setting is (currently 15 minutes).
     
  18. mmpaovdr macrumors newbie

    Joined:
    Mar 25, 2018
    #18
    I have the same problem. For me, changing System Preferences > Mission Control > "Displays have separate Spaces" to ON seems to fix it. Does this setting affect it for anyone else too? If so, might be a bug in High Sierra, because Mission Control settings shouldn't affect screen saver, right?
     
  19. mikeboss macrumors 65816

    mikeboss

    Joined:
    Aug 13, 2009
    Location:
    switzerland
    #19
    confirmed! screen saver behavior back to normal after changing this setting in system preferences.
     
  20. stomms macrumors newbie

    stomms

    Joined:
    Nov 2, 2017
    Location:
    Tallinn
    #20
    No, doesn't work for me, still need to click mouse to stop screensaver... :(
     
  21. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #21
    This doesn't work for me. My "Displays have separate Spaces" always ON, but still need to click the mouse to wake up the screen.
    Same here
     
  22. hepcat72 macrumors newbie

    Joined:
    Apr 23, 2010
    #22
    I can confirm that setting "Displays have separate spaces" to on, logging out, & back in, fixes the problem on my late 2013 iMac. I have had this issue since installing high sierra. This issue did not occur in sierra for me.

    Furthermore, turning off "Displays have separate spaces", logging out, & back in makes the issue recur.
     
  23. stomms macrumors newbie

    stomms

    Joined:
    Nov 2, 2017
    Location:
    Tallinn
    #23
    It seems to work like it should after 10.13.4 update and "separate spaces" checked, now the screensaver stops after mouse movement. Finally! Thanks for the tip!
     
  24. randulo macrumors newbie

    Joined:
    Oct 15, 2013
    #24
    Hi all,

    I have a different problem, changes in the screensaver timeout don't get applied at all. The desktop background and the screensaver image choice do not remain after a reboot. I did a reset of NVRAM which presented a bad surprise: my SSD wasn't recognized. Fortunately, after a search I found it was because the old file system didn't recognize the new one on the SSD. After hours of updating the old 1TB drive and rebooting to High Sierra on the SSD, the screensaver stuff still didn't work. I did another NVRAM reset. The screen goes to screensaver after whatever the default is, about 15 minutes I think?

    I can see the changes I make being written to ~/Library/Preferences/ByHost/com.apple.screensaver.***serial***.plist
    so those params in that file are not being read back.

    Suggestions welcome :)
     
  25. Ache Brown macrumors newbie

    Joined:
    Apr 16, 2018
    #25
    I have the exact same problem, did you get to the bottom of it?
     

Share This Page

26 October 6, 2017