Scrolling using high CPU in Lion

Discussion in 'Mac OS X Lion (10.7)' started by kopite19, Jul 23, 2011.

  1. kopite19 macrumors regular

    Joined:
    Jun 3, 2010
    #1
    I went into Activity Monitor and my CPU usage was:

    % User: 2,74
    % System: 2.5o
    % Idle: 94.76

    I start scrolling up and down a few times and the CPU usage jumped to:

    % User: 16.45
    % System: 13.98
    % Idle: 68.57

    The processes that spike are Activity Monitor (naturally) WindowServer and Kernal Task.

    I can't remember what it was like in SL and whether this is normal, but it does seem very high cpu usage for scrolling a box...

    MBP 2010 13" C2D 2.4ghz.

    Interested to see if anyone else has this...
     
  2. nikguitar macrumors member

    Joined:
    Jul 30, 2011
    #2
    My first post. Yes I'm having the same problem straight after I have upgraded to Lion. Any solution yet?

    nik
     
  3. nikguitar macrumors member

    Joined:
    Jul 30, 2011
    #3
    It does it with all the software I have tried so far, including : finder (up to 49%), firefox 5 (up to 70% fan spins like crazy :eek:), sparrow (up to 50%), safari (up to 30%).

    Really annoyed here. I'm with a macbook pro 15-inch early 2009, 2.6ghz, 4gb ram.
    If it keeps like this I suppose I have to downgrade :mad:.

    Any thought?

    nik
     
  4. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #4
    get similar in safari

    scrolling causes safari & safari web process to each go to 25% cpu, stop scrolling it goes down again
     
  5. OldDeveloper macrumors newbie

    Joined:
    Jul 30, 2011
    Location:
    Columbus, Ohio
    #5
    Try turning off smooth scrolling and see if that helps.
     
  6. Atarikid macrumors regular

    Joined:
    May 14, 2011
    #6
    Guess I told this about a trillion times. The new overlay scrollbars are responsible of this.
    You can turn them off in the preferences/always show scrollbars.

    The overal GUI speed is about 4-5 times faster without the overlay scrollbars.
    (According Xbench) but you clearly see a differences
     
  7. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #7
    how do you turn off scrollbars ?

    with each of the 3 options, scroll bars appear when I scroll so i get the same problem

    I can only get it to not display them when I am not scrolling
     
  8. nikguitar macrumors member

    Joined:
    Jul 30, 2011
    #8
    I did it, but still finder kicks up to 68% if I scroll up and down...sigh :(
     
  9. nikguitar macrumors member

    Joined:
    Jul 30, 2011
    #9
    Unfortunately it doesn't help (in my case) :(
     
  10. JasonHB macrumors regular

    Joined:
    Jul 20, 2010
    Location:
    Warwickshire, UK
    #10
    Is doesn't matter how many times you tell us, it doesn't make it true,

    It makes no difference to the performance of my system whether they are on or off.

    It is still spiking like mad when scrolling up, down, forwards or backwards.

    Scrolling appears to be a massive resource hog at the moment.

    I am sure it will be sorted come 10.7.1 or 10.7.2

    Jason
     
  11. Infrared macrumors 68000

    Infrared

    Joined:
    Mar 28, 2007
    #11
    Some spiking is to be expected. I'm not seeing anything like 50%
    of 1 core though, if I rapidly move the mouse wheel back and forth.
     
  12. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #12
    What is your comps specs? I get about a 1-2% increase in activity when I scroll. Which is completely expected.

    Since scrolling is likely a graphics card function (smooth scrolling tends to use opengl or other hardware assisted technology) you may just have a weak graphics card.

    My specs are:

    Mac Pro 3,1
    8-core 2.8GHz Xeon
    10GB Ram
    1GB ATI 5870HD
    Samsung SSD 270 r / 270 w
     
  13. Atarikid macrumors regular

    Joined:
    May 14, 2011
    #14
    Well it is true.
    Do the test yourself with Xbench.

    You will notice the UI index is about 5 times higher with overlay scrollbars are disabled.
    It is also verified at the Appel developer program by at least 3 Apple devs.
     
  14. Icy1007 macrumors 6502a

    Icy1007

    Joined:
    Feb 26, 2011
    Location:
    Cleveland, OH
    #15
    When I scroll up and down, Safari only goes "up" to about 3%. I stop scrolling and it goes down to 0.4%. Scroll bars are set to only appear when scrolling.
     
  15. kristoffer4 macrumors 6502a

    kristoffer4

    Joined:
    Jan 17, 2006
    Location:
    Denmark
    #16
    Hopefully this will be fixed in 10.7.1 or .2..:mad:
     
  16. macewan macrumors newbie

    Joined:
    Aug 13, 2009
    #17
    Same problem with Snow Leopard

    In my case turning off smooth scrolling did the trick - just slightly.
     
  17. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #18
    And this is an issue because???
     
  18. kristoffer4 macrumors 6502a

    kristoffer4

    Joined:
    Jan 17, 2006
    Location:
    Denmark
    #19
    It uses more cpu and battery than Snow Leopard.
     
  19. nikguitar macrumors member

    Joined:
    Jul 30, 2011
    #20
    Definitely not in 10.7.1 - I have updated couple of minutes ago :mad:
     
  20. Saturn1217 macrumors 6502a

    Joined:
    Apr 28, 2008
    #21
    This was definitely also an issue in SL that just got worse in Lion.

    I never tried disabling the scroll bar overlay but disabling inertial scrolling will make things a little better. I ended up turning it off in SL for this very reason (even though I really like it but it makes my computer really hot while doing simple web browsing)

    I suspect (and I am no expert) that the rubber banding in Lion, which can't be disabled, also uses some extra cpu and this results in the higher cpu usage even with inertial scrolling turned off.

    I think this is also the reason a lot of people are complaining about lower battery in Lion. Even in SL if I am on battery I make a point to use the arrow keys instead of scrolling and it makes a big difference in battery times.

    I hope that apple can find some way to fix this (not sure what they could do...maybe hardware acceleration :confused: )

    PS I am semi-obsessive compulsive about my cpu usage. I monitor it all the time so that is how I noticed about the scrolling...:eek:
     
  21. nejc92 macrumors newbie

    Joined:
    Nov 5, 2015
    #22

Share This Page