iPhone See if this helps with your iOS 9 lag

Discussion in 'iOS 9' started by scjr, Sep 20, 2015.

  1. scjr, Sep 20, 2015
    Last edited: Sep 20, 2015

    scjr macrumors 68000

    scjr

    Joined:
    Jan 28, 2013
    #1
    Let me preface this post by saying, I didn't have an issue dealing with the jerky animations in my 6+. I was happy Safari, which I use the most, no longer crashed several times daily.

    Last night a member, FoxD mentioned turning on Reduce Transparency. I started messing around with that option and Reduce Motion. I completed the steps below and it helped tremendously!! Some folks have posted that it helped them as well.


    ***** To be clear, you're turning both these options ON from the iOS 9 default and then turning them OFF. (going back to default) *****


    "I might have stumbled upon something that gets rid of most or all of the lag. I have a 6+.

    I slid the Reduce Transparency slider to ON and messed around with my Apps, Notification Center, etc. I then set Reduce Motion to ON. Same thing, I just tooled around iOS for a bit with both ON. I then set Reduce Motion to OFF and slid Reduce Transparency to OFF and bingo, no more lag!!

    I've tried everything to get it to lag, pulling down spolight, opening tons of apps in the app switcher. I've seen that the jerky lag before, so I know what it looks like. It's much, much smoother now and dare I say fast!

    Happy days are here again! :)

    Try it out! YMMV."
     
  2. bandofbrothers macrumors 601

    bandofbrothers

    Joined:
    Oct 14, 2007
    Location:
    Uk
    #2
    As I've mentioned on a few recent previous threads I've always had those toggled On in my iPhone 6 Plus and iPad Air settings ,which is why I couldn't reproduce the lag / stutter some others were experiencing.
     
  3. scjr thread starter macrumors 68000

    scjr

    Joined:
    Jan 28, 2013
    #3
    Correct, but once turned back on to the iOS default it eliminated the lag on my 6+.
     
  4. FoxD macrumors 6502

    Joined:
    Apr 28, 2010
    #4
    Yup, it worked for me and SCJR and myself solved the lag issue. :)

    Settings-General-Accesibility-Increase Contrast-Reduce Transparency

    Super smooth again!!! Try it, it worked for my iPhone 6 Plus and my wife's. Both had major lag before.
     
  5. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #5
    Thought "what the heck" and tried this on my Min3 .....
    No joy :confused:
     
  6. FoxD macrumors 6502

    Joined:
    Apr 28, 2010
    #6
    It worked for me on my iPhone 6 Plus...my iPad Air 2 never had any lag with iOS9. I have no idea about other devices but will try it on my son's iPhone 5 when he upgrades.

    I think the main people with lag issues were using the 6 Plus.
     
  7. scjr thread starter macrumors 68000

    scjr

    Joined:
    Jan 28, 2013
    #7
    Same here. iPad Air 2 always good. 6+ was jerky.
     
  8. Jayson A macrumors 68000

    Joined:
    Sep 16, 2014
    #8
    Too scared to update... no idea when Apple will stop signing 8.4.1

    Is the delay still there when you tap an app?
     
  9. perkedel macrumors 6502a

    perkedel

    Joined:
    Dec 30, 2014
    Location:
    California
    #9
    People with lag phones, would love to see videos of this. After couple days, mine is just as fast. It could be the amount of music , video, apps, stuff you stored in the phones while spotlight searches.

    Again, videos to show the lag.
     
  10. scjr thread starter macrumors 68000

    scjr

    Joined:
    Jan 28, 2013
    #10
    No delay. Not sure if it works for everyone, so you may want to stay on 8.4.1 for now. I'm pleased with the results.
     
  11. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #11
    Wow, it actually helped on my 6+...Thanks!
     
  12. Solver macrumors 6502a

    Joined:
    Jan 6, 2004
    Location:
    Cupertino, CA
    #12
    This video compares many iPhones with 8.4.1 with the released iOS 9.0,

    iOS 8.4.1 wins the overall speed test.
     
  13. anthonymoody macrumors 68020

    Joined:
    Aug 8, 2002
    #13
    Wow this really helped on my 6+ which is running the 9.1 beta. The lag was so bad I was thinking about downgrading to 9.0 assuming the public release was better. Turns out I had Reduce Motion already On, but not Reduce Transparency. Turned that on and the effect is instantly noticeable. Seriously. Wow - thanks!
     
  14. Solver macrumors 6502a

    Joined:
    Jan 6, 2004
    Location:
    Cupertino, CA
    #14
     
  15. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #15
    The point is to turn them both on and then off...not to keep both on.
     
  16. anthonymoody macrumors 68020

    Joined:
    Aug 8, 2002
    #16
    Perhaps but I already had Reduce Motion set to ON because it helps battery life. As for the reduced transparency, I find I actually prefer it ON as in Safari it was always distracting to me. Wouldn't be surprised if this also helps with battery life marginally.
     
  17. scjr thread starter macrumors 68000

    scjr

    Joined:
    Jan 28, 2013
    #17
    You're welcome! That is so awesome! Coming from you, that means plenty!
     
  18. Solver macrumors 6502a

    Joined:
    Jan 6, 2004
    Location:
    Cupertino, CA
    #18
    I have no problem with lag on my iPad Air 2.
    But, shouldn't settings search find reduce transparency when typing in the word, "reduce"?
    That seems like a bug.
    image.png
     
  19. Paddle1 macrumors 68030

    Joined:
    May 1, 2013
    #19
    Everyone in this thread is confused, the OP is saying to turn these settings on then back off, not leave them turned on. Also I don't see a reason that doing that would make any difference.
     
  20. anthonymoody macrumors 68020

    Joined:
    Aug 8, 2002
    #20
    I noted that too on my 6+. Had to dig into the Increase Contrast settings to find it myself.

    "Confused" or not, it works either way (or did for me), and I prefer them On. As to why it works? Who knows. But it does, pretty dramatically in my case as I now no longer want to drop back to 9.0.
     
  21. scjr thread starter macrumors 68000

    scjr

    Joined:
    Jan 28, 2013
    #21
    I don't think everyone is confused. FoxD, batting1000 understood and it helped them both.

    Maybe there's a bug in these two settings that contribute to jerky animations? Not sure, but I'm pleased.
     
  22. Paddle1 macrumors 68030

    Joined:
    May 1, 2013
    #22
    FoxD made no indication that he turned the settings back off. batting1000 and anthonymoody are the only ones who have clarified that they know what you meant.
     
  23. Paddle1 macrumors 68030

    Joined:
    May 1, 2013
    #23
    I know that these settings can improve performance if left on, it's just turning them on then back off that I don't understand.
     
  24. fjarl macrumors member

    Joined:
    Sep 13, 2015
    #24
    The funny thing is that there is even more to this. Obviously, there's some kind of problem with the blurring effect used when the main content needs to be turned into a background. But it seems it's highly localised, to the home screen to be exact. Like other users my app switcher becomes super smooth with reduced transparency (6+). The thing is, it's equally smooth with transparency turned on, just not near the homescreen! In the app switcher, as long as you get away from the homescreen (you need at least 5-6 open apps to get there), it's smooth sailing, just as if transparency was turned off. So it seems it's the blurring of the home screen that is the culprit?
     
  25. anthonymoody macrumors 68020

    Joined:
    Aug 8, 2002
    #25
    This may be the case as that's where I noticed most of the problem - home screen and app switcher.
     

Share This Page