SemiTether updated, more stable, now allows Safari while Semitethered

Discussion in 'Jailbreaks and iOS Hacks' started by spacehog371, Oct 30, 2011.

  1. spacehog371 macrumors regular

    Joined:
    Dec 13, 2003
    #1
  2. mrCide macrumors member

    Joined:
    Jul 27, 2009
    #2
    I installed it today after the updates to mobilesubstrate and appsync, tests okay. phone seems to be fine but it hasn't even been a day yet.
     
  3. spacehog371 thread starter macrumors regular

    Joined:
    Dec 13, 2003
    #3
    I think it's a pretty badass solution. Semitether will definitely hold me over until I can get back to my computer for a full reboot.
     
  4. BrunoM macrumors newbie

    Joined:
    Oct 30, 2011
    #4
    I like it, but i'm still waiting for the untethered version as i want to install installous :/
     
  5. rick snagwell macrumors 68040

    rick snagwell

    Joined:
    Feb 12, 2011
    Location:
    oceanside, ca
    #5
    taboo.
     
  6. ericlin0122 macrumors member

    Joined:
    Sep 10, 2010
  7. simple20 macrumors regular

    Joined:
    Jun 26, 2010
    #7
    I was about to pull the trigger but then say the warning that its a full mobile substrate rewrite. What does that mean? Also what is appsync? Lastly I'm on 4.3.2 untethered jb with the blobs on tiny umbrella. If I do the semi-tether, I can still restore to an un-jb'd 5.0, OR 4.3.2 and reinstall the untethered JB, right?
     
  8. lokerd macrumors 6502a

    lokerd

    Joined:
    May 2, 2010
    Location:
    Beaumont
    #8
    I have two iPads and one iP4 on 4.2.1. The iP4 is not used for phone service as I have a iP4s for phone.

    So, tethered or semi tethered is fine.

    Given this, is there a clear and clean shot to update these devices to ios5 and keep the JB all along the way?

    Is there a good set of instructions anywhere for people still trying to upgrade from a JBed 4.2.1 device?

    Thanks!!
     
  9. spacehog371 thread starter macrumors regular

    Joined:
    Dec 13, 2003
    #9
    MobileSubstrate was updated yesterday, the semitether has been updated to make use of it. AppSync is program people use to sync cracked apps to their computer. If you don't use cracked apps, it doesn't affect you.

    ----------

    Only the original iPad can be jailbroken on iOS 5 right now, not the iPad 2. If you want to jailbreak an original iPad or iPhone 4, update to iOS 5 like you normally would, restore your backup and sync all of your apps, etc... and then use this tutorial:

    http://www.jailbreakstatus.com/how-to-jailbreak-with-redsn0w/
     
  10. farmermac macrumors 6502a

    Joined:
    Jul 23, 2009
    Location:
    Iowa
    #10
    am i the only person for which the semi tether package doesnt work? My iphone just hangs at the apple screen. Tried reinstalling it but no dice.
     
  11. smotheredhope macrumors regular

    Joined:
    Jan 31, 2009
    #11
    It's a shame That you are adverse to using different browsers as atomic is superior in every way.
     
  12. vtmikevt macrumors regular

    Joined:
    Oct 11, 2007
    #12
    the update leaves me with a new "app" called semitether with a white icon. I'm scared to open it. Does anyone know what this is / does?
     
  13. Eternal 28 macrumors 6502

    Joined:
    Apr 22, 2008
    #13
    Thats just the app that runs in the background to keep your iPhone in reboot mode incase of a reboot.
     
  14. spacehog371 thread starter macrumors regular

    Joined:
    Dec 13, 2003
    #14
    You have to reboot with redsn0w after you install it.
     
  15. loyalist macrumors 6502

    Joined:
    Mar 18, 2011
  16. edk macrumors regular

    Joined:
    Apr 12, 2006
    #16
    ..and if after a reboot, you still have a white icon, then just respring, and everything should be fine.
     
  17. vtmikevt macrumors regular

    Joined:
    Oct 11, 2007
    #17
    yes this will work on 4S...just open cydia and...wait, you don't have cydia? oh just jailbreak your 4S...oh there's no jailbreak for the 4S?

    I guess it doesn't work...
     
  18. spacehog371 thread starter macrumors regular

    Joined:
    Dec 13, 2003
    #18
    In my experience, the white icon doesn't mean anything. I can open it and change settings, etc. even though mine is showing as white right now. I'm sure there are others with OCD that it will annoy though.
     
  19. edk macrumors regular

    Joined:
    Apr 12, 2006
    #19
    agreed. but a simple respring via sbsettings fixes it, so why not..
     
  20. schiotz macrumors newbie

    Joined:
    Aug 22, 2011
    #20
    I don't know if it is a problem with semitether, with mobile substrate or with something else, but all icons installed through Cydia are white (not Cydia itself, though). Everything works, it is just the icons (yes, I did boot tethered). Also, respringing sometimes fixes it for a while, but rarely.
     
  21. spacehog371 thread starter macrumors regular

    Joined:
    Dec 13, 2003
    #21
    That's very odd. Have you tried restoring and using redsn0w?
     
  22. TheComposer macrumors member

    Joined:
    Oct 5, 2011
    #22
    If you guys buy an Iphone Wall Charger, you'll virtually have the device turned on every momeny so no need of reboot = Jailbroken all the time, how convenient is this?
     
  23. EvanLugh macrumors 68000

    EvanLugh

    Joined:
    Aug 29, 2007
    Location:
    Developer land
    #23
    i haven't installed it yet simply because i haven't actually restarted the device. Running the GM since it came out.
     
  24. schiotz macrumors newbie

    Joined:
    Aug 22, 2011
    #24
    I did that now. It did not help. But while fumbling with it, BibBoss tweeted 'White icons not caused by semitether. Install my "respring" from cydia and run that. It rebuilds your app cache before respringing'

    Indeed, installing that package and running it fixed the icons, but only until next respring. They then become white again. Well, I can live with that. :)

    Jakob
     
  25. sneezymarble macrumors 6502

    Joined:
    Oct 1, 2008
    #25
    Nice. I think I'll finally move to iOS5 now.
     

Share This Page