separate windows drive on mac pro without bootcamp

Discussion in 'Mac Pro' started by lilbiscuit, Apr 21, 2016.

Tags:
  1. lilbiscuit macrumors newbie

    Joined:
    Apr 7, 2016
    #1
    I have a 2009 Mac Pro with PCIE card with two SSDs in Raid0 as the OSX boot drive (El Capitan).

    Since OSX can't install bootcamp on an "external" drive, I wanted to see if I can just move my Windows 10 SSD over from my PC and install in the MP and run with it.

    So I installed rEFInd bootloader and then installed my windows SSD (after running sysprep on it while in the PC) to remove drivers etc.

    What the heck...it might work, right ??

    So ...almost....but not quite. I booted the MP and selected the windows SSD from rEFInd boot options options .... and it did start to boot windows, and in fact it looked like I was just about to get my windows login screen...... then BOOM ...reboot.

    So, I am I SOL on this setup? Or, is there a way to actually get my Windows SSD to boot?
     
  2. Synchro3 macrumors 65816

    Synchro3

    Joined:
    Jan 12, 2014
    #2
    Try to reinstall Windows from CD. It should repair the installation and make it bootable.

    You don't need a boot loader.
     
  3. lilbiscuit thread starter macrumors newbie

    Joined:
    Apr 7, 2016
    #3
    I need the bootloader because I am not using bootcamp.

    I will try the repair.....
     
  4. AidenShaw macrumors P6

    AidenShaw

    Joined:
    Feb 8, 2003
    Location:
    The Peninsula
    #4
    This is what you'll see if the Windows system was installed on a disk in legacy (ATA) mode, and you're booting in AHCI mode. A single registry entry needs to be tweaked to enable the AHCI driver. Can the MP6,1 BIOS set ATA mode on the drive?

    If the system is set to halt on bluescreen, you see a message saying "can't find system disk".
     
  5. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #5
    Bootcamp isn't a bootloader.

    Bootcamp is two things:
    1) Bootcamp Assistant in OS X, which is used mostly to prepare a partition and Windows installer. You don't need to use this. Neither did I.
    2) Bootcamp Drivers for Windows. A collection of Windows drivers to be installed on Windows. You should do this part after you get Windows booting up.

    That being said, rEFInd is pretty cool so there's no problem keeping it. I'm just saying it's not required.

    Windows cannot move easily from computer to computer like OS X can, unless you have extremely similar systems and you are exceptionally lucky. It is loading the wrong drivers. Here's a good article explaining this, and how you can try to fix the issues:
    http://www.howtogeek.com/239815/why-cant-you-move-a-windows-installation-to-another-computer/
     
  6. lilbiscuit thread starter macrumors newbie

    Joined:
    Apr 7, 2016
    #6

    The Dell machine that this came from was set to AHCI in bios, not ATA. Funny now the Dell does not even recognize this disk as a bootable disk since I ran sysprep and installed it in the MP, but MP still tries to boot it.
     
  7. lilbiscuit thread starter macrumors newbie

    Joined:
    Apr 7, 2016
    #7
    The plot thickens. I took the original SSD windows disk and cloned that to a SATA hard drive, then wiped the SSD and installed it in the MP and installed Windows 10 (via rEFInd). Win10 booted fine. So close now I can taste it...

    Then I took a proggie called Laplink PCMOVER and copied over apps and docs and stuff from the SATA (PC) to the SSD (MP)... and that took all night. This morning I came down to a MP with my old windows junk on it. BOOM - Done - right ???. But it recommended a reboot. I should have known ...

    Restarted the MP and booted Win10 and same BSOD :mad:

    Now the interesting part. I took the backed up SATA out of the Dell ...just for kicks...installed THAT disk in the MP.

    Booted right up. Go figure. But the SATA is so slooow I can't use it. And...the final irony ... the SSD now gets BSOD on the Dell PC!

    Anyone have a clue?
     
  8. AidenShaw macrumors P6

    AidenShaw

    Joined:
    Feb 8, 2003
    Location:
    The Peninsula
    #8
    What is the BSOD error code?
     
  9. lilbiscuit thread starter macrumors newbie

    Joined:
    Apr 7, 2016
    #9
    It was the same error: INACCESSIBLE_BOOT_DEVICE

    But wait...there's more!!

    So then I took the SSD and restored it's original image (the same image used to clone to the SATA drive that "just worked" in the MP). I figured now that I have the SATA that boots, I should be able to compare startup logs between the SATA and the SSD in the MP to see where THE SSD would fail.

    But this time...the SSD did NOT fail. It booted straight into Windows in the MP.

    :)o_O:confused::cool:

    THE END!
     
  10. IowaLynn macrumors 6502a

    IowaLynn

    Joined:
    Feb 22, 2015
    #10
    Drives in RAID are an issue if you installed Apple Bootcamp driver for HFS. Disable driver or install 3rd party (MacDrive?)

    Some PCIE SATAIII cards work, some you install windows while using SATAII first and move the drive to PCIe card.

    If target SSD is Samsung their Data Migration works.

    On Dell you can do install and instead of letting it restart first time, pull it and insert in your Mac to finish install if needed.

    XP941 or later is fast and bootable option with Lycom adapter.
     
  11. AidenShaw macrumors P6

    AidenShaw

    Joined:
    Feb 8, 2003
    Location:
    The Peninsula
    #11
    Think about this error - "INACCESSIBLE_BOOT_DEVICE".

    This means that partway through booting from the system disk - the system disk disappears. It obviously was accessible to get to this point, but suddenly isn't.

    This is exactly the driver registry issue that I previously mentioned. Early in booting the system switches from the generic BIOS interface to the system drive, to using the native OS drivers for the system drive.

    The "INACCESSIBLE_BOOT_DEVICE" error means that the native OS drivers have not been installed or are installed but don't have the registry entry set to "start on boot".

    If you search on that error for Intel chipsets, you'll see that there are several different drivers:
    • The legacy ATA driver
    • The more modern generic AHCI driver
    • The Intel RAID driver (several different versions, depending on the chipset)
    The legacy ATA and the AHCI driver are always present - so if you see this error it most likely means that the "start on boot" flag is not set for the AHCI driver. (If you installed Windows with AHCI enabled, the "start on boot" flag will be enabled.)

    So, while it may look like there's no pattern to what works and what doesn't -- it's really whether the "start on boot" flag in the installed Windows OS matches the BIOS setting of the system.
     

Share This Page